[ABD] th23 Autolinks - v1.2.0

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
th23
Registered User
Posts: 233
Joined: Sat Jul 03, 2004 7:36 am
Location: Germany
Contact:

Re: [RC] th23 Autolinks - v1.0.5

Post by th23 » Wed Apr 23, 2008 9:57 pm

th23 wrote:MySQL client version: 5.0.32
dlareghoe wrote:MySQL client version: 4.0.27
I think it's somehow related to the DB... can you please remove all the "collate utf-8" part(s) and try again? - Thanks!
Life is what happens...while you're busy making other plans!

User avatar
th23
Registered User
Posts: 233
Joined: Sat Jul 03, 2004 7:36 am
Location: Germany
Contact:

[RC] th23 Autolinks - Update to v1.2.0

Post by th23 » Fri Apr 25, 2008 9:35 am

It's done...next release candidate ready :-)

See first posting for download and details on v1.2.0
Life is what happens...while you're busy making other plans!

ecwpa
Registered User
Posts: 107
Joined: Thu Sep 25, 2003 2:13 am
Contact:

Re: [RC] th23 Autolinks - v1.2.0

Post by ecwpa » Fri Apr 25, 2008 10:11 am

[New feature] Automatically links user names to profiles [suggestion provided by Spaniel]
greate idea, plus you can add the group color to the username to make it look even nicer
carefull, not english speaker native here

newweb
Registered User
Posts: 8
Joined: Tue Jun 03, 2008 7:04 pm

Re: [RC] th23 Autolinks - v1.2.0

Post by newweb » Wed Jun 04, 2008 2:47 pm

This mod does not work with https link. It is work only with http link

Why ?

User avatar
aawinkler
Registered User
Posts: 17
Joined: Thu Feb 21, 2008 12:06 pm

Re: [RC] th23 Autolinks - v1.2.0

Post by aawinkler » Mon Jun 30, 2008 9:44 am

Really great mod and works like a charm!

I just have one problem with the CSS formatting - some of the links are formatted correctly (with the dotted line), some are not; even the same words in the same thread / topic / post are sometimes formatted correctly and the next time not - and I have no idea why this could happen???

EDIT: It seems that only words used in the last line (not paragraph) of the post are formatted incorrectly... so the problem only occurs if the last line of a post contains a word to be autolinked...

Everything else is handled absolutely correctly!

Any ideas on this?

Thanks a lot,

Andreas

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [RC] th23 Autolinks - v1.2.0

Post by MydnyteSyn » Wed Jul 02, 2008 10:13 am

I love this mod! Though, I have a question that's just occurred to me while adding tons of autolinks from my websites wiki so the keywords are linked automatically in posts. There's A LOT that has to be autolinked. Is there any way to set up this mod to accept categories so I can organize the links by category in the admin CP yet not have those categories affect the way the mod works?

For example: There are over 224 member pages that I need to link. There are over two hundred other pages from another category I need to link. Sometimes it's hard to remember what's already been linked as the pages of links that are already autolinked continues to grow. I'd like to be able to place the links for member pages in its own category in the autolinks admin CP, the planet information in its own, the businesses & organizations in its own, etc.

Can this be done?

Did that make sense?

User avatar
th23
Registered User
Posts: 233
Joined: Sat Jul 03, 2004 7:36 am
Location: Germany
Contact:

Re: [RC] th23 Autolinks - v1.2.0

Post by th23 » Wed Jul 02, 2008 11:50 am

Okay, after a while...time to give some feedback to you :)
Thanks for all the replies - as well the good ones (they keep me working on that) as the improvement suggestions (we always try to become the best) ;-)
ecwpa wrote:...group color to the username to make it look even nicer
That's already build in...at least the newest version on my homepage uses the group color.
newweb wrote:This mod does not work with https link. It is work only with http link
Why ?
Let me have a look into that... you mean linking a https site, right? This could be a small change, which I will put on the list for the next release. However, if it's a major change, it might comel later...
aawinkler wrote:I just have one problem with the CSS formattin...It seems that only words used in the last line (not paragraph) of the post are formatted incorrectly...
Any ideas on this?
Yes, this is because of how the posts end according to the standard phpBB CSS definition. Simply add the following line to the standard CSS...this ensures the underlining will be visible...

Code: Select all

.content {
   padding-bottom:1px;
}
MydnyteSyn wrote:...adding tons of autolinks from my websites wiki so the keywords are linked automatically in posts. ... to accept categories ...
Please bear in mind, that the way this MOD inserts links is not the fastest one (though it has other advantages). For tons of links on each page you might consider to include them already in the posts stored in the DB (which has disadvantages due to updates to the posts/links as well)

Categories :? Not planned as I see your point, but don't have the feeling yet, that's it really required for most users...however, I'll put it on the request list and there it will be, when the next round of features to be implemented will be selected.

---

Thanks again all the users of the MOD for your support in making this MOD better :)

Cheers
th23
Life is what happens...while you're busy making other plans!

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [RC] th23 Autolinks - v1.2.0

Post by MydnyteSyn » Thu Jul 03, 2008 6:13 am

Thank you for considering my suggestion/need. I've downloaded the latest version. Will this affect the links we already have autolinked? Do I just upload the new files, overwrite the old ones, and double check the file edits to upgrade?

User avatar
th23
Registered User
Posts: 233
Joined: Sat Jul 03, 2004 7:36 am
Location: Germany
Contact:

Re: [RC] th23 Autolinks - v1.2.0

Post by th23 » Thu Jul 03, 2008 8:01 am

MydnyteSyn wrote:Will this affect the links we already have autolinked? Do I just upload the new files, overwrite the old ones, and double check the file edits to upgrade?
There should be no changes in the DB structure...so just upload new files and check edits to be sure you have the latest code in every script - that should do the trick :) Sorry for not providing any upgrade instructions, but keeping those up to date for multiple MODs is a pain...
Life is what happens...while you're busy making other plans!

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [RC] th23 Autolinks - v1.2.0

Post by MydnyteSyn » Fri Jul 04, 2008 1:20 am

Terrific, thank you :)

User avatar
aawinkler
Registered User
Posts: 17
Joined: Thu Feb 21, 2008 12:06 pm

Re: [RC] th23 Autolinks - v1.2.0

Post by aawinkler » Fri Jul 04, 2008 9:35 pm

th23 wrote:Yes, this is because of how the posts end according to the standard phpBB CSS definition. Simply add the following line to the standard CSS...this ensures the underlining will be visible...

Code: Select all

.content {
   padding-bottom:1px;
}
Thanks a lot - that made the underlining visible and solved my problem!

Another thing: would it be possible to make word comparison case sensitive (best thing would be to chose for every word / phrase ;-))? That would also be very useful...

And I now get the problem that the phrases that are autolinked in a post get replaced by something like: "th23autolink_encode_start_3r5fcim6PGEgaHJlZj0iaHR0cDovL2RlLndpa2lwZWRpYS5vcmcvd2lraS9XZXN0LVN
5bmRyb20iIGNsYXNzPSJ0aDIzYXV0b2xpbmtzIiB0aXRsZT0iQXV0b2xpbmtlZCI+Qk5TPC9hPg==
th23autolink_encode_end_3r5fcim6"

The correct link is set though...??

Good work!

Andreas

net83it
Registered User
Posts: 500
Joined: Sun Jan 15, 2006 2:42 pm
Location: Sicily
Contact:

Re: [RC] th23 Autolinks - v1.2.0

Post by net83it » Sun Jul 20, 2008 9:05 am

interesting mod

i suggest you two new features

1) an option to convert into a link only the first of each keyword in the posts
2) option to configure different CSS style and title/alt tag for each keyword
they are features of the autolinks mod for phpbb2



[New feature] Automatically links user names to profiles [suggestion provided by Spaniel]

so, username in the posts are automatically linked to profiles? is it possibile to disable this feature?

User avatar
th23
Registered User
Posts: 233
Joined: Sat Jul 03, 2004 7:36 am
Location: Germany
Contact:

Re: [RC] th23 Autolinks - v1.2.0

Post by th23 » Sun Jul 27, 2008 6:34 pm

net83it wrote:i suggest you two new features
Thanks... I will put them on the list for the next release...
net83it wrote:so, username in the posts are automatically linked to profiles? is it possibile to disable this feature?
Yes, and yes...it links occurances of user names in the posts and for sure it can be disabled via the ACP.
Life is what happens...while you're busy making other plans!

mrgingles
Registered User
Posts: 96
Joined: Mon Jan 02, 2006 2:53 pm
Location: Ischia (Italy)
Contact:

Re: [RC] th23 Autolinks - v1.2.0

Post by mrgingles » Sat Nov 01, 2008 1:46 pm

Nice MOD, I'll try it as soon as possible ;)
Visit my website! http://www.techcommunity.it

MydnyteSyn
Registered User
Posts: 383
Joined: Sun Oct 07, 2007 10:02 am

Re: [RC] th23 Autolinks - v1.2.0

Post by MydnyteSyn » Sun Nov 02, 2008 12:28 am

I was just curious if the next version of this mod was being worked on? I'm in desperate need of having them convert into a link only the first of each keyword in the posts. :)

Locked

Return to “[3.0.x] Abandoned MODs”