[ABD] Reimg Image Resizer (+ lightbox) 0.0.B8

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
User avatar
DoYouSpeakWak
Registered User
Posts: 2310
Joined: Fri Jul 25, 2008 1:32 pm
Location: Island of Wak-Wak
Name: Hans Lassen
Contact:

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by DoYouSpeakWak »

This is by far the nicest resize mod iwe tryed. Easy install. Found a bug in the install file. (i think)

Code: Select all

Open: includes/acp/acp_styles.php

Find
Tip: This may be a partial find and not the whole line.
Code: Select All
'icon_back_top', 

Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.
Code: Select All
'icon_reimg_zoom_in', 'icon_reimg_zoom_out',
To me that looked more like a inline add instead of on a new line. Added it after and inline and it worked perfect.

Two questions i hope someone can help with. <

How do i edit the midsize size ? and is it posible to make the whole image clickable along with the zoom button in viewtopic. Or remove the zoom button and make the whole image work. Both would be so nice.

DYSW
Whatever you share comes back. Support the phpBB Communities
My Validated and Released Modifications
Offering paid services. 10+ years of experience with phpBB3 and as System Administrator.

TaleTN
Registered User
Posts: 121
Joined: Tue Mar 18, 2008 4:24 pm
Location: The Netherlands
Contact:

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by TaleTN »

desmoworks wrote:So this will sound ridiculous, but for some reason the parameters won't show up in my admin section. I've gone over the install twice and can't figure it out.

The mod is working on my site though? It resizes then opens the original with light box.

Any thoughts on this?
Try to purge the cache from within the ACP (on the General tab). The configuration settings should appear in the Post settings.

eman80 wrote:
dugi wrote:this mod works for the most users (including me), but foe some users no :?
maybe because differences of browsers . e.g this mod works with me on IE7 and FF3 but when I tried it on google chrome it doesn't work.
Yes, that might well be possible. However, in an unsupported browser this MOD should simply do nothing (i.e. users should still be able to view topics with images in it). By the way, I will look into Google Chrome, because it is very similar to Safari, so it probably could work (after perhaps a few adjustments).

DoYouSpeakWak wrote:Found a bug in the install file. (i think)

Code: Select all

Open: includes/acp/acp_styles.php

Find
Tip: This may be a partial find and not the whole line.
Code: Select All
'icon_back_top', 

Add after
Tip: Add these lines on a new blank line after the preceding line(s) to find.
Code: Select All
'icon_reimg_zoom_in', 'icon_reimg_zoom_out',
To me that looked more like a inline add instead of on a new line. Added it after and inline and it worked perfect.
Thanks for your feedback. :) I really did mean add a new line, because it looked nicer to me. But inline will work just as fine, and perhaps indeed is more consistent with the existing code.
DoYouSpeakWak wrote:Two questions i hope someone can help with. <

How do i edit the midsize size ?
What do you mean when you say "midsize size"?
DoYouSpeakWak wrote:and is it posible to make the whole image clickable along with the zoom button in viewtopic. Or remove the zoom button and make the whole image work. Both would be so nice.
It was suggested before that the zoom button should be an option. In the next update I am planning to make the whole image clickable if the zoom button is off (and if the image was not already linkable).

obvios
Registered User
Posts: 45
Joined: Sat Sep 13, 2008 2:34 am

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by obvios »

hi there..
need help...
i really dont know how and where to insert these file into phpmyadmin as this is my first time using phpmyadmin :cry:

Code: Select all

INSERT INTO phpbb_config (config_name, config_value) VALUES ('reimg_max_width', '640'), ('reimg_max_height', '480'), ('reimg_rel_width', '0'), ('reimg_swap_portrait', '1'), ('reimg_zoom', '_litebox');
i manage to open phpmyadmin, but i donno where to put it..

please help me.

thanks..

User avatar
Muad''Dib
Registered User
Posts: 311
Joined: Tue Jun 12, 2007 6:20 pm
Contact:

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by Muad''Dib »

Muad''Dib wrote:The only thing i could recommend, or at least want, would be a way to reserve the space on the page where the picture is going to load.

In some threads with multiple pictures, the thread keeps getting bumped down further and further when each image loads. This isnt so bad on a broadband connection. More annoying than anything to keep having to use the scroll over and over again. However if you also tend to dial-up users, the thread bumping can really be frustrating.

Could this be something i could do myself? Or would alot have to be re-written by you? I havent really looked at the code too much lately.

Thanks very much for your consideration.
TaleTN, do you have a response to this?

User avatar
leviatan21
Registered User
Posts: 2663
Joined: Fri Aug 10, 2007 7:22 am
Location: Buenos Aires, Argentina
Name: Gabriel

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by leviatan21 »

obvios wrote:hi there..
need help...
***
i manage to open phpmyadmin, but i donno where to put it..

please help me.

thanks..
[Tutorial] How to use phpMyAdmin
Excuse me for my poor English, I speak Spanish. | Image phpBB en Español

Return;
Registered User
Posts: 1
Joined: Tue Dec 09, 2008 5:22 pm

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by Return; »

TaleTN wrote:
desmoworks wrote:So this will sound ridiculous, but for some reason the parameters won't show up in my admin section. I've gone over the install twice and can't figure it out.

The mod is working on my site though? It resizes then opens the original with light box.

Any thoughts on this?
Try to purge the cache from within the ACP (on the General tab). The configuration settings should appear in the Post settings.
I have the same problem, i can't see the configuration settings of the mod, but its working really nice!
Yes, i cleared cache many times and still not seeing it.
Thnx for the mod, but any tip on how to solve my problem? :(


PS: excuse my bad english, i'm argentinian

the.ronin
Registered User
Posts: 184
Joined: Sun Oct 05, 2008 10:53 pm

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by the.ronin »

THANK YOU for this mod!!

I had been going crazy trying to find an image resizer that worked with IE6, Bord3 Portal, and NV Gallery mod. Of the ones I have tried, either it conflicted with the gallery or it broke the style in IE6 in the portal page. This mod works great with them ALL!!

Thank you very very much again!!

IBICO
Registered User
Posts: 14
Joined: Fri Dec 12, 2008 10:29 pm

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by IBICO »

What would have to be changed to make it work on other themes?
I use the IceBlue and have 3.0.4

TaleTN
Registered User
Posts: 121
Joined: Tue Mar 18, 2008 4:24 pm
Location: The Netherlands
Contact:

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by TaleTN »

Muad''Dib wrote:TaleTN, do you have a response to this?
Yes, I do: it's a very good suggestion. :P But seriously: Sorry for not responding sooner. I did read your post, but I was still thinking about it. You could add something like this to your theme's stylesheet:

Code: Select all

.reimg { width: auto; height: 480px; visibility: visible; }
You will then even see the images load again. However, once they have fully loaded, they will be resized if neccessary. The problem is that you simply can't know the dimensions of an image before it has (fully) loaded, so you have to guess. If you assume that all images will be resized, than a good guess would be the resize dimensions. Perhaps it would be nice to have an extra option in the ACP to enable/disable such a feature.

Return; wrote:I have the same problem, i can't see the configuration settings of the mod, but its working really nice!
Yes, i cleared cache many times and still not seeing it.
Thnx for the mod, but any tip on how to solve my problem? :(
If purging the cache does not help, then perhaps the problem lies in the changes in includes/acp/acp_board.php. Have you installed any other MODs? If so, then perhaps there is a conflict between the two.

the.ronin wrote:THANK YOU for this mod!!
You are very welcome. :mrgreen:

IBICO wrote:What would have to be changed to make it work on other themes?
I use the IceBlue and have 3.0.4
If IceBlue has its own template, then I don't really know. If IceBlue is just a theme and uses the prosilver or subsilver2 template, then this MOD already covers all changes.

Picool
Registered User
Posts: 19
Joined: Thu Nov 13, 2008 11:34 am

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by Picool »

Hi, your mod is very good and usefull ! But...(yes ever a but XD) i have a little problem with the image resizer, it reduce all pictures ^^, and it's a problem about resizing sign picture :

http://thefpsb.penspinning.fr/viewtopic ... 635#p25635

How can i do for resize only picture in post and not in sign ? Thanks !

User avatar
KellyBean
Registered User
Posts: 270
Joined: Wed Nov 07, 2007 3:06 pm
Location: Massachusetts
Contact:

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by KellyBean »

Works perfectly, thanks! :D
My Forum | My Design/How-to Site
Need help MODing or customizing your site? I can do it for a very reasonable fee. Contact me!

Image

desmoworks
Registered User
Posts: 3
Joined: Thu Nov 27, 2008 10:23 pm

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by desmoworks »

TaleTN wrote:
Return; wrote:I have the same problem, i can't see the configuration settings of the mod, but its working really nice!
Yes, i cleared cache many times and still not seeing it.
Thnx for the mod, but any tip on how to solve my problem? :(
If purging the cache does not help, then perhaps the problem lies in the changes in includes/acp/acp_board.php. Have you installed any other MODs? If so, then perhaps there is a conflict between the two.
I still can't get it to work. Cache purged several times and I've triple checked the acp_board.php file. I'm at a total loss... I can't figure it out!

kidfrom
Registered User
Posts: 5
Joined: Sun Oct 05, 2008 12:19 am

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by kidfrom »

Hi, I have the same problem.

I can not seems to get rid of

Code: Select all

style="overflow: hidden; max-height: none;"
above my Image? I have followed installation to a T, but can not find why this is still happening...

Any suggestions??

User avatar
COD3M4ST3R-X
Registered User
Posts: 2269
Joined: Sat Aug 02, 2008 5:47 am
Location: Lahore,Pakistan

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by COD3M4ST3R-X »

desmoworks wrote:
TaleTN wrote:
Return; wrote:I have the same problem, i can't see the configuration settings of the mod, but its working really nice!
Yes, i cleared cache many times and still not seeing it.
Thnx for the mod, but any tip on how to solve my problem? :(
If purging the cache does not help, then perhaps the problem lies in the changes in includes/acp/acp_board.php. Have you installed any other MODs? If so, then perhaps there is a conflict between the two.
I still can't get it to work. Cache purged several times and I've triple checked the acp_board.php file. I'm at a total loss... I can't figure it out!
The setting should be in ACP>General>>Board Configuration>>Post Settings at the end of the page
“Need and struggle are what excite and inspire us.”

desmoworks
Registered User
Posts: 3
Joined: Thu Nov 27, 2008 10:23 pm

Re: [BETA] Reimg Image Resizer (+ lightbox) 0.0.B8

Post by desmoworks »

COD3M4ST3R-X wrote:
desmoworks wrote:
TaleTN wrote:
Return; wrote:I have the same problem, i can't see the configuration settings of the mod, but its working really nice!
Yes, i cleared cache many times and still not seeing it.
Thnx for the mod, but any tip on how to solve my problem? :(
If purging the cache does not help, then perhaps the problem lies in the changes in includes/acp/acp_board.php. Have you installed any other MODs? If so, then perhaps there is a conflict between the two.
I still can't get it to work. Cache purged several times and I've triple checked the acp_board.php file. I'm at a total loss... I can't figure it out!
The setting should be in ACP>General>>Board Configuration>>Post Settings at the end of the page
I know as that is where I put the code... but no matter what I do it isn't showing up. Image height per post is the last thing before the code I put in... I just went back through the entire installation again and it is correct. Pretty confusing for sure...

Locked

Return to “[3.0.x] Abandoned MODs”