[ABD] Mass email HTML V 0.6.3

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
Locked
kking183
Registered User
Posts: 45
Joined: Fri Jun 01, 2007 2:50 pm

Re: [BETA] Mass email HTML

Post by kking183 »

well i just installed it on 3.0.4 with no problems :shock:

Pablo12CR
Registered User
Posts: 4
Joined: Mon Jun 30, 2008 7:47 pm

Re: [BETA] Mass email HTML

Post by Pablo12CR »

Mickroz wrote:
diastasi wrote:@ howard_hopkinso

Try to change something. It happened to me.

In ACP > Members & Groups:
Find a member, See in its settings:
Notification method: only with mail, only with jabber, both

In my forum, in some of my members (included me) the setting was "both" and could not receive message, (although with 3.0.2 all messages came to me).
When change this to "only by mail" everything fixed. The bad thing is that I have to check and change all my members settings. :roll:
you can run this sql:

Code: Select all

UPDATE phpbb_users SET user_notify_type=0

Thanks!!!

This is the solution for the problem, the mod install already finish and its working! :)

cotp
Registered User
Posts: 445
Joined: Wed Sep 14, 2005 7:34 pm
Contact:

Re: [BETA] Mass email HTML

Post by cotp »

When I try to install it I have this error:

Code: Select all

Fatal error: Function name must be a string in /home/***/domains/***.com/public_html/forum/install/index.php on line 75
my tables are named phpbb3_ and not phpbb don't know if that matters...

Can someone help me ?

Cotp

kemraj
Registered User
Posts: 46
Joined: Wed Aug 08, 2007 1:02 am
Contact:

Re: [BETA] Mass email HTML

Post by kemraj »

can some tell me how to remove the sql (database) part of this mod please

User avatar
diastasi
Registered User
Posts: 97
Joined: Thu Jul 10, 2008 10:23 am

Re: [BETA] Mass email HTML

Post by diastasi »

cotp wrote:When I try to install it I have this error:

Code: Select all

Fatal error: Function name must be a string in /home/***/domains/***.com/public_html/forum/install/index.php on line 75
my tables are named phpbb3_ and not phpbb don't know if that matters...

Can someone help me ?

Cotp
Try to install it without runing the install script. See this http://www.phpbb.com/community/viewtopi ... 5#p8135555

kemraj wrote:can some tell me how to remove the sql (database) part of this mod please
Just remove the phpbb3_mail table

kemraj
Registered User
Posts: 46
Joined: Wed Aug 08, 2007 1:02 am
Contact:

Re: [BETA] Mass email HTML

Post by kemraj »

diastasi can you give me step by step instruction please

kemraj
Registered User
Posts: 46
Joined: Wed Aug 08, 2007 1:02 am
Contact:

Re: [BETA] Mass email HTML

Post by kemraj »

don't worry i got true lol thanks again

cotp
Registered User
Posts: 445
Joined: Wed Sep 14, 2005 7:34 pm
Contact:

Re: [BETA] Mass email HTML

Post by cotp »

[quote="diastasi]
Try to install it without runing the install script. See this http://www.phpbb.com/community/viewtopi ... 5#p8135555

[/quote]
cotp wrote:
my tables are named phpbb3_ and not phpbb don't know if that matters...

Cotp

All my tables are named phpbb3_
should it be phpbb3_mail or phpbb_ mail like in the script ?

Another thing, I can't seem to find the acp mass email module in the list to install just the ACP_MASS_EMAIL (normal one) any idea why ?

I did that but it didn't change anything:
empapa wrote:
OPEN INSTALL/INDEX.PHP
DELETE FOLLOWING LINES:

Code: Select all

$sql_query = preg_replace('#phpbb_#i', $table_prefix, $table);

$remove_remarks($sql_query);

$sql_query = split_sql_file($sql_query, $delimiter);

foreach ($sql_query as $sql)
{
   $db->sql_query($sql);
}
unset($sql_query);

$error = array();
Works for me, gj =)

User avatar
diastasi
Registered User
Posts: 97
Joined: Thu Jul 10, 2008 10:23 am

Re: [BETA] Mass email HTML

Post by diastasi »

@ cotp

I think you should run in SQL the following:

Code: Select all

    CREATE TABLE IF NOT EXISTS `phpbb3_mail` (
         `id` int(11) unsigned NOT NULL auto_increment,
         `user_id` int(11) unsigned NOT NULL,
         `username` varchar(255) character set utf8 collate utf8_bin NOT NULL,
         `user_colour` varchar(6) character set utf8 collate utf8_bin NOT NULL,
         `subject` text character set utf8 collate utf8_bin NOT NULL,
         `message` text character set utf8 collate utf8_bin NOT NULL,
         `display_it` tinyint(4) unsigned NOT NULL default '0',
         `time` int(11) unsigned NOT NULL default '0',
         PRIMARY KEY  (`id`)
    ) DEFAULT CHARSET=utf8 ;
make the edits in the files as the mod says, and upload files.
Go to ACP > System > Manage modules you will find the new modules now. You must first upload all mod's files in order the new modules to be seen.

User avatar
diastasi
Registered User
Posts: 97
Joined: Thu Jul 10, 2008 10:23 am

Re: [BETA] Mass email HTML

Post by diastasi »

kemraj wrote:diastasi can you give me step by step instruction please
everything OK now ? Just going to phpmyadmin > your database.. find the phpbb_mail table, select it , scroll down and from the dropdown select "delete selected"

Rostely
Registered User
Posts: 5
Joined: Sun Aug 24, 2008 11:04 am

Re: [BETA] Mass email HTML

Post by Rostely »

After doing the instructions and going to install/index.php, I get an empty page. Is someone familiar with this problem? What shall I do?

I think instal.php only does some sql changes, isn't it? I'd be happy to get those then I'll do the changes in phpmyadmin :)

Great mod anyways! Can't wait to use it on my board. 8-)

User avatar
diastasi
Registered User
Posts: 97
Joined: Thu Jul 10, 2008 10:23 am

Re: [BETA] Mass email HTML

Post by diastasi »

do it mannually http://www.phpbb.com/community/viewtopi ... d#p8409005 and add the ACP modules mannually too, after editing and uploading files

Rostely
Registered User
Posts: 5
Joined: Sun Aug 24, 2008 11:04 am

Re: [BETA] Mass email HTML

Post by Rostely »

Thanks, but in that post a table is made as phpbb3_ while it should be phpbb_

How do I add the mod mannually to the ACP? I can't figure it out.

User avatar
Ladysarajane
Registered User
Posts: 441
Joined: Sat Feb 18, 2006 10:05 pm

Re: [BETA] Mass email HTML

Post by Ladysarajane »

If you phpBB tables are phpbb_email and it made the table is phpbb3_email it is easy to change in phpmyadmin.
BACK UP FIRST!
Go to phpmyadmin and click on your database.
Now on the left click on the table you want to rename.
When it loads, in the main panel...look at the top and click on operations.
Once that loads in the main panel....scroll a little downwards and you are going to look for Table Options
In the options (the table current name should be in the rename table text box) change the table name to the one that matches your prefix and name...if it is phpbb3_mail for example and your prefix is phpbb_ then rename the table to phpbb_mail.
Then click on the go and it should easily rename your table for you.
When all else fails, read the instructions

User avatar
diastasi
Registered User
Posts: 97
Joined: Thu Jul 10, 2008 10:23 am

Re: [BETA] Mass email HTML

Post by diastasi »

If first installing the mod change the SQL code from

Code: Select all

    CREATE TABLE IF NOT EXISTS `phpbb3_mail`
to

Code: Select all

    CREATE TABLE IF NOT EXISTS `phpbb_mail`
and run it.

As for the ACP you can add the modules manually like this:
Go ACP>System>Admin ControlPanel
On the right side you will see the ACP categories. Click at System then General (I dont remember the English words exactly cause im using Greek ACP)
There you can see at bottom a menu like the pix attached

Image

- Choose the "Create HTML mails" and press "Add Module".
- When finish you can see it appeared with a black lock icon.
- You just have to click the link "Activate" at the right to activate it.
- Do the same for "manage HTML mails"
- Delete the cache
Now the new module will appear in ACP>System>General

Locked

Return to “[3.0.x] Abandoned MODs”