[ABD] WAP Browser Style

Any abandoned MODs will be moved to this forum.

WARNING: MODs in this forum are not currently being supported or maintained by the original MOD author. Proceed at your own risk.
Forum rules
IMPORTANT: MOD Development Forum rules

WARNING: MODs in this forum are not currently being supported nor updated by the original MOD author. Proceed at your own risk.
User avatar
soundboy
Registered User
Posts: 117
Joined: Wed May 30, 2007 5:25 am
Location: Australia
Contact:

Re: [DEV] WAP Browser Style

Post by soundboy » Tue Jul 01, 2008 10:08 am

Ok.. news guys :D
Im juust wrapping up the package into one... Should take me about 15 mins. Then, im releasing a RC1. ;)

There will be a credit at the bottom of the style (this style took 3 months to do :( ) But hopefully we dont get any cheapskates :evil: :lol:

Donations will be accepted, if you donate an acceptable amount (whatever i think is acceptable), you are free to get rid of the credit at the bottom.

So.. 15 mins away! :D
Broadcasting World
Forum For Shoutcast Users, Online DJ's, Broadcasters And Podcasters!
Come Join!

User avatar
onai
Registered User
Posts: 9
Joined: Sun Jun 29, 2008 1:15 pm

Re: [DEV] WAP Browser Style

Post by onai » Tue Jul 01, 2008 10:43 am

I just revisited the demo via my laptop and noticed the username and password were stacked! Thus making me want to visit using my phone... NICE!!! very nice. Great job! I look forward to adding this for my forum.

User avatar
soundboy
Registered User
Posts: 117
Joined: Wed May 30, 2007 5:25 am
Location: Australia
Contact:

Re: [DEV] WAP Browser Style

Post by soundboy » Tue Jul 01, 2008 10:55 am

Well.. im testing it on my mates site :)
Should be happening soon. And onai, thanks for the comments on the theme. Yes i improved it thanks to your comment :)

-James
www.broadcastingworld.net
Broadcasting World
Forum For Shoutcast Users, Online DJ's, Broadcasters And Podcasters!
Come Join!

User avatar
soundboy
Registered User
Posts: 117
Joined: Wed May 30, 2007 5:25 am
Location: Australia
Contact:

Re: [RC1] WAP Browser Style

Post by soundboy » Tue Jul 01, 2008 11:12 am

The download is up :)
Ive tested it on a mates site, i recommend you test it before you put it up. There may be a few little things that need changing, like i said its just come off my forum and into a zip.

Donations accepted if you like it - Larger donations will enable you to take off my copyright! (I will pm you IF YOU ARE ALLOWED)

Thanks guys for waiting. Ive been very busy and i did this infront of work i have to do :? lol.
Enjoy
Broadcasting World
Forum For Shoutcast Users, Online DJ's, Broadcasters And Podcasters!
Come Join!

Xabi
Registered User
Posts: 460
Joined: Wed May 23, 2007 9:04 am

Re: [RC1] WAP Browser Style

Post by Xabi » Tue Jul 01, 2008 12:44 pm

Thank you, but the style does not work for me. I use SEO urls (from the phpbb-seo.com mod), and I'm getting the default style instead of the wap style when navigating to "rewritten" URLs. The original phpBB URLs work, but the SEO ones do not work. For example:

This one works (it shows the wap style):
http://www.xxx.com/search.php?style=7

But this one does not work (it shows the default style and not the wap style):
http://www.xxx.com/dj-forum-f41.html?style=7

:(

User avatar
soundboy
Registered User
Posts: 117
Joined: Wed May 30, 2007 5:25 am
Location: Australia
Contact:

Re: [RC1] WAP Browser Style

Post by soundboy » Tue Jul 01, 2008 12:54 pm

hmmm... not sure with seo. What are you using for seo? What mod?
Or is it just a mod_rewrite?

I will ry and give you support for it, but im not sure about seo.
Broadcasting World
Forum For Shoutcast Users, Online DJ's, Broadcasters And Podcasters!
Come Join!

Xabi
Registered User
Posts: 460
Joined: Wed May 23, 2007 9:04 am

Re: [RC1] WAP Browser Style

Post by Xabi » Tue Jul 01, 2008 1:43 pm

This is the SEO mod: http://downloads.phpbb-seo.com/phpbb3-s ... te-38.html

It's a mod combined with mod_rewrite rules of course.

StPaddy81
Registered User
Posts: 17
Joined: Sat Jun 28, 2008 9:06 pm

Re: [RC1] WAP Browser Style

Post by StPaddy81 » Tue Jul 01, 2008 2:38 pm

OK, is there no access to the ACP, MCP or UCP while using this mod or am I just missing something?

mahdi22
Registered User
Posts: 69
Joined: Thu Mar 06, 2008 11:33 pm
Contact:

Re: [RC1] WAP Browser Style

Post by mahdi22 » Tue Jul 01, 2008 10:33 pm

nice & thanks alot

see u forget some Code like
Attachment in topic

i do it

the correct code

Code: Select all

<!-- INCLUDE overall_header.html -->



<br clear="all" />

<div id="pagecontent">

	<table width="100%" cellspacing="1">
	<tr>
		<td align="{S_CONTENT_FLOW_BEGIN}" valign="middle" nowrap="nowrap">
		</td>
		<!-- IF TOTAL_POSTS -->
			<td class="gensmall" width="100%" align="{S_CONTENT_FLOW_END}" nowrap="nowrap"><!-- INCLUDE pagination.html --></td>
		<!-- ENDIF -->
	</tr>
	</table>



<!-- BEGIN postrow -->
	<table class="tablebg" width="100%" cellspacing="1">

		<tr>
			<th style="text-align: right;"><!-- IF not S_IS_BOT --><small><!-- IF postrow.U_REPORT --><a href="{postrow.U_REPORT}">Report</a> - <!-- ENDIF --><!-- IF postrow.U_DELETE --><a href="{postrow.U_DELETE}">Delete</a> <!-- ENDIF --></small>
							<!-- ENDIF -->
							</th>
		</tr>

	<!-- IF postrow.S_ROW_COUNT is even --><tr class="row1"><!-- ELSE --><tr class="row2"><!-- ENDIF -->

	<!-- IF postrow.S_IGNORE_POST -->
			<td class="gensmall" colspan="2" height="25" align="center"><!-- IF postrow.S_FIRST_UNREAD --><a name="unread"></a><!-- ENDIF --><a name="p{postrow.POST_ID}"></a>{postrow.L_IGNORE_POST}</td>
	<!-- ELSE -->

			<td align="center" valign="middle">
				<!-- IF postrow.S_FIRST_UNREAD --><a name="unread"></a><!-- ENDIF --><a name="p{postrow.POST_ID}"></a>
				
			</td>
		</tr>
		
		<!-- IF postrow.S_ROW_COUNT is even --><tr class="row1"><!-- ELSE --><tr class="row2"><!-- ENDIF -->


			<td valign="top">
				<table width="100%" cellspacing="5">
				<tr>
					<td>
					<!-- IF postrow.S_POST_UNAPPROVED or postrow.S_POST_REPORTED -->
						<table width="100%" cellspacing="0">
						<tr>
							<td class="gensmall"><!-- IF postrow.S_POST_UNAPPROVED --><span class="postapprove">{UNAPPROVED_IMG} <a href="{postrow.U_MCP_APPROVE}">{L_POST_UNAPPROVED}</a></span> <!-- ENDIF --> <!-- IF postrow.S_POST_REPORTED --><span class="postreported">{REPORTED_IMG} <a href="{postrow.U_MCP_REPORT}">{L_POST_REPORTED}</a></span><!-- ENDIF --></td>
						</tr>
						</table>

						<br clear="all" />
					<!-- ENDIF -->

<!-- IF postrow.U_PROFILE --><b class="postauthor"<!-- IF postrow.POST_AUTHOR_COLOUR --> style="color: {postrow.POST_AUTHOR_COLOUR}"<!-- ENDIF -->>{postrow.POST_AUTHOR}</b> <!-- ENDIF -->

<br>
						<div class="postbody">

{postrow.MESSAGE}</div>

				

				

				

					</td>
				</tr>
				</table>
			</td>
		</tr>

		<!-- IF postrow.S_ROW_COUNT is even --><tr class="row1"><!-- ELSE --><tr class="row2"><!-- ENDIF -->

			<!-- BEGIN attachment -->
							<tr>
								<!-- IF postrow.attachment.S_ROW_COUNT is even --><td class="row2"><!-- ELSE --><td class="row1"><!-- ENDIF -->{postrow.attachment.DISPLAY_ATTACHMENT}</td>
							</tr>
						<!-- END attachment -->
			<td></td>
		</tr>


	
	</table>	<br><!-- ENDIF -->
<!-- END postrow -->



	


	

	<table width="100%" cellspacing="1">
	<tr>
		<!-- IF TOTAL_POSTS -->
			<td class="gensmall" width="100%" align="{S_CONTENT_FLOW_END}" nowrap="nowrap"><!-- INCLUDE pagination.html --></td>
		<!-- ENDIF -->
	</tr>
	</table>

</div>
<br>

<!-- INCLUDE posting_qr_body.html -->


<div id="pagefooter"></div>


<!-- INCLUDE overall_footer.html -->


and Quick rep

iam use QUICK_REPLY

open posting_qr_body.html

remove all and relapsed with

Code: Select all

<!-- IF QUICK_REPLY_ALLOWED -->
<!-- DEFINE $S_SIGNATURE = TRUE -->
<!-- IF PRIME_CAPTCHA_TITLE or S_CONFIRM_CODE -->
	<!-- DEFINE $CAN_HIDE_OPTIONS = false -->
<!-- ELSE -->
	<!-- DEFINE $CAN_HIDE_OPTIONS = true -->
<!-- ENDIF -->
<script type="text/javascript">
// <![CDATA[
	var LA_TOO_FEW_CHARS	= "{LA_QUICK_REPLY_TOO_FEW_CHARS}";
	var LA_SHOW_OPTIONS		= "{LA_QUICK_REPLY_SHOW_OPTIONS}";
	var LA_HIDE_OPTIONS		= "{LA_QUICK_REPLY_HIDE_OPTIONS}";
	var LA_SHOW_QUICK_REPLY	= "{LA_QUICK_REPLY_SHOW}";
	var LA_HIDE_QUICK_REPLY	= "{LA_QUICK_REPLY_HIDE}";
	var QUICK_REPLY_COOKIE	= "{QUICK_REPLY_COOKIE_NAME}";
	<!-- IF QUICK_REPLY_POST_IDS -->
	var prime_post_ids		= [{QUICK_REPLY_POST_IDS}]; 
	<!-- IF PRIME_MULTI_QUOTE -->
	var LA_NONE_SELECTED	= "{LA_QUICK_REPLY_NO_QUOTES_SELECTED}";
	var LA_QUOTE_SELECTED	= "{LA_QUICK_REPLY_QUOTE_SELECTED}";
	<!-- ENDIF -->
	<!-- ENDIF -->

	// For editor.js
	var	form_name = 'postform';
	var	text_name = 'message';
// ]]>
</script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/editor.js" ></script>
<script type="text/javascript" src="{T_TEMPLATE_PATH}/prime_quick_reply.js" ></script>
<table width="100%" cellspacing="0" cellpadding="0">
	<tr>
		<th<!-- IF $CAN_HIDE_OPTIONS --> style="padding-right:150px;"<!-- ENDIF -->><!-- IF $CAN_HIDE_OPTIONS --><a name="toggle_quick_reply_options" id="toggle_quick_reply_options" class="down" style="float:left;cursor:pointer;font-weight:normal;display:block;width:150px;text-align:center;<!-- IF not QUICK_REPLY_SHOW_FORM -->visibility:hidden;<!-- ENDIF -->" onclick="prime_quick_reply_toggle(this);"><!-- IF QUICK_REPLY_SHOW_OPTIONS -->{L_QUICK_REPLY_HIDE_OPTIONS}<!-- ELSE -->{L_QUICK_REPLY_SHOW_OPTIONS}<!-- ENDIF --></a><!-- ENDIF --><a name="toggle_postform" id="toggle_postform" style="cursor:pointer;" onclick="prime_quick_reply_toggle(this);"><!-- IF QUICK_REPLY_SHOW_FORM -->{L_QUICK_REPLY_HIDE}<!-- ELSE -->{L_QUICK_REPLY_SHOW}<!-- ENDIF --></a> {L_QUICK_REPLY_POST_REPLY}</th>
	</tr>
</table>

<form name="postform" id="postform" method="post" action="{QUICK_REPLY_POST_ACTION}" onsubmit="return prime_quick_reply_check(this);"<!-- IF not QUICK_REPLY_SHOW_FORM --> style="display:none;"<!-- ENDIF -->>
<table class="tablebg" width="100%" cellspacing="1">
	<tr class="row1">
		<td valign="top" id="quick_reply_options" class="profile postdetails"<!-- IF not QUICK_REPLY_SHOW_OPTIONS and $CAN_HIDE_OPTIONS --> style="display:none;"<!-- ENDIF --> width="150">
		<div style="width:150px;">
			<dl>
				<!-- IF QUICK_REPLY_POST_IDS and PRIME_MULTI_QUOTE -->
				<!-- ENDIF -->
			</dl>
			<div style="margin:2px 0.5em 4px 0.5em"><div class="spacer" style="height:1px;overflow:hidden;"></div></div>
			<dl>
			</dl>
		</div>
		</td>
		<td valign="top" class="row2" width="100%">
		
			<table width="100%" cellspacing="0" cellpadding="0" border="0">
				<tr>
					<td align="center" valign="top" style="width: 100%;">
						<textarea name="message" id="message" rows="9" cols="76" tabindex="3" onchange="prime_quick_reply_quotes(this);" onselect="storeCaret(this); prime_quick_reply_quotes(this);" onclick="storeCaret(this); prime_quick_reply_quotes(this);" onkeyup="storeCaret(this); prime_quick_reply_quotes(this);" class="inputbox" style="width:662;height:93;"></textarea>
					</td>
					<!-- IF S_BBCODE_ALLOWED -->
					<td width="80" align="center" valign="top" style="display:none;" id="quick_reply_palette">
						<div style="width:80px;text-align:center;position:relative;top:-14px;">
						<script type="text/javascript">
						// <![CDATA[
							colorPalette('v', 8, 3)
							prime_quick_reply_onload(); // Needs to be located after posting_bbcodes.html, which sets window.onload
						// ]]>
						</script>
						</div>
					</td>
					<!-- ENDIF -->
			 	</tr>
			</table>
		</td>
	</tr>
<!-- IF not S_USER_LOGGED_IN -->
	<!-- IF PRIME_CAPTCHA_TITLE -->
	<tr>
		<td class="row1"><b class="genmed">{PRIME_CAPTCHA_INSTRUCTIONS}:</b></td>
		<td class="row2">{PRIME_CAPTCHA_KEY_PHRASE}<br /><input class="post" tabindex="4" name="{PRIME_CAPTCHA_FIELD_KEY_RESPONSE}" size="30" value="" type="text" />{PRIME_CAPTCHA_HIDDEN_FIELDS}</td>
	</tr>
	<!-- ENDIF -->
	<!-- IF S_CONFIRM_CODE -->
	<tr>
		<td class="row1" valign="top"><b class="genmed">{L_CONFIRM_CODE}: </b><center style="margin:0.5em auto;"><input class="post" type="text" name="confirm_code" size="8" maxlength="8" /></center><span class="gensmall">{L_CONFIRM_CODE_EXPLAIN}</span></td>
		<td class="row2" align="left">
			<input type="hidden" name="confirm_id" value="{CONFIRM_ID}" />
			{CONFIRM_IMAGE}
		</td>
	</tr>
	<!-- ENDIF -->
<!-- ENDIF -->
	<tr>
		<td class="cat" colspan="2" align="center">
			{QUICK_REPLY_HIDDEN_FIELDS}
			<input type="submit" name="preview" tabindex="6" value="{L_PREVIEW}" class="btnlite" onclick="document.getElementById('postform').action += '#preview';" />&nbsp;
			<input type="submit" name="post" tabindex="5" value="{L_SUBMIT}" class="btnmain" accesskey="s" />
		</td>
	</tr>
</table>
{S_FORM_TOKEN}
</form>
<!-- ENDIF -->
and don't forget to put
prime_quick_reply.js
editor.js
into TEMPLATE

i hope u like it plz u r great

demo : u must use your phone to see demo

http://www.ll22ll.com/wap

User avatar
soundboy
Registered User
Posts: 117
Joined: Wed May 30, 2007 5:25 am
Location: Australia
Contact:

Re: [RC1] WAP Browser Style

Post by soundboy » Wed Jul 02, 2008 6:57 am

mahdi22 wrote:What he said...
Thanks mate, i kept attachments out for the moment but feel free to use these codes from him.
Xabi wrote:This is the SEO mod: http://downloads.phpbb-seo.com/phpbb3-s ... te-38.html

It's a mod combined with mod_rewrite rules of course.
Ask the mod writer, i dont use that type of mod. If he/she doesnt respond, pm me :)
StPaddy81 wrote:OK, is there no access to the ACP, MCP or UCP while using this mod or am I just missing something?
None, firstly, this is a forum style, not a acp style. And secondly, there are deleteing abilities for mods and admins. But no mcp.

Most things that you are asking will be put in RC2 :)
Hope to see some more comments :)
Broadcasting World
Forum For Shoutcast Users, Online DJ's, Broadcasters And Podcasters!
Come Join!

User avatar
Professional
Registered User
Posts: 187
Joined: Mon Jan 21, 2008 2:40 pm

Re: [RC1] WAP Browser Style

Post by Professional » Wed Jul 02, 2008 7:44 am

hi i can't l it ;)
انجمن تخصصی نسل جدید موبایل ها
My Mobile Forum: M4P Forum
Every Thing That U Feel,Is Every Thing That I Feel.

User avatar
YirmeYah
Registered User
Posts: 2
Joined: Wed Jul 02, 2008 8:26 am
Location: Manila, Philippines
Contact:

Re: [RC1] WAP Browser Style

Post by YirmeYah » Wed Jul 02, 2008 9:43 am

my message was not posted using quick reply while using opera browser. Using my phone browser I cannot post in the quick reply because the submit button is not visible. What's wrong? Help pls.
YRMYH 6:16

mahdi22
Registered User
Posts: 69
Joined: Thu Mar 06, 2008 11:33 pm
Contact:

Re: [RC1] WAP Browser Style

Post by mahdi22 » Wed Jul 02, 2008 10:41 am

YirmeYah wrote:my message was not posted using quick reply while using opera browser. Using my phone browser I cannot post in the quick reply because the submit button is not visible. What's wrong? Help pls.
because your quick reply not compatible whit the style you can use evil quick replay

User avatar
soundboy
Registered User
Posts: 117
Joined: Wed May 30, 2007 5:25 am
Location: Australia
Contact:

Re: [RC1] WAP Browser Style

Post by soundboy » Wed Jul 02, 2008 11:12 am

YirmeYah wrote:my message was not posted using quick reply while using opera browser. Using my phone browser I cannot post in the quick reply because the submit button is not visible. What's wrong? Help pls.
Do you have Evil <3's quick reply mod installed?
Broadcasting World
Forum For Shoutcast Users, Online DJ's, Broadcasters And Podcasters!
Come Join!

User avatar
MultiMatt
Registered User
Posts: 67
Joined: Fri Dec 05, 2003 6:09 pm
Location: Louisville KY
Contact:

Re: [RC1] WAP Browser Style

Post by MultiMatt » Wed Jul 02, 2008 1:47 pm

Soundboy,
I truly appreciate your work on this! THANK YOU! I will donate to you once I get back from holiday (and have a fresh paycheck!).

A few questions/comments:
  • I think the install instructions in your read me file could use a little more clarity, particularly for the less-proficient forum owners out there! I ended up figuring it out, but it wasn't quite as intuitive as you might think it is, you advanced person, you! :)
    I imagine part of that has to do with the fact that your workload is heavy and you were simply trying to get this thing posted for us! If you'd like me to help write up something more descriptive, I'll gladly do that and shoot it to you for inclusion in the readme file.
  • I was trying to modify the header so I could have an image of the title of my forum (instead of Wap Version 10) at the top as well as the name of the forum in the page title (so it would save as Windows Mobile Louisville, not My Wap Style when someone adds it to their favorites). I did the edits to the overall_header.html file, but it they did not take. Is there another file I have to edit for that? (see, I am getting into dangerous territory here! I know just enough to cause myself trouble!) :P
Thanks!
Matt

Locked

Return to “[3.0.x] Abandoned MODs”