Youtube "FULL SCREEN" Button NOT working.. please help

Get help developing custom BBCodes or request one.
Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by Pangaea » Sat May 11, 2013 4:55 pm

http://www.youtube.com/watch?v=813WjXdU ... e=youtu.be

ALSO!!!!!! AND THIS IS VERY IMPORTANT!!

Image

this is how my forum looks on my server

Now... ok .. I want to try these out:
https://www.phpbb.com/customise/db/bbcode/media/
https://www.phpbb.com/customise/db/bbcode/video/

however it says in the install steps
1. Download bbmedia.js.zip and extract it into your forum directory
2. Go to ACP, tab "Posting", page "BBCodes"
3. Add [video] BBCode as described below
4. Add [video=] BBCode as described below
I "NEED" to know.. whenever i see people say "extract it into your forum directory"

Dose that mean:

1. Extract the zip/rar into the root of my php so the individual files are in the root. .. like...
phpbbROOT/extracted files
2 . Extract the zip/rar into the root of my php so so the files are in a subfolder called .....
phpbbROOT/bbmedia.js/extracted files
3. Extract the zip/rar into some other folder within my phpbb forum folders so the individual files are in the root of that folder.. so .. ..
phpbbROOT/someotherfolder/extracted files
4. Extract the zip/rar into some other folder within my phpbb forum so the files are in a subfolder off that folder called ....
phpbbROOT/someotherfolder/bbmedia.js/extracted files
thankyou

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by Pangaea » Sat May 11, 2013 5:14 pm

ok folks
im heading into the 4th our with this..
ive had no breaks, not so much as a cup of tea.. my whole forum development has been pretty much on hold all day because of this issues. its not 6pm.. ive pmed a forum admin with my forum admin and logsins.. i cant seem to get a response, i guess hes busy or hes gone to bed (i am awaare some people might not be on the same time zone as me)...

i am begging somone i will give ANYONE >> ANYONE at all all the logins needed to access every dam part of my forum. so you can make it display youtube videos with a working full screen button

if nobody is bother to do that or is too busy or whatever then i guess ive been left with no other alternative but to offer some some money to get this working, i dont have a whole lot of money myself, to be perfectly honest im struggling for every last penny i can get... but i can contribute something but only if its good help and it sorts my issue with the youtube posting out

User avatar
pit-PL
Registered User
Posts: 3055
Joined: Sat Nov 21, 2009 12:24 pm

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by pit-PL » Sat May 11, 2013 5:45 pm

I did not read the entire topic but try http://youtu.be/813WjXdUnew
Just for testing.

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by Pangaea » Sat May 11, 2013 5:53 pm

youtu.be ?

User avatar
pit-PL
Registered User
Posts: 3055
Joined: Sat Nov 21, 2009 12:24 pm

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by pit-PL » Sat May 11, 2013 7:16 pm

Why are you so surprised, i've seen this on your video.

User avatar
5hocK
Registered User
Posts: 3011
Joined: Wed Nov 23, 2011 7:00 pm
Location: England

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by 5hocK » Sat May 11, 2013 7:17 pm

Unzipped and uploaded into the forum directory
Image
as the instructions said
1. Download bbmedia.js.zip and extract it into your forum directory
(it doesn't say extract, create a subdirectory on the server and upload to the subdirectory ;))

Followed this guide: https://www.phpbb.com/customise/db/bbcode/media/

and got this result: http://www.headnog.com/viewtopic.php?f=15&t=20
A thread is pretty much a topic. Stop with the pedantics will ya.

Pangaea
Registered User
Posts: 191
Joined: Tue Jan 26, 2010 10:20 am

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by Pangaea » Sat May 11, 2013 7:37 pm

Hi 5hock
I am happy to report i finally got this working using this
https://www.phpbb.com/customise/db/bbcode/media/

and your informative help on where "exactly" to put mod files when people say "in forum folder"

After god knows how many hours with this.. i if anything have something better now.. this one can do other things apart from youtube. also the full screen button is now working super fine.

Thank you everyone else that helped, and im sorry ive been such a pain.. if i had got the info on where to put mod files at the start of this perhaps it woulnt have ended up like this.

anyway.. thank you every

i shall do my very best not to bother this forum again for a while... im sure i am getting tiring to help

Pangaea begs youtube not to change their page format in any way that could break this fragile win any time soon

Ademx33
Registered User
Posts: 4
Joined: Sun Nov 30, 2008 8:47 pm

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by Ademx33 » Fri Dec 13, 2013 8:44 pm

Hello, Pangaea.
I did't make any search on forum when I met your question. I don't know whether you solve your problem or not but I will share my BBcodes. There is no need to install any modbox or there is no need to write short YouTube links. Yo can add entire YouTube links. The only reason of being not Fullscreen is : <param name="allowFullScreen" value="true"></param> .. ve ... allowfullscreen="true". These words make your screen full.
I just shared a video on my site as an example. When you visit you will see that it will be fullscreen.
BBCODe

Code: Select all

[YouTube]http://www.youtube.com/watch?v={TEXT}[/YouTube]
HTML

Code: Select all

<object width="425" height="350"><param name="movie" value="http://www.youtube.com/v/{TEXT}"></param>
    <param name="allowFullScreen" value="true"></param>
    <param name="wmode" value="transparent"></param>
    <embed src="http://www.youtube.com/v/{TEXT}" type="application/x-shockwave-flash" allowfullscreen="true" wmode="transparent" width="425" height="350"></embed></object>
Helping

Code: Select all

YouTube : [YouTube]YouTube video URL[/Youtube]
Also visit:
1 : http://www.becikoyu.com/forum/viewtopic ... 89#Youtube
2 : http://www.becikoyu.com/forum/viewtopic ... 4071#p7339




---------------------------------------------------------------------------------------------------------------------------
Message No : 003

clight77
Registered User
Posts: 907
Joined: Sun May 11, 2003 11:09 pm

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by clight77 » Sun Jan 05, 2014 6:59 am

@Ademx33
Yours worked fine

Thanks
I Follow Up On My Posts.
So Should Everybody...

Ademx33
Registered User
Posts: 4
Joined: Sun Nov 30, 2008 8:47 pm

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by Ademx33 » Tue Apr 29, 2014 12:43 pm

You're welcome.
I m happy if I help.


---------------------------------------------------------------------------------------------------------------------------
Message No : 004

Xcalibr8
Registered User
Posts: 7
Joined: Thu Oct 26, 2017 12:55 am
Name: Dave

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by Xcalibr8 » Wed Nov 01, 2017 11:42 am

AndroidOS wrote:
Sat May 11, 2013 2:50 pm
The reason it isn't working is because YouTube now use a different embedding system.

Replace your HTML replacement with this:

Code: Select all

<iframe width="420" height="315" src="http://www.youtube.com/embed/{SIMPLETEXT}" frameborder="0" allowfullscreen></iframe>
And your BBCode with this:

Code: Select all

[youtube]{SIMPLETEXT}[/youtube]
Hello,
I was looking for a simple way to add youtube and tried the 1st response this guy got. Worked like a charm. i have considered other options but this is the easiest, makes a button that matches my style, and it just works. Thank you AndroidOS

User avatar
KevC
Support Team Member
Support Team Member
Posts: 67312
Joined: Fri Jun 04, 2004 10:44 am
Location: Oxford, UK
Contact:

Re: Youtube "FULL SCREEN" Button NOT working.. please help

Post by KevC » Wed Nov 01, 2017 11:44 am

Far easier to do it now with this
https://www.phpbb.com/customise/db/exte ... ediaembed/

No BBcode needed. Just paste the link and you're done.
-:|:- Support Request Template -:|:-
Image
Cheap UK Hosting
"In the land of the blind the little green bloke with no pupils is king - init!"

Post Reply

Return to “Custom BBCode Development and Requests”

Who is online

Users browsing this forum: No registered users and 4 guests