[DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
snakeman2058
Registered User
Posts: 7
Joined: Fri Jun 16, 2017 1:20 pm

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by snakeman2058 » Fri Jun 16, 2017 6:07 pm

Steve wrote:
Fri Jun 16, 2017 4:53 pm
I'm not sure what could have caused this but I will try and reproduce it.
Thank you so much! Feel free to PM me if you want any more information or anything at all. It looks like its almost there now (when viewing topics, and the settings page has populated now) but the routing isn't working at the moment. I'll try apache restart in a bit and see if that helps

Apache restart didnt change it unfortunately
Last edited by snakeman2058 on Fri Jun 16, 2017 7:58 pm, edited 1 time in total.

User avatar
Steve
Registered User
Posts: 918
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Fri Jun 16, 2017 6:26 pm

Do you have any cache system on your server? Like cloud fare etc?

snakeman2058
Registered User
Posts: 7
Joined: Fri Jun 16, 2017 1:20 pm

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by snakeman2058 » Fri Jun 16, 2017 8:03 pm

Steve wrote:
Fri Jun 16, 2017 6:26 pm
Do you have any cache system on your server? Like cloud fare etc?
Not that im aware of, its just a godaddy domain pointed directly to the external IP of the server

spiritatbay
Registered User
Posts: 49
Joined: Mon Feb 06, 2017 1:37 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by spiritatbay » Fri Jun 16, 2017 8:31 pm

spiritatbay wrote:
Mon Jun 12, 2017 2:29 pm
Steve wrote:
Mon Jun 12, 2017 4:34 am
Could you disable the editor and then preview prosilver and test to see if you still get the notice?
Disabling the editor did it. Didn't need to switch to Prosilver.
I downgraded to 1.6. Is there something I could do on my end to get back up to date? I'm now using Advanced BBCode Box (instead of WYSIWYG) as well as QuickReply Reloaded. To your knowledge, is the issue I had before present with any changes to the editor/quick reply?

User avatar
Steve
Registered User
Posts: 918
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Fri Jun 16, 2017 8:44 pm

snakeman2058 wrote:
Fri Jun 16, 2017 8:03 pm
Steve wrote:
Fri Jun 16, 2017 6:26 pm
Do you have any cache system on your server? Like cloud fare etc?
Not that im aware of, its just a godaddy domain pointed directly to the external IP of the server
Ok I will get back to you.
spiritatbay wrote:
Fri Jun 16, 2017 8:31 pm
[quote=spiritatbay post_id=14760341 time=<a href="tel:1497277771">1497277771</a> user_id=1634036]
[quote=Steve post_id=14759921 time=<a href="tel:1497242057">1497242057</a> user_id=948955]
Could you disable the editor and then preview prosilver and test to see if you still get the notice?
Disabling the editor did it. Didn't need to switch to Prosilver.
[/quote]

I downgraded to 1.6. Is there something I could do on my end to get back up to date? I'm now using Advanced BBCode Box (instead of WYSIWYG) as well as QuickReply Reloaded. To your knowledge, is the issue I had before present with any changes to the editor/quick reply?
[/quote]
The ext checks for an empty message area in the quick reply, I don't know what these other extensions do to the quick reply but it must be making the form look empty or modify the submit button.

snakeman2058
Registered User
Posts: 7
Joined: Fri Jun 16, 2017 1:20 pm

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by snakeman2058 » Mon Jun 19, 2017 5:13 pm

Steve wrote:
Fri Jun 16, 2017 8:44 pm
snakeman2058 wrote:
Fri Jun 16, 2017 8:03 pm
Steve wrote:
Fri Jun 16, 2017 6:26 pm
Do you have any cache system on your server? Like cloud fare etc?
Not that im aware of, its just a godaddy domain pointed directly to the external IP of the server
Ok I will get back to you.
No worries! Whenever you get a chance is fine, I'm sure its something I'm doing/did wrong on my side. For some extra information, I'm on debian with the following php:
PHP 5.6.30-0+deb8u1 (cli) (built: Feb 8 2017 08:50:21)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

and these extensions installed:
Activation Justification
Avatars on Memberlist
Birthday Cake
mChat
phpBB Media Embed PlugIn
PM Name Suggestions
Remove Subject from Replies
Search user topics
Simple mentions
Topic/Post Reactions

Saving your settings page no longer results in errors, so its just the routing now thats the problem. Like I said, let me know if theres anything I can do to give you more information

User avatar
Steve
Registered User
Posts: 918
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Mon Jun 19, 2017 6:40 pm

Can I have link to your site?

snakeman2058
Registered User
Posts: 7
Joined: Fri Jun 16, 2017 1:20 pm

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by snakeman2058 » Tue Jun 20, 2017 1:43 am

Steve wrote:
Mon Jun 19, 2017 6:40 pm
Can I have link to your site?
Thanks for your help! Routing issue was solved by going to ACP, general, Purge the cache

Great extension thank you!

M4rc0
Registered User
Posts: 22
Joined: Wed May 17, 2017 11:37 am

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by M4rc0 » Tue Jun 20, 2017 11:51 am

Hi Steve, I reacted to a post and the smile icon on the button became green on the post. The problem is that it became green also for all the other posts even if I didn't reacted to them. Hope it helps to know. Thanks

User avatar
Steve
Registered User
Posts: 918
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Tue Jun 20, 2017 12:22 pm

It's supposed to do that , it shows you that you can use the reaction button again in posts. 👍🏻

Smorawski
Registered User
Posts: 8
Joined: Mon Jun 19, 2017 1:55 pm

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Smorawski » Thu Jun 22, 2017 2:31 pm

Wonderful job you did there !!!

User avatar
Torlax
Registered User
Posts: 6
Joined: Sat Jun 24, 2017 12:45 pm

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Torlax » Sun Jun 25, 2017 3:32 pm

Steve wrote:
Mon May 22, 2017 11:29 am
M4rc0 wrote:
Sun May 21, 2017 10:25 am
I wanted to disable your extension waiting for your fixes, but all the users can't post if I do it.
This is the error message:

Image

If it helps
Thank you
Upload this file extracted zip archive into your extensions folder over writing any existing files, this should allow you to disable the extension. for now until I've release the next version.
http://www.steven-clark.online/phpBB3-E ... php?id=162
null2 wrote:
Mon May 22, 2017 12:19 am
Im getting an error deleting inactive users:

Image
fixed for next version.
I have exactly the same problem except that I could not even activate the extension ... The process did not go to the end. And I realize that when posting an article, I get the same error message as my neighbor above :
Erreur générale
SQL ERROR [ mysqli ]

Field 'post_reaction_data' doesn't have a default value [1364]

SQL

INSERT INTO Fo3_posts (forum_id, poster_id, icon_id, poster_ip, post_time, post_visibility, enable_bbcode, enable_smilies, enable_magic_url, enable_sig, post_username, post_subject, post_text, post_checksum, post_attachment, bbcode_bitfield, bbcode_uid, post_postcount, post_edit_locked, topic_id) VALUES (1, 5212, 0, '86.193.215.118', 1498404721, 1, 1, 1, 1, 1, '', 'Re: Bienvenue sur le nouveau forum !', '<t>test</t>', '098f6bcd4621d373cade4e832627b4f6', 0, '', 'v3krndt9', 1, 0, 37841)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1844
CALL: phpbb\db\driver\factory->sql_query()

FILE: [ROOT]/posting.php
LINE: 1415
CALL: submit_post()
I also do not delete it, despite the files you provided ... I find myself with a broken forum :-/

User avatar
Steve
Registered User
Posts: 918
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Sun Jun 25, 2017 4:10 pm

What version are you trying to test? as these errors have been fixed in 0.5.6

User avatar
Torlax
Registered User
Posts: 6
Joined: Sat Jun 24, 2017 12:45 pm

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Torlax » Sun Jun 25, 2017 7:30 pm

Steve wrote:
Sun Jun 25, 2017 4:10 pm
What version are you trying to test? as these errors have been fixed in 0.5.6
Version 0.5.6

I was able to re-establish the forum by deleting the tables related to the extension in the database (all post_reaction column).

User avatar
Steve
Registered User
Posts: 918
Joined: Tue Apr 07, 2009 7:48 pm
Location: UK ,up north!!
Name: Steven Clark
Contact:

Re: [DEV][3.2] Topic/Post Reactions(like, happy, thanks, angry)

Post by Steve » Mon Jun 26, 2017 5:13 am

The only way I can reproduce this if the last migration file was not uploaded or was not run on install.

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: Bing [Bot], Blitze, DriverGeo, fliper4o, onlyproevo, Tbot [Bot], uruguayito and 27 guests