[CDB] Lightbox

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
rrbailey89
Registered User
Posts: 248
Joined: Fri Oct 24, 2014 3:00 pm

Re: [BETA] Lightbox

Post by rrbailey89 »

rrbailey89 wrote:
VSE wrote:Lightbox extension has been updated to 1.0.0-RC1

Download: https://github.com/VSEphpbb/lightbox/releases

Notable Updates:
  • Fixed a mistake causing gallery and signature settings to fail
Right on! Thank you VSE
Make sure your using this version.
Nonprofit_Prophet
Registered User
Posts: 3
Joined: Sat Sep 05, 2015 2:19 am

Re: [RC] Lightbox

Post by Nonprofit_Prophet »

Oyabun1 wrote:
Nonprofit_Prophet wrote:I can't seem to get the extension working.
The style you are using, at least for guests, darkfx, is rubbish. It doesn't seem to have any template events included. Therefore, the code from this extension isn't being called where necessary.

You would experience similar problems with most other extensions.

Find a better style.
Unfortunately, I can't seem to find many good styles for phpBB. Is there a good repository for them?

DarkFX is pretty bad, I've had to do quite a bit of modifications to get it working. But, it's the only dark theme I've found that would look decent at all. The forums are only part of my site - the forum theme has to match the MediaWiki and WordPress themes. I'd like to have Lightbox, but if it means going with prosilver or something, then I'll have to go without.

Thanks for the help!
User avatar
MattF
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 5352
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [RC] Lightbox

Post by MattF »

Nonprofit_Prophet wrote:I can't seem to get the extension working. I don't have any other extensions installed, and I'm on phpBB 3.1.5. I did get it installed, and I can change the board settings. Here's a screenshot:
Image

Here's a link to my forum (a page with both img tags and image attachments):
http://mythosmc.com/f/viewtopic.php?f=8&t=2&p=12

The 1px setting is intentional. I want every image the user clicks (well, every posted image and image attachment) to appear in Lightbox so that they see how it works more quickly. I tried other sizes as well, though, and they don't work.

I tried clearing my cache, tried changing settings, nothing works. The images simply don't resize.
That style you are using is missing everything needed to make this extension (and probably others as well) work.
Formerly known as VSEMy ExtensionsPlease do not PM me for support.
MarieNatalie
Registered User
Posts: 46
Joined: Tue May 05, 2015 1:19 pm
Location: Athens Greece
Name: Maria

Re: [RC] Lightbox

Post by MarieNatalie »

gerger wrote:I have EXACT the same problem with PROSILVER
me too :oops:

New version 1.0.0-RC1 doesn't resize the images
User avatar
MattF
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 5352
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [RC] Lightbox

Post by MattF »

MarieNatalie wrote:
gerger wrote:I have EXACT the same problem with PROSILVER
me too :oops:

New version 1.0.0-RC1 doesn't resize the images
Yes it does. http://forum.mattfriedman.me/viewtopic.php?f=8&t=1587
You have other problems you'll need to investigate and figure out and report what's wrong. Or show a link.
Formerly known as VSEMy ExtensionsPlease do not PM me for support.
User avatar
Hippie459MN
Registered User
Posts: 962
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [RC] Lightbox

Post by Hippie459MN »

Newest version (1.0.0-RC1) is working perfect here for me using this style ( viewtopic.php?f=476&t=2322466 ) as well as Prosilver.

Im sure this has been asked but any plans to get this to work board wide with images? Say with like Pages extension ( viewtopic.php?f=536&t=2270066 )
User avatar
MattF
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 5352
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [RC] Lightbox

Post by MattF »

Hippie459MN wrote:Im sure this has been asked but any plans to get this to work board wide with images? Say with like Pages extension ( viewtopic.php?f=536&t=2270066 )
It works on any image in the board if it has the "postimage" class.

It already works with the Pages extension just fine too: http://forum.mattfriedman.me/page/lightbox
Formerly known as VSEMy ExtensionsPlease do not PM me for support.
rrbailey89
Registered User
Posts: 248
Joined: Fri Oct 24, 2014 3:00 pm

Re: [RC] Lightbox

Post by rrbailey89 »

VSE wrote:
Hippie459MN wrote:Im sure this has been asked but any plans to get this to work board wide with images? Say with like Pages extension ( viewtopic.php?f=536&t=2270066 )
It works on any image in the board if it has the "postimage" class.

It already works with the Pages extension just fine too: http://forum.mattfriedman.me/page/lightbox
I wonder does phpbb gallery use postimage class? It does not seem to work with that.

although... I do think that phpbb gallery is completely different in how it operates.
User avatar
Hippie459MN
Registered User
Posts: 962
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [RC] Lightbox

Post by Hippie459MN »

VSE wrote:It works on any image in the board if it has the "postimage" class.

It already works with the Pages extension just fine too: http://forum.mattfriedman.me/page/lightbox
Well would you look at that. It does work. Sweet! Thank you much. :D

Think the reason it didnt before was I didnt have an image size set in the ACP when I checked it. Had a moment. lol
User avatar
optimusvault
Registered User
Posts: 108
Joined: Tue Jul 28, 2015 2:51 am
Name: Aaron

Re: [RC] Lightbox

Post by optimusvault »

Does this work for attachments?
Cheers,
Aaron
User avatar
MattF
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 5352
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [RC] Lightbox

Post by MattF »

optimusvault wrote:Does this work for attachments?
Yes.
Formerly known as VSEMy ExtensionsPlease do not PM me for support.
User avatar
optimusvault
Registered User
Posts: 108
Joined: Tue Jul 28, 2015 2:51 am
Name: Aaron

Re: [RC] Lightbox

Post by optimusvault »

I've got Create thumbnail turned on. I'm having a feeling that that is why attachments are not showing up in a lightbox?
Cheers,
Aaron
User avatar
MattF
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 5352
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [RC] Lightbox

Post by MattF »

optimusvault wrote:I've got Create thumbnail turned on. I'm having a feeling that that is why attachments are not showing up in a lightbox?
Thumbnailed attachments work just fine, but only if they are bigger than the lightbox setting. If they're smaller they will be ignored.

And of course since thumbnails are made at the time of posting, so old posts with thumbs created at a setting even smaller than the current thumbnail or lightbox size will be ignored too.

I always say for best results, set the Lightbox and attachment thumbnail sizes to the same value.
Formerly known as VSEMy ExtensionsPlease do not PM me for support.
Nully
Registered User
Posts: 453
Joined: Thu Jan 29, 2009 10:11 pm
Location: France
Contact:

Re: [BETA] Lightbox

Post by Nully »

Nully wrote: Anyway it works well except for two pictures which are (width) 1 200px × (height) 1 800px
I made a test here:
http://forum.mattfriedman.me/viewtopic. ... 1689#p1689

it works.
Do you have an idea why it does not in my forum?
Only with this picture there is a problem!
MarieNatalie
Registered User
Posts: 46
Joined: Tue May 05, 2015 1:19 pm
Location: Athens Greece
Name: Maria

Re: [RC] Lightbox

Post by MarieNatalie »

VSE wrote:
MarieNatalie wrote:
gerger wrote:I have EXACT the same problem with PROSILVER
me too :oops:

New version 1.0.0-RC1 doesn't resize the images
Yes it does. http://forum.mattfriedman.me/viewtopic.php?f=8&t=1587
You have other problems you'll need to investigate and figure out and report what's wrong. Or show a link.
Thanks for the answer Matt but i don't have the knowledge to find out what is happening.
I delete 1.0.0-RC1 and installed again 1.0.0-b4 version...and is working like a charm.
I don't know what I could say :|
Locked

Return to “Extensions in Development”