[DEV] Post Love

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Rainermex
Registered User
Posts: 24
Joined: Wed Feb 11, 2009 9:25 pm

Re: Possible fix to the X problem

Post by Rainermex » Fri Aug 02, 2019 3:58 pm

jefmcg wrote:
Sat Jul 13, 2019 1:16 pm
Yesterday I updated to the latest version of this extension, and it stopped working! I got the "X" instead of the hearts. I tried to roll it back and it broke my whole forum because the database had changed. Luckily I had a backup of the DB from just before the I upgraded, so I was able to get everything back the way it had been in a few minutes.

So then, the fix to the X problem. NOTE: I HAVEN"T TESTED THIS. You'll have to delete the data - all your previous histories of likes. If you don't want to do that, then you either need to have a backup of your DB from when it was last working or reverse engineer the DB changes. So this fix is really for those who have never had it working.

Steps
  1. Backup your database
  2. Disable the extension
  3. Delete the extension data
  4. Download the version of the extension that I downloaded in August. https://github.com/satanasov/postlove/t ... 426b9c0435 If you open this on your phone, you will need to go to the bottom of the page and click "Desktop version"
  5. Replace the version in your ext folder with this version
  6. Enable it
  7. Come back here to say it works, or to tell everyone that it's still broken and that I am an idiot.
Hi,

I just installed the Post Love extension and got the X.

OK, I back up my database and then I make the steps as listed.

Could it be that I need to restore the database or for what do I need to make a backup ?

Thank You Rainer

Rainermex
Registered User
Posts: 24
Joined: Wed Feb 11, 2009 9:25 pm

Re: Possible fix to the X problem

Post by Rainermex » Fri Aug 02, 2019 4:19 pm

Rainermex wrote:
Fri Aug 02, 2019 3:58 pm
jefmcg wrote:
Sat Jul 13, 2019 1:16 pm
Yesterday I updated to the latest version of this extension, and it stopped working! I got the "X" instead of the hearts. I tried to roll it back and it broke my whole forum because the database had changed. Luckily I had a backup of the DB from just before the I upgraded, so I was able to get everything back the way it had been in a few minutes.

So then, the fix to the X problem. NOTE: I HAVEN"T TESTED THIS. You'll have to delete the data - all your previous histories of likes. If you don't want to do that, then you either need to have a backup of your DB from when it was last working or reverse engineer the DB changes. So this fix is really for those who have never had it working.

Steps
  1. Backup your database
  2. Disable the extension
  3. Delete the extension data
  4. Download the version of the extension that I downloaded in August. https://github.com/satanasov/postlove/t ... 426b9c0435 If you open this on your phone, you will need to go to the bottom of the page and click "Desktop version"
  5. Replace the version in your ext folder with this version
  6. Enable it
  7. Come back here to say it works, or to tell everyone that it's still broken and that I am an idiot.
Hi,

I just installed the Post Love extension and got the X.

OK, I back up my database and then I make the steps as listed.

Could it be that I need to restore the database or for what do I need to make a backup ?

Thank You Rainer
HI,

Problem solved. It is working now.

How do I change the read heart for any other image ?

Thank You Rainer

User avatar
janus_zonstraal
Registered User
Posts: 3723
Joined: Sat Aug 30, 2014 1:30 pm

Re: [DEV] Post Love

Post by janus_zonstraal » Fri Aug 02, 2019 5:20 pm

Search for the image in the extension files and place your image there with the same name and dimensions.
Sorry! My English is bat ;) !!!

Rainermex
Registered User
Posts: 24
Joined: Wed Feb 11, 2009 9:25 pm

Re: [DEV] Post Love

Post by Rainermex » Fri Aug 02, 2019 6:25 pm

janus_zonstraal wrote:
Fri Aug 02, 2019 5:20 pm
Search for the image in the extension files and place your image there with the same name and dimensions.
Hi,

Thank You. I thought one might use a different name. I searched and searched trying to find where he specifies the image to use.

regards Rainer

User avatar
janus_zonstraal
Registered User
Posts: 3723
Joined: Sat Aug 30, 2014 1:30 pm

Re: [DEV] Post Love

Post by janus_zonstraal » Fri Aug 02, 2019 6:39 pm

Did you look in the image folder of the extension?
https://github.com/satanasov/postlove/t ... ter/images
Sorry! My English is bat ;) !!!

Rainermex
Registered User
Posts: 24
Joined: Wed Feb 11, 2009 9:25 pm

Re: [DEV] Post Love

Post by Rainermex » Fri Aug 02, 2019 11:30 pm

janus_zonstraal wrote:
Fri Aug 02, 2019 6:39 pm
Did you look in the image folder of the extension?
https://github.com/satanasov/postlove/t ... ter/images
Hi,

Yes I found the red heart but is there no way to specify somewhere if to use the red heart or any other image ?

Will just get another image and exchange the red heart with it.

regards Rainer

vtmp
Registered User
Posts: 1
Joined: Sun Aug 11, 2019 3:45 pm

Re: [DEV] Post Love

Post by vtmp » Sun Aug 11, 2019 3:51 pm

Are there any permissions associated with this extension? It appears not, but hoping to confirm.

I have one user that is reporting they are unable to view and use this extension, while other users in the same group are able to. This user has cleared their cache, deleted cookies, logged in/out, etc. When opening the forum in an incognito window, they are able to see the "Most Liked Posts" section, but it disappears (along with the likes functionality) once they log in.

Any other suggestions?

User avatar
GoBieN
Registered User
Posts: 543
Joined: Fri Mar 05, 2004 5:22 pm
Location: Belgium
Contact:

Re: [DEV] Post Love

Post by GoBieN » Sun Aug 25, 2019 7:39 pm

Yes there are permissions (user or group).

mkschn
Registered User
Posts: 1
Joined: Tue Aug 27, 2019 1:47 pm

Re: Possible fix to the X problem

Post by mkschn » Tue Aug 27, 2019 1:55 pm

Rainermex wrote:
Fri Aug 02, 2019 4:19 pm
Rainermex wrote:
Fri Aug 02, 2019 3:58 pm
jefmcg wrote:
Sat Jul 13, 2019 1:16 pm
Yesterday I updated to the latest version of this extension, and it stopped working! I got the "X" instead of the hearts. I tried to roll it back and it broke my whole forum because the database had changed. Luckily I had a backup of the DB from just before the I upgraded, so I was able to get everything back the way it had been in a few minutes.

So then, the fix to the X problem. NOTE: I HAVEN"T TESTED THIS. You'll have to delete the data - all your previous histories of likes. If you don't want to do that, then you either need to have a backup of your DB from when it was last working or reverse engineer the DB changes. So this fix is really for those who have never had it working.

Steps
  1. Backup your database
  2. Disable the extension
  3. Delete the extension data
  4. Download the version of the extension that I downloaded in August. https://github.com/satanasov/postlove/t ... 426b9c0435 If you open this on your phone, you will need to go to the bottom of the page and click "Desktop version"
  5. Replace the version in your ext folder with this version
  6. Enable it
  7. Come back here to say it works, or to tell everyone that it's still broken and that I am an idiot.
Hi,

I just installed the Post Love extension and got the X.

OK, I back up my database and then I make the steps as listed.

Could it be that I need to restore the database or for what do I need to make a backup ?

Thank You Rainer
HI,

Problem solved. It is working now.

How do I change the read heart for any other image ?

Thank You Rainer
Tried these steps, didn't work out.
How did you solve it?
Ksuha wrote:
Wed Mar 06, 2019 12:14 pm
News: I'm on the forum have 2 profile admin and user. Now, I can see the cross only when stay in the admin profile. In user profile is heart and there is a chance to click. The notification to whom it clicked. Stay it? At least someone can press...
btw: Having the same issue like Ksuha here. As an admin I just see that "x", as a normal user everything works fine.

Thanks
Mike

Datsun
Registered User
Posts: 8
Joined: Sat Jun 02, 2007 10:20 pm

Re: [DEV] Post Love

Post by Datsun » Fri Sep 27, 2019 8:04 am

Hi, Love this extension and have been using it on my board for a while.
Just wondering if it's possible to make it compatible with Advanced Point System? viewtopic.php?f=456&t=2500296

So users receive points when one of their posts are liked.

User avatar
mrgoldy
Jr. Extension Validator
Posts: 1181
Joined: Tue Oct 06, 2009 7:34 pm
Location: The Netherlands
Name: Gijs
Contact:

Re: [DEV] Post Love

Post by mrgoldy » Sat Sep 28, 2019 8:51 am

If you're interested, Satanasov, I can even create the PR for APS integration.

Datsun
Registered User
Posts: 8
Joined: Sat Jun 02, 2007 10:20 pm

Re: [DEV] Post Love

Post by Datsun » Mon Sep 30, 2019 7:50 am

mrgoldy wrote:
Sat Sep 28, 2019 8:51 am
If you're interested, Satanasov, I can even create the PR for APS integration.
Do it :D

Post Reply

Return to “Extensions in Development”