Page 50 of 53

Re: Possible fix to the X problem

Posted: Fri Aug 02, 2019 3:58 pm
by Rainermex
jefmcg wrote:
Sat Jul 13, 2019 1:16 pm
Yesterday I updated to the latest version of this extension, and it stopped working! I got the "X" instead of the hearts. I tried to roll it back and it broke my whole forum because the database had changed. Luckily I had a backup of the DB from just before the I upgraded, so I was able to get everything back the way it had been in a few minutes.

So then, the fix to the X problem. NOTE: I HAVEN"T TESTED THIS. You'll have to delete the data - all your previous histories of likes. If you don't want to do that, then you either need to have a backup of your DB from when it was last working or reverse engineer the DB changes. So this fix is really for those who have never had it working.

Steps
  1. Backup your database
  2. Disable the extension
  3. Delete the extension data
  4. Download the version of the extension that I downloaded in August. https://github.com/satanasov/postlove/t ... 426b9c0435 If you open this on your phone, you will need to go to the bottom of the page and click "Desktop version"
  5. Replace the version in your ext folder with this version
  6. Enable it
  7. Come back here to say it works, or to tell everyone that it's still broken and that I am an idiot.
Hi,

I just installed the Post Love extension and got the X.

OK, I back up my database and then I make the steps as listed.

Could it be that I need to restore the database or for what do I need to make a backup ?

Thank You Rainer

Re: Possible fix to the X problem

Posted: Fri Aug 02, 2019 4:19 pm
by Rainermex
Rainermex wrote:
Fri Aug 02, 2019 3:58 pm
jefmcg wrote:
Sat Jul 13, 2019 1:16 pm
Yesterday I updated to the latest version of this extension, and it stopped working! I got the "X" instead of the hearts. I tried to roll it back and it broke my whole forum because the database had changed. Luckily I had a backup of the DB from just before the I upgraded, so I was able to get everything back the way it had been in a few minutes.

So then, the fix to the X problem. NOTE: I HAVEN"T TESTED THIS. You'll have to delete the data - all your previous histories of likes. If you don't want to do that, then you either need to have a backup of your DB from when it was last working or reverse engineer the DB changes. So this fix is really for those who have never had it working.

Steps
  1. Backup your database
  2. Disable the extension
  3. Delete the extension data
  4. Download the version of the extension that I downloaded in August. https://github.com/satanasov/postlove/t ... 426b9c0435 If you open this on your phone, you will need to go to the bottom of the page and click "Desktop version"
  5. Replace the version in your ext folder with this version
  6. Enable it
  7. Come back here to say it works, or to tell everyone that it's still broken and that I am an idiot.
Hi,

I just installed the Post Love extension and got the X.

OK, I back up my database and then I make the steps as listed.

Could it be that I need to restore the database or for what do I need to make a backup ?

Thank You Rainer
HI,

Problem solved. It is working now.

How do I change the read heart for any other image ?

Thank You Rainer

Re: [DEV] Post Love

Posted: Fri Aug 02, 2019 5:20 pm
by janus_zonstraal
Search for the image in the extension files and place your image there with the same name and dimensions.

Re: [DEV] Post Love

Posted: Fri Aug 02, 2019 6:25 pm
by Rainermex
janus_zonstraal wrote:
Fri Aug 02, 2019 5:20 pm
Search for the image in the extension files and place your image there with the same name and dimensions.
Hi,

Thank You. I thought one might use a different name. I searched and searched trying to find where he specifies the image to use.

regards Rainer

Re: [DEV] Post Love

Posted: Fri Aug 02, 2019 6:39 pm
by janus_zonstraal
Did you look in the image folder of the extension?
https://github.com/satanasov/postlove/t ... ter/images

Re: [DEV] Post Love

Posted: Fri Aug 02, 2019 11:30 pm
by Rainermex
janus_zonstraal wrote:
Fri Aug 02, 2019 6:39 pm
Did you look in the image folder of the extension?
https://github.com/satanasov/postlove/t ... ter/images
Hi,

Yes I found the red heart but is there no way to specify somewhere if to use the red heart or any other image ?

Will just get another image and exchange the red heart with it.

regards Rainer

Re: [DEV] Post Love

Posted: Sun Aug 11, 2019 3:51 pm
by vtmp
Are there any permissions associated with this extension? It appears not, but hoping to confirm.

I have one user that is reporting they are unable to view and use this extension, while other users in the same group are able to. This user has cleared their cache, deleted cookies, logged in/out, etc. When opening the forum in an incognito window, they are able to see the "Most Liked Posts" section, but it disappears (along with the likes functionality) once they log in.

Any other suggestions?

Re: [DEV] Post Love

Posted: Sun Aug 25, 2019 7:39 pm
by GoBieN
Yes there are permissions (user or group).

Re: Possible fix to the X problem

Posted: Tue Aug 27, 2019 1:55 pm
by mkschn
Rainermex wrote:
Fri Aug 02, 2019 4:19 pm
Rainermex wrote:
Fri Aug 02, 2019 3:58 pm
jefmcg wrote:
Sat Jul 13, 2019 1:16 pm
Yesterday I updated to the latest version of this extension, and it stopped working! I got the "X" instead of the hearts. I tried to roll it back and it broke my whole forum because the database had changed. Luckily I had a backup of the DB from just before the I upgraded, so I was able to get everything back the way it had been in a few minutes.

So then, the fix to the X problem. NOTE: I HAVEN"T TESTED THIS. You'll have to delete the data - all your previous histories of likes. If you don't want to do that, then you either need to have a backup of your DB from when it was last working or reverse engineer the DB changes. So this fix is really for those who have never had it working.

Steps
  1. Backup your database
  2. Disable the extension
  3. Delete the extension data
  4. Download the version of the extension that I downloaded in August. https://github.com/satanasov/postlove/t ... 426b9c0435 If you open this on your phone, you will need to go to the bottom of the page and click "Desktop version"
  5. Replace the version in your ext folder with this version
  6. Enable it
  7. Come back here to say it works, or to tell everyone that it's still broken and that I am an idiot.
Hi,

I just installed the Post Love extension and got the X.

OK, I back up my database and then I make the steps as listed.

Could it be that I need to restore the database or for what do I need to make a backup ?

Thank You Rainer
HI,

Problem solved. It is working now.

How do I change the read heart for any other image ?

Thank You Rainer
Tried these steps, didn't work out.
How did you solve it?
Ksuha wrote:
Wed Mar 06, 2019 12:14 pm
News: I'm on the forum have 2 profile admin and user. Now, I can see the cross only when stay in the admin profile. In user profile is heart and there is a chance to click. The notification to whom it clicked. Stay it? At least someone can press...
btw: Having the same issue like Ksuha here. As an admin I just see that "x", as a normal user everything works fine.

Thanks
Mike

Re: [DEV] Post Love

Posted: Fri Sep 27, 2019 8:04 am
by Datsun
Hi, Love this extension and have been using it on my board for a while.
Just wondering if it's possible to make it compatible with Advanced Point System? viewtopic.php?f=456&t=2500296

So users receive points when one of their posts are liked.

Re: [DEV] Post Love

Posted: Sat Sep 28, 2019 8:51 am
by mrgoldy
If you're interested, Satanasov, I can even create the PR for APS integration.

Re: [DEV] Post Love

Posted: Mon Sep 30, 2019 7:50 am
by Datsun
mrgoldy wrote:
Sat Sep 28, 2019 8:51 am
If you're interested, Satanasov, I can even create the PR for APS integration.
Do it :D

Re: [DEV] Post Love

Posted: Tue Nov 26, 2019 2:02 pm
by Scones
I seem to have the same problem as other mentioned on here.

I have an established forum which until recently was on phpbb3.1.9, and had an old version of postlove installed.
I have updated to phpbb 3.2.8, disabled and then deleted the old postlove, and finallly followed the instructions on

https://github.com/satanasov/postlove

to install the latest version. However, all I get appearing on the posts is a little 'X' which I cannot click on. I can't see any errors showing anywhere, it just doesn't work. Any ideas how I can start debugging this?

I've also tried disabling, deleting data, and then enabling to see if that helped.

Re: [DEV] Post Love

Posted: Tue Nov 26, 2019 3:47 pm
by jefmcg
I've got a long post above explaining my fix, which is basically installing an earlier version of the - https://github.com/satanasov/postlove/t ... 426b9c0435 - which works fine.

Just delete your data, remove the current version and replace it with the old one.

Re: [DEV] Post Love

Posted: Tue Nov 26, 2019 4:15 pm
by Scones
jefmcg wrote:
Tue Nov 26, 2019 3:47 pm
I've got a long post above explaining my fix, which is basically installing an earlier version of the - https://github.com/satanasov/postlove/t ... 426b9c0435 - which works fine.

Just delete your data, remove the current version and replace it with the old one.
Thanks for this, worked a treat apart from I can't see why's liked the post. What do I need to do to fix this bit?