Page 2 of 8

Re: [DEV] Birthday Control

Posted: Wed Jul 02, 2014 10:48 am
by Satanasov
You will need the last development version.

After RC1 release there was a change in migration that resolved exactly this issue.

Re: [DEV] Birthday Control

Posted: Wed Jul 02, 2014 11:33 am
by MrC
I just tried to update to latest dev but somehow it's not updating the database.
After clicking the link to the final step i'm thrown back 2 steps.

Re: [DEV] Birthday Control

Posted: Wed Jul 02, 2014 2:58 pm
by Satanasov
boardurl/install/update_database.php I think was the script to update the DB.

Re: [DEV] Birthday Control

Posted: Wed Jul 02, 2014 3:09 pm
by nicofuma
if you want to update an extension you need to disable and re-enable it.
boardurl/install/update_database.php is only for the core

Re: [DEV] Birthday Control

Posted: Wed Jul 02, 2014 4:01 pm
by Methen
Here is a very simple question to think about, what good does it do to force people to give you their age when you have no way to verify that person is giving you accurate information in the first place, its like I tell people on chat rooms all the time why bother if you cannot verify it...

Re: [DEV] Birthday Control

Posted: Wed Jul 02, 2014 4:12 pm
by Satanasov
We have discussed this few posts back.

Re: [DEV] Birthday Control

Posted: Thu Jul 03, 2014 5:54 am
by MrC
Lucifer4o wrote:boardurl/install/update_database.php I think was the script to update the DB.
That doesn't work either, same result
nicofuma wrote:if you want to update an extension you need to disable and re-enable it.
boardurl/install/update_database.php is only for the core
We were talking about the core update ;) (RC1 -> RC2 dev)

I will give it another try with last nights build
*edit, updated with last night dev version. Im not sure which version im running now since the console still shows RC1. Modified files have been uploaded and db update has run.
The header errors are still there.

Re: [DEV] Birthday Control

Posted: Thu Jul 03, 2014 7:17 am
by Satanasov
Disable extension. Delete extension data.

Go to Users and Groups -> Custom profile fields and remove the last one (W_BDAY).

Enable extension

Re: [DEV] Birthday Control

Posted: Thu Jul 03, 2014 8:31 am
by MrC
@work now, so no time to type a lot
Lucifer4o wrote:Disable extension. Delete extension data.

Go to Users and Groups -> Custom profile fields and remove the last one (W_BDAY).

Enable extension
That part works now

Now, when i register
Notice: You are not old enough to register to this board.
This board has minum age of 18 years. in /home/spaapen.net/public_html/31/ext/anavaro/birthdaycontrol/event/mainlistener.php on line 95

Warning: Cannot modify header information - headers already sent by (output started at /home/spaapen.net/public_html/31/ext/anavaro/birthdaycontrol/event/mainlistener.php:95) in /home/spaapen.net/public_html/31/includes/functions.php on line 5018

Warning: Cannot modify header information - headers already sent by (output started at /home/spaapen.net/public_html/31/ext/anavaro/birthdaycontrol/event/mainlistener.php:95) in /home/spaapen.net/public_html/31/includes/functions.php on line 5020

Warning: Cannot modify header information - headers already sent by (output started at /home/spaapen.net/public_html/31/ext/anavaro/birthdaycontrol/event/mainlistener.php:95) in /home/spaapen.net/public_html/31/includes/functions.php on line 5021

Warning: Cannot modify header information - headers already sent by (output started at /home/spaapen.net/public_html/31/ext/anavaro/birthdaycontrol/event/mainlistener.php:95) in /home/spaapen.net/public_html/31/includes/functions.php on line 5022
http://www.spaapen.net/31

Re: [BETA] Birthday Control

Posted: Sat Nov 29, 2014 4:20 am
by wkuzma
I see your ext was updated I will have to try that one the other errored on registering.

Works now with one exception when viewing the board registration rules during registration and not filling out the date part and just clicking on I agree to these terms I get an error

Fatal error: Call to a member function getName() on a non-object in /home4/wkuzma/public_html/includes/functions.php on line 4949

Re: [BETA] Birthday Control

Posted: Tue Dec 02, 2014 7:02 am
by wkuzma
New problem
I don't know how to explain it but I will tell you how I tracked it to your ext
One user send a message in private message to me that his posts
were not showing up on the board. He told which forums he was posting in and what message
he was replying to. I went to the forum and message and only saw the orginal post that was done by someone else even though it said there was 1 reply.
I replied to that message and then it said there were two replys instead of just the one I did,
I started to track the problem by disabling all extentions one by one and checking to see if the message appeared. When I got to your ext and disabled it his message appeared
when I re-enabled it his message disapeared
I am keeping your ext disabled but I have no idea why this happened to only one user maybe something in his name which is |iog|Delahanty the two lines in his name is on the \ key holding the shift and pressing that key gives |

Re: [BETA] Birthday Control

Posted: Tue Dec 02, 2014 9:32 am
by Satanasov
OK ... I think I will have to rethink the extension ... there seems to be no logic behind it ... but I will test it.

Re: [BETA] Birthday Control

Posted: Tue Dec 02, 2014 9:44 am
by franki_63
German translation for this extension
birthdaycontrol_de.zip

Re: [DEV] Birthday Control

Posted: Tue Dec 02, 2014 4:28 pm
by Satanasov
:shock: :shock: Just reviewed my code... how the hell did I release this thing. Returning to dev status. I hope to return it in beta in few hours.

I know where the errors comes from.

Re: [BETA] Birthday Control

Posted: Tue Dec 02, 2014 7:13 pm
by Satanasov
wkuzma wrote:New problem
I don't know how to explain it but I will tell you how I tracked it to your ext
One user send a message in private message to me that his posts
were not showing up on the board. He told which forums he was posting in and what message
he was replying to. I went to the forum and message and only saw the orginal post that was done by someone else even though it said there was 1 reply.
I replied to that message and then it said there were two replys instead of just the one I did,
I started to track the problem by disabling all extentions one by one and checking to see if the message appeared. When I got to your ext and disabled it his message appeared
when I re-enabled it his message disapeared
I am keeping your ext disabled but I have no idea why this happened to only one user maybe something in his name which is |iog|Delahanty the two lines in his name is on the \ key holding the shift and pressing that key gives |

Please test the current release. It should not have this issue.