[CDB] Thanks for posts

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
John45
Registered User
Posts: 199
Joined: Sat Jun 08, 2013 2:54 am

Re: [DEV] Thanks for posts

Post by John45 » Sun Jul 19, 2015 6:32 pm

bmc1776 wrote:
John45 wrote:For some odd reason when you enable it for posts it tends to replace the quote button.
Have you figured out this issue by chance? I am stuck with this.

I am using prosilver v3.1.5 and the thanks button overlays the quotes button, I have gone through 29 pages and either missed where someone addressed how to resolve the issue or it is just not there, I have tried some of the code changes recommended for the thanks.css and they don't work.

Anyone?
I'm stuck at it too. :x

Maiden2k
Registered User
Posts: 10
Joined: Wed Mar 10, 2010 5:08 pm

Re: [DEV] Thanks for posts

Post by Maiden2k » Sun Jul 19, 2015 9:37 pm

.

Maiden2k
Registered User
Posts: 10
Joined: Wed Mar 10, 2010 5:08 pm

Re: [DEV] Thanks for posts

Post by Maiden2k » Sun Jul 19, 2015 9:47 pm

bmc1776 wrote:
John45 wrote:For some odd reason when you enable it for posts it tends to replace the quote button.
Have you figured out this issue by chance? I am stuck with this.

I am using prosilver v3.1.5 and the thanks button overlays the quotes button, I have gone through 29 pages and either missed where someone addressed how to resolve the issue or it is just not there, I have tried some of the code changes recommended for the thanks.css and they don't work.

Anyone?
this
viewtopic.php?f=456&t=2259046&start=420#p14128311

+

this
viewtopic.php?f=456&t=2259046&start=420#p14130301

User avatar
Galixte de EzCom
Registered User
Posts: 1041
Joined: Mon Oct 04, 2004 11:14 pm
Location: France
Name: Raphaël M.
Contact:

Re: [DEV] Thanks for posts

Post by Galixte de EzCom » Sun Jul 19, 2015 11:50 pm

To solve partially this problem you have to revert this modification: https://github.com/rxu/thanks_for_posts ... 5759b7b54f.

I say partially because this modification is a fix for this particular problem: https://github.com/rxu/thanks_for_posts/issues/35.
Communau EzCom
📖 « Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
📋 Lists of all extensions identified for phpBB 3.1.x & 3.2.x.
📋 Lists of all styles identified for phpBB 3.1.x & 3.2.x.
Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

User avatar
kamaleon
Registered User
Posts: 510
Joined: Tue Sep 09, 2014 9:47 am
Location: Barcelona

Re: [DEV] Thanks for posts

Post by kamaleon » Wed Jul 22, 2015 9:55 am

So this extension is not working properly?
This is a test signature. I hope you love it :D

valdos
Registered User
Posts: 29
Joined: Tue May 19, 2015 9:19 am

Re: [DEV] Thanks for posts

Post by valdos » Wed Jul 22, 2015 10:08 am

The proposal
To add a pivot table another column with the coefficient of usefulness
The number of posts divided by the number of thanks.
To show the effectiveness of posts left on the forum.

rxu
Extensions Development Team
Posts: 3002
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Wed Jul 22, 2015 4:26 pm

kamaleon wrote:So this extension is not working properly?
It's not currently.
valdos wrote:To add a pivot table another column with the coefficient of usefulness
Do you mean usefulness of users or something else?
valdos wrote:To show the effectiveness of posts left on the forum.
Didn't get the point. The extension already has a feature of posts ratings.

User avatar
kamaleon
Registered User
Posts: 510
Joined: Tue Sep 09, 2014 9:47 am
Location: Barcelona

Re: [DEV] Thanks for posts

Post by kamaleon » Wed Jul 22, 2015 4:30 pm

rxu wrote:
kamaleon wrote:So this extension is not working properly?
It's not currently.
Too bad :(

Is there any way we can help?
This is a test signature. I hope you love it :D

rxu
Extensions Development Team
Posts: 3002
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Wed Jul 22, 2015 4:34 pm

kamaleon wrote:Is there any way we can help?
Thanks, but not really. The main problem is the "thanks" button displaying, which I hope to fix with the phpBB 3.1.6 release in case of merging the pull request required for that.

valdos
Registered User
Posts: 29
Joined: Tue May 19, 2015 9:19 am

Re: [DEV] Thanks for posts

Post by valdos » Thu Jul 23, 2015 6:54 am

rxu wrote: Do you mean usefulness of users or something else?
Yes (Да я имею ввиду полезность оставленных постов)

You can write 1000 posts but none of them received thanks.
And you can write 1000 posts and get 500 thanks.
Get 1000/500 = 2.
The coefficient of usefulness of 2.
Of course the feature is not perfect, because one post can get 200 thanks, and the other 300, and the remaining 998 anything, but nonetheless.

(Можно написать 1000 постов, но ни одни из них не получил благодарности.
А можно написать 1000 постов и получить 500 благодарностей.
Получится 1000/500 = 2.
Коэффициент полезности 2.
Конечно характеристика не идеальна, так как один пост может получить 200 благодарностей, а другой 300, а остальные 998 ничего, но тем не менее.)

MDuss
Registered User
Posts: 46
Joined: Sat May 03, 2008 2:50 pm

Re: [DEV] Thanks for posts

Post by MDuss » Thu Jul 23, 2015 11:05 am

Hi.

I have installed this Mod in my testforum and have here a Little Problem.
I can not see the Ratings in the Topic and Forum area.

Here are my sample.
In my main Forum (phpbb 3.0.12 and the original thanks mod) it Looks like this:
Sreen1

Sreen2

And in my updated testforum (phpbb 3.1.5 and thanks Mod 2.0.2) it Looks like this.

Sreen3

Sreen4

In the first poste here on this Images it Looks like in my old Forum, creenshot with the Posts toplist, Rating topis and Rating Forum.
And the calculation seems also not to be correct.

What coud I do so that this work correct?

MfG
MDuss

CoinHELP
Registered User
Posts: 104
Joined: Fri Oct 16, 2009 6:41 pm

Re: [DEV] Thanks for posts

Post by CoinHELP » Sat Jul 25, 2015 1:57 am

I am getting this when I upload to servers and I tried it multiple ways.

Display name in composer.json: Thanks for posts
Version in composer.json: 2.0.2
Name in composer.json: gfksx/ThanksForPosts
Path to composer.json: /ext/thanks_for_posts-master/composer.json

And it doesn't show up in extension manager. I don't have trouble with most of these extensions since changing over to 3.1 but some just seem difficult.

Sisem
Registered User
Posts: 121
Joined: Fri May 25, 2007 11:52 am

Re: [DEV] Thanks for posts

Post by Sisem » Sat Jul 25, 2015 2:34 am

Think I've actually found the problem with the button not showing / overlaying.

The mod is creating a second instance of the <ul class="post-buttons"> and not simply putting the button into the existing class, so the new duplicate class is overlaying it. But also it's inserting the button in the wrong place...

So, open up the viewtopic_body_post_buttons_list_after from the template/event folder,

Delete <ul class="post-buttons"> from line 3,

Delete </ul> from line 7,

Then rename the same file from viewtopic_body_post_buttons_list_after.html to viewtopic_body_post_buttons_after.html - ie removing the '_list'.

I've also had to create my custom template folder in ext/gfksx/ThanksForPosts/styles/customthemename and copy in everything from the ProSilver folder to get it all correct.

Also I've had to leave the file viewtopic_body_post_buttons_list_after.html in the prosilver folder but delete all the contents of the file, as it was still using that inheritance and putting the duplicate class and button in.
Last edited by Sisem on Sun Jul 26, 2015 12:48 pm, edited 1 time in total.

CoinHELP
Registered User
Posts: 104
Joined: Fri Oct 16, 2009 6:41 pm

Re: [DEV] Thanks for posts

Post by CoinHELP » Sun Jul 26, 2015 3:34 am

I am getting this when I upload to servers and I tried it multiple ways.

Display name in composer.json: Thanks for posts
Version in composer.json: 2.0.2
Name in composer.json: gfksx/ThanksForPosts
Path to composer.json: /ext/thanks_for_posts-master/composer.json

gfksx/ThanksForPosts
/ext/thanks_for_posts-master/composer.json
Are in red so what path do I use?

rxu
Extensions Development Team
Posts: 3002
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Sun Jul 26, 2015 5:18 am

CoinHELP wrote:what path do I use?
You can find the info in the 1st post of this topic. Thanks.

Locked

Return to “Extensions in Development”