[CDB] Thanks for posts

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
rxu
Extensions Development Team
Posts: 2955
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Sun Oct 30, 2016 11:56 am

Swen wrote:The role doesn't exist?
It exists in phpBB 3.1 by default.

Swen
Registered User
Posts: 72
Joined: Sun Oct 04, 2015 5:44 pm

Re: [DEV] Thanks for posts

Post by Swen » Sun Oct 30, 2016 12:02 pm

Thanks for reply, but not on my side! I don't know why. Add this by hand. Activation works now.

But i use theme we_universal. Must i do something after activation? I can't thank any post. Nothing will show up. Only via menu i have two links now.

Any hind here?

Thanks for your work and support!

EDIT: Tested Prosilver and there is also no rating available.
Regards Swen

rxu
Extensions Development Team
Posts: 2955
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Sun Oct 30, 2016 1:20 pm

Swen wrote:But i use theme we_universal. Must i do something after activation?
You can try disable the extension, create the we_universal folder inside the \ext\gfksx\ThanksForPosts\styles\ folder, copy the contents of the \ext\gfksx\ThanksForPosts\styles\prosilver folder into it, enable extension.
Swen wrote:Tested Prosilver and there is also no rating available.
It should be there once you have enabled it in ACP. At least it works fine on my side now.

User avatar
Galixte de EzCom
Registered User
Posts: 1028
Joined: Mon Oct 04, 2004 11:14 pm
Location: France
Name: Raphaël M.
Contact:

Re: [DEV] Thanks for posts

Post by Galixte de EzCom » Sun Oct 30, 2016 1:43 pm

Hi,

you have to set the permissions for each group. No needs to customize/add/edit some files to make compatible this extension with We_universal style.
Communau EzCom
📖 « Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
📋 Lists of all extensions identified for phpBB 3.1.x & 3.2.x.
📋 Lists of all styles identified for phpBB 3.1.x & 3.2.x.
Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

Swen
Registered User
Posts: 72
Joined: Sun Oct 04, 2015 5:44 pm

Re: [DEV] Thanks for posts

Post by Swen » Sun Oct 30, 2016 1:56 pm

Where i must set permissions? Don't find any option in group rules.
Regards Swen

User avatar
Galixte de EzCom
Registered User
Posts: 1028
Joined: Mon Oct 04, 2004 11:14 pm
Location: France
Name: Raphaël M.
Contact:

Re: [DEV] Thanks for posts

Post by Galixte de EzCom » Sun Oct 30, 2016 2:02 pm

Communau EzCom
📖 « Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
📋 Lists of all extensions identified for phpBB 3.1.x & 3.2.x.
📋 Lists of all styles identified for phpBB 3.1.x & 3.2.x.
Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

Swen
Registered User
Posts: 72
Joined: Sun Oct 04, 2015 5:44 pm

Re: [DEV] Thanks for posts

Post by Swen » Sun Oct 30, 2016 3:00 pm

OK is set to yes.
Regards Swen

cichy_ludek
Registered User
Posts: 72
Joined: Fri Jun 17, 2016 12:31 pm

Re: [DEV] Thanks for posts

Post by cichy_ludek » Sun Oct 30, 2016 8:54 pm

Maybe someone already tried to ajaxify this? :)

User avatar
Galixte de EzCom
Registered User
Posts: 1028
Joined: Mon Oct 04, 2004 11:14 pm
Location: France
Name: Raphaël M.
Contact:

Re: [DEV] Thanks for posts

Post by Galixte de EzCom » Mon Oct 31, 2016 3:26 am

An Addon already exists: viewtopic.php?f=456&t=2259666.
Communau EzCom
📖 « Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
📋 Lists of all extensions identified for phpBB 3.1.x & 3.2.x.
📋 Lists of all styles identified for phpBB 3.1.x & 3.2.x.
Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

krafyt
Registered User
Posts: 52
Joined: Sun Aug 23, 2009 11:13 pm

Re: [DEV] Thanks for posts

Post by krafyt » Mon Oct 31, 2016 4:49 pm

rxu wrote:The problem comes from phpBB 3.1.10 core, we're working hard on sorting it out. Sorry for the inconvenience.
Any news according to this?

cichy_ludek
Registered User
Posts: 72
Joined: Fri Jun 17, 2016 12:31 pm

Re: [DEV] Thanks for posts

Post by cichy_ludek » Mon Oct 31, 2016 10:40 pm

Galixte de EzCom wrote:An Addon already exists: viewtopic.php?f=456&t=2259666.
Thank You, works perfect.

rxu
Extensions Development Team
Posts: 2955
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Nov 01, 2016 5:00 pm

krafyt wrote:Any news according to this?
Yes. It's been fixed in the development repository and the fix will be rolled out with the upcoming phpBB 3.1.11.
And no, I don't know how soon it's going to be released ;)

Bogdan.
Registered User
Posts: 32
Joined: Thu Sep 15, 2016 6:50 pm
Contact:

Re: [DEV] Thanks for posts

Post by Bogdan. » Fri Nov 04, 2016 8:33 am

Image
Image link - https://s12.postimg.org/6zhzvulwd/thanks.jpg

I dont know why the button doesn't show.
There is a square but nothing in it...
Any tips what should i do?

rxu
Extensions Development Team
Posts: 2955
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Fri Nov 04, 2016 8:46 am

Bogdan. wrote:I dont know why the button doesn't show.
viewtopic.php?f=456&t=2259046&p=14121846

Bogdan.
Registered User
Posts: 32
Joined: Thu Sep 15, 2016 6:50 pm
Contact:

Re: [DEV] Thanks for posts

Post by Bogdan. » Fri Nov 04, 2016 9:30 am

rxu wrote:
Bogdan. wrote:I dont know why the button doesn't show.
viewtopic.php?f=456&t=2259046&p=14121846
It shows now but i have another probleme.
Before it it shows the QUOTE ...

Image

https://s21.postimg.org/hjuoskbjr/quote.jpg

Edit : works now i use

Code: Select all

<!-- IF  not postrow.S_FIRST_POST_ONLY or postrow.S_ONLY_TOPICSTART -->
   <!-- IF not postrow.S_GLOBAL_POST_THANKS and not postrow.S_POST_ANONYMOUS and S_FORUM_THANKS and S_USER_LOGGED_IN and not postrow.S_IS_OWN_POST and (not postrow.S_ALREADY_THANKED or postrow.S_REMOVE_THANKS) -->
   <a id="lnk_thanks_post{postrow.POST_ID}" href="{postrow.THANKS_LINK}" class="button icon-button {postrow.THANKS_IMG}" title="{postrow.THANK_ALT}{postrow.POST_AUTHOR}"><span>{postrow.THANK_ALT_SHORT}</span></a>
   <!-- ENDIF -->
<!-- ENDIF -->
And that .css and it works.

Locked

Return to “Extensions in Development”