[DEV] Thanks for posts

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
FAMZONE
Registered User
Posts: 15
Joined: Mon May 22, 2017 12:33 pm

Re: [DEV] Thanks for posts

Post by FAMZONE » Fri Sep 15, 2017 11:56 am

If I had the support of the author I'll ask him, but I bought that theme a year ago and the support (default) is 6 months.
Thanks for your help.

rxu
Extensions Development Team
Posts: 2835
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Fri Sep 15, 2017 12:14 pm

FAMZONE
The issue is I never bought that style so I have no access to its code for sorting out your problem.

FAMZONE
Registered User
Posts: 15
Joined: Mon May 22, 2017 12:33 pm

Re: [DEV] Thanks for posts

Post by FAMZONE » Fri Sep 15, 2017 12:41 pm

I sent you a private message, let's talk there, thanks.

neeraj.sinha
Registered User
Posts: 16
Joined: Wed Oct 04, 2017 3:53 pm

Re: [DEV] Thanks for posts

Post by neeraj.sinha » Fri Oct 06, 2017 10:39 am

This does works fine with 3.2.1!

User avatar
feruchio
Registered User
Posts: 49
Joined: Fri Sep 08, 2017 7:26 am

Re: [DEV] Thanks for posts

Post by feruchio » Mon Oct 09, 2017 9:54 pm

Is it possible to make it works with my theme? http://awesomecs.syntrwave.com/

rxu
Extensions Development Team
Posts: 2835
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Oct 10, 2017 4:02 am

That style is prosilver-based, so I assume it should be possible.

User avatar
feruchio
Registered User
Posts: 49
Joined: Fri Sep 08, 2017 7:26 am

Re: [DEV] Thanks for posts

Post by feruchio » Tue Oct 10, 2017 6:45 am

But will it be hard you to do it, or is way too much work? :?

rxu
Extensions Development Team
Posts: 2835
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Oct 10, 2017 9:46 am

Like with any "premium" (paid) style - I have no idea as I never bought it and didn't see its code.

User avatar
feruchio
Registered User
Posts: 49
Joined: Fri Sep 08, 2017 7:26 am

Re: [DEV] Thanks for posts

Post by feruchio » Tue Oct 10, 2017 9:50 am

But what if you were able to see it, would you bother to do it? ;)

rxu
Extensions Development Team
Posts: 2835
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Oct 10, 2017 9:57 am

If I was able to see it, it would be easier to decide if it's possible ;)

cangor
Registered User
Posts: 58
Joined: Thu Oct 28, 2010 1:56 pm

Re: [DEV] Thanks for posts

Post by cangor » Tue Oct 24, 2017 12:55 pm

Thanks for porting this mod to 3.2.1! I have some problems migrating from 3.0.14: On https://www.phpbb.com/support/docs/en/3 ... /upgrade3/ you are told to delete all existing mod-data. Of course all data for this extension is affected as well. So I tried to copy the phpbb_thanks-table from my 3.0.14 to my 3.2.1., but the tables even don't have the same columns. I found the \ext\gfksx\ThanksForPosts\migrations\ directory which seems to take care of that, but how can I start the migration there?
Last edited by cangor on Tue Oct 24, 2017 1:04 pm, edited 1 time in total.

rxu
Extensions Development Team
Posts: 2835
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Oct 24, 2017 1:04 pm

You can try keepeing the database table at place. It should be converted on the extension installation.
But you have to remove the MOD ACP module for 3.0.x before converting the board to 3.2.

cangor
Registered User
Posts: 58
Joined: Thu Oct 28, 2010 1:56 pm

Re: [DEV] Thanks for posts

Post by cangor » Tue Oct 24, 2017 1:20 pm

Thanks for your fast reply!

Okay, I have 2 databases like "dbold" (for 3.0.14) and "dbnew" (for 3.2.1).

I copied the php_thanks table from the old to the new database (because it was removed like it's described in https://www.phpbb.com/support/docs/en/3 ... /upgrade3/):

Code: Select all

use dbnew;
CREATE TABLE `phpbb_thanks` (
  `thanks_id` mediumint(8) unsigned NOT NULL AUTO_INCREMENT,
  `thanks_from` mediumint(8) unsigned NOT NULL,
  `thanks_to` mediumint(8) unsigned NOT NULL,
  `post_id` mediumint(8) unsigned NOT NULL,
  PRIMARY KEY (`thanks_id`)
) ENGINE=MyISAM;
INSERT INTO dbnew.phpbb_thanks SELECT * from dbold.phpbb_thanks;
Then I activated the extension and got this error:

Code: Select all

SQL ERROR [ mysqli ]
Key column 'user_id' doesn't exist in table [1072]
SQL
ALTER TABLE phpbb_thanks ADD INDEX user_id (user_id)

rxu
Extensions Development Team
Posts: 2835
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Oct 24, 2017 2:25 pm

Creating an empty table without any data in it makes no sense. You can try importing the full table (structure+data) from the old DB.

What version of the MOD did you have?

cangor
Registered User
Posts: 58
Joined: Thu Oct 28, 2010 1:56 pm

Re: [DEV] Thanks for posts

Post by cangor » Tue Oct 24, 2017 2:48 pm

rxu wrote:
Tue Oct 24, 2017 2:25 pm
Creating an empty table without any data in it makes no sense. You can try importing the full table (structure+data) from the old DB.
Thats why I'm inserting the old data:

Code: Select all

INSERT INTO dbnew.phpbb_thanks SELECT * from dbold.phpbb_thanks;
rxu wrote:
Tue Oct 24, 2017 2:25 pm
What version of the MOD did you have?
Ouch, just checked it again and it might be that I was using this mod:
viewtopic.php?f=70&t=1115275
:oops:
Not sure yet, it's hard to see in the old mod-system which mod you used and it's long ago since I installed it...

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: alex75, Aurelienazerty, Hippie459MN, sr55, Tbot [Bot] and 32 guests