[CDB] Thanks for posts

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
rxu
Extensions Development Team
Posts: 2993
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Wed Jun 24, 2015 6:07 pm

Booster1304 wrote:This is the result.
It seems that for Subway style the thanks button is just overlaying the quote button thus the latter becomes inaccessible. Will look into it later.

Booster1304
Registered User
Posts: 18
Joined: Sun Jun 21, 2015 7:42 am

Re: [DEV] Thanks for posts

Post by Booster1304 » Wed Jun 24, 2015 6:22 pm

Image

Now got it solved that the thumbs icon appears.
Taken the original code by you for viewtopic-body-post-buttons-list-after.html

Code: Select all

<!-- IF  not postrow.S_FIRST_POST_ONLY or postrow.S_ONLY_TOPICSTART -->
	<!-- IF not postrow.S_GLOBAL_POST_THANKS and not postrow.S_POST_ANONYMOUS and S_FORUM_THANKS and S_USER_LOGGED_IN and not postrow.S_IS_OWN_POST and (not postrow.S_ALREADY_THANKED or postrow.S_REMOVE_THANKS) -->
		<ul class="post-buttons">
			<li>
				<a id='lnk_thanks_post{postrow.POST_ID}' href="{postrow.THANKS_LINK}" title="{postrow.THANK_ALT}{postrow.POST_AUTHOR}" class="button icon-button {postrow.THANKS_IMG}"><span>{postrow.THANK_ALT_SHORT}</span></a>
			</li>
		</ul>
	<!-- ENDIF -->
<!-- ENDIF -->
and some changes in thanks.css

Code: Select all

.thanks-icon:before
{
font-family: 'subway-icons',Open Sans,sans-serif;
	content: "\e0aa";  
}
.thanks-icon:hover:before{ background-position: -3px -19px; }

.removethanks-icon:before
{
font-family: 'subway-icons',Open Sans,sans-serif;
	content: "\e0af";  

}
If now you could make it not overlayering the Quote Button you will be my personal hero :)

Schtorsch
Registered User
Posts: 49
Joined: Tue Aug 12, 2008 8:49 am

Re: [DEV] Thanks for posts

Post by Schtorsch » Thu Jun 25, 2015 10:10 am

I don´t know if I had the same problems like the users before - but I have installed the extension "Topic solved" ( https://github.com/tierra/topicsolved ) and "Thanks for posts". I think, the buttons are at the same position. Now I can solve OR thank the post. Are there only 7 "slots" for buttons like these both? My own topics I cannot thank - there is the button for "solved" visible. Topics from other users I can only thank - but not solving...

User avatar
Blackwolf_Oz
Registered User
Posts: 264
Joined: Sat Jan 02, 2010 5:15 am
Location: Melbourne Australia
Name: Nick
Contact:

Re: [DEV] Thanks for posts

Post by Blackwolf_Oz » Fri Jun 26, 2015 10:43 am

Great mod....thanks for all your hard work! :D :D
We are Anonymous. We are Legion. We do not forgive. We do not forget. Expect us.

Ultimate Edition, Ultimate Edition Oz, Oz Unity

Karsten1975
Registered User
Posts: 7
Joined: Fri Jun 26, 2015 1:09 pm

Re: [DEV] Thanks for posts

Post by Karsten1975 » Fri Jun 26, 2015 1:24 pm

I am using custom style black. My Board Version is 3.1.5

I tried all in this post.
But the Thank for posts button is not showing.

Can anybody help me please?



Sorry for my english. I am from Germany

rxu
Extensions Development Team
Posts: 2993
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Fri Jun 26, 2015 2:00 pm

Karsten1975 wrote:I am using custom style black.
Can I download it somehow for checking?

Karsten1975
Registered User
Posts: 7
Joined: Fri Jun 26, 2015 1:09 pm

Re: [DEV] Thanks for posts

Post by Karsten1975 » Fri Jun 26, 2015 2:23 pm

rxu wrote:
Karsten1975 wrote:I am using custom style black.
Can I download it somehow for checking?
https://www.phpbb.com/customise/db/style/black/

that´s the link to the Style

rxu
Extensions Development Team
Posts: 2993
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Fri Jun 26, 2015 3:57 pm

Karsten1975
Now, what extension code are you using? The problem is that the current version of the black style is not updated to phpBB 3.1.5, so if you use the latest code, the button won't show.

Karsten1975
Registered User
Posts: 7
Joined: Fri Jun 26, 2015 1:09 pm

Re: [DEV] Thanks for posts

Post by Karsten1975 » Fri Jun 26, 2015 4:45 pm

rxu wrote:Karsten1975
Now, what extension code are you using? The problem is that the current version of the black style is not updated to phpBB 3.1.5, so if you use the latest code, the button won't show.

Thanks for all. It works
I Just Updatet Style to 3.1.5

Karsten1975
Registered User
Posts: 7
Joined: Fri Jun 26, 2015 1:09 pm

Re: [DEV] Thanks for posts

Post by Karsten1975 » Fri Jun 26, 2015 5:07 pm

Karsten1975 wrote:
rxu wrote:Karsten1975
Now, what extension code are you using? The problem is that the current version of the black style is not updated to phpBB 3.1.5, so if you use the latest code, the button won't show.

Thanks for all. It works
I Just Updatet Style to 3.1.5

Now I have another Problem. All thanks are listet double in the Threads
Image

User avatar
Galixte de EzCom
Registered User
Posts: 1041
Joined: Mon Oct 04, 2004 11:14 pm
Location: France
Name: Raphaël M.
Contact:

Re: [DEV] Thanks for posts

Post by Galixte de EzCom » Fri Jun 26, 2015 5:44 pm

Hi,
rxu wrote:Karsten1975
Now, what extension code are you using? The problem is that the current version of the black style is not updated to phpBB 3.1.5, so if you use the latest code, the button won't show.
this style is updated by Arty, the author, on this page : http://www.artodia.com/phpbb-styles/black2/downloads.
Communau EzCom
📖 « Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
📋 Lists of all extensions identified for phpBB 3.1.x & 3.2.x.
📋 Lists of all styles identified for phpBB 3.1.x & 3.2.x.
Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

Karsten1975
Registered User
Posts: 7
Joined: Fri Jun 26, 2015 1:09 pm

Re: [DEV] Thanks for posts

Post by Karsten1975 » Fri Jun 26, 2015 6:40 pm

Galixte de EzCom wrote:Hi,
rxu wrote:Karsten1975
Now, what extension code are you using? The problem is that the current version of the black style is not updated to phpBB 3.1.5, so if you use the latest code, the button won't show.
this style is updated by Arty, the author, on this page : http://www.artodia.com/phpbb-styles/black2/downloads.
Now i use the Style from this page:
http://www.artodia.com/phpbb-styles/black2/
But still dont work correctly. It´s all double in Threads and in Forum overview.
Last edited by Karsten1975 on Sat Jun 27, 2015 4:16 pm, edited 1 time in total.

Booster1304
Registered User
Posts: 18
Joined: Sun Jun 21, 2015 7:42 am

Re: [DEV] Thanks for posts

Post by Booster1304 » Sat Jun 27, 2015 3:17 pm

Rxu, any Idea to my issue?
Tried it on Subway Style and Dark extension i´ve send you?

rxu
Extensions Development Team
Posts: 2993
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Sat Jun 27, 2015 3:53 pm

Booster1304 wrote:any Idea to my issue?
The problem is that the html element adding the thanks button has the same css class and hence the same alignment as the post buttons list, so the button overlays the last button in the list.
This is css implementation problem where I'm not an expert in, so the fixing will take some time, sorry.

Booster1304
Registered User
Posts: 18
Joined: Sun Jun 21, 2015 7:42 am

Re: [DEV] Thanks for posts

Post by Booster1304 » Sun Jun 28, 2015 8:17 am

Ok, would be great if you take some time again and try to fix this :)

Don´t hurry, take your time friend.

Locked

Return to “Extensions in Development”