[CDB] Thanks for posts

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
CoinHELP
Registered User
Posts: 104
Joined: Fri Oct 16, 2009 6:41 pm

Re: [DEV] Thanks for posts

Post by CoinHELP » Mon Jul 27, 2015 12:19 am

I spoke to soon. I don't see the thanks button in the post. I am using AllanStyle-SUBSILVER.

CoinHELP
Registered User
Posts: 104
Joined: Fri Oct 16, 2009 6:41 pm

Re: [DEV] Thanks for posts

Post by CoinHELP » Mon Jul 27, 2015 10:21 am

I have been through every option and link in the ACP and there's no permissions for the thanks extension. I am not even authorized to view the thanks list.

If anyone have any insight it would be appreciated.

I did get this ajax error when I deleted the board cookies No route found for "POST /thankslist/givens/22037/ucp.php"

heads
Registered User
Posts: 1
Joined: Mon Jul 27, 2015 1:23 pm

Re: [DEV] Thanks for posts

Post by heads » Mon Jul 27, 2015 1:25 pm

Did anyone manage to make this work with tapatalk? Currently using 2.0.2 in phpbb 3.1.5, it works well in browser, but tapatalk won't show any Thank/Like option when clicking a message.

pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: [DEV] Thanks for posts

Post by pathfinderenterprises » Tue Jul 28, 2015 12:01 pm

I have just installed this on my board and it has imported the 'Thanks count' from the old mod, and this is displayed at the bottom of the home page; but that is the only place anything is displayed :?

I am not able to thank anybody (thanks icon not showing in posts), I have checked for permissions but there is no option to allow 'thank for post' in any user permissions.

I am using prosilver style. I have not modified the style, but I do have quiet a few extensions enabled, are there any known conflicts or is there some setting I may have missed?

My board is www.havenownersforum.co.uk/index.php

pm me if you would like board access.
Keith


If everything seems to be going well, you have obviously overlooked something.

rxu
Extensions Development Team
Posts: 2955
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Jul 28, 2015 2:06 pm

About permissions viewtopic.php?p=14153331#p14153331
About adding styles support
viewtopic.php?p=14153361#p14153361

MDuss
Registered User
Posts: 46
Joined: Sat May 03, 2008 2:50 pm

Re: [DEV] Thanks for posts

Post by MDuss » Tue Jul 28, 2015 3:27 pm

John45 wrote:For some odd reason when you enable it for posts it tends to replace the quote button.
Same Problem here.
I can use the thank button, but when the thanks mod is enabled it replace the Quote Button, so i can give my thank to a post, but i can not use the Quote function with the button to Quote a post.

Is there any posibilities to solve this Problem?

Screen

In the Screen in the top you see the Buttons for my own post. There I have the Quote button.
The Postbuttons in the bottom are from an other user. Here I have the thanks button, but no Quote button.

MfG
MDuss

rxu
Extensions Development Team
Posts: 2955
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Jul 28, 2015 5:20 pm

Again, the issue is well known. The fix is rolling back ti the previous development state viewtopic.php?f=456&t=2259046&p=14153216#p14153216

The regular fix is to be applied after the phpBB 3.1.6 release.

pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: [DEV] Thanks for posts

Post by pathfinderenterprises » Tue Jul 28, 2015 6:12 pm

rxu wrote:About permissions viewtopic.php?p=14153331#p14153331
Permissions should apper under the groups forum permissions at the Misc tab (f.e. Can thank for posts), please recheck that.
There is no 'Misc Tab' under 'groups forum permissions' and in the 'Misc Tab' under 'forum permissions' there is no "Can thank for posts" option

I am looking at permission settings for 'Registered Users' group.
Keith


If everything seems to be going well, you have obviously overlooked something.

rxu
Extensions Development Team
Posts: 2955
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [DEV] Thanks for posts

Post by rxu » Tue Jul 28, 2015 6:21 pm

pathfinderenterprises wrote:There is no 'Misc Tab' under 'groups forum permissions'
From what version of MOD for phpBB 3.0 did you migrate?

pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: [DEV] Thanks for posts

Post by pathfinderenterprises » Tue Jul 28, 2015 6:30 pm

rxu wrote:
pathfinderenterprises wrote:There is no 'Misc Tab' under 'groups forum permissions'
From what version of MOD for phpBB 3.0 did you migrate?
I have no way of knowing now; I don't have any copies of my phpBB 3.0 board to refer to. I have always tried to keep all mods and phpBB versions up to date so I can only assume that it would have been the latest version of the mod. Sorry I can't be more accurate.
Keith


If everything seems to be going well, you have obviously overlooked something.

pathfinderenterprises
Registered User
Posts: 142
Joined: Fri Aug 04, 2006 5:14 pm
Location: Bolton
Contact:

Re: [DEV] Thanks for posts

Post by pathfinderenterprises » Tue Jul 28, 2015 9:20 pm

I don't know if this helpful but, I have just noticed that the "Has Thanked" and "Been Thanked" statistics were successfully migrated and show in the uses profile fields.
Keith


If everything seems to be going well, you have obviously overlooked something.

MDuss
Registered User
Posts: 46
Joined: Sat May 03, 2008 2:50 pm

Re: [DEV] Thanks for posts

Post by MDuss » Wed Jul 29, 2015 3:36 pm

rxu wrote:Again, the issue is well known. The fix is rolling back ti the previous development state viewtopic.php?f=456&t=2259046&p=14153216#p14153216

The regular fix is to be applied after the phpBB 3.1.6 release.
Thx rxu.

Now it works correct. :D

MFG
MDuss

CoinHELP
Registered User
Posts: 104
Joined: Fri Oct 16, 2009 6:41 pm

Re: [DEV] Thanks for posts

Post by CoinHELP » Thu Jul 30, 2015 11:05 am

I applied the fix from the previous page and still no button, still no permissions to even view thanks list. I am using AllanStyle-SUBSILVER.

I disabled and enable the extension, cleared cache, closed and opened browser, as well.

MDuss
Registered User
Posts: 46
Joined: Sat May 03, 2008 2:50 pm

Re: [DEV] Thanks for posts

Post by MDuss » Thu Jul 30, 2015 3:37 pm

MDuss wrote:
rxu wrote:Again, the issue is well known. The fix is rolling back ti the previous development state viewtopic.php?f=456&t=2259046&p=14153216#p14153216

The regular fix is to be applied after the phpBB 3.1.6 release.
Thx rxu.

Now it works correct. :D

MFG
MDuss
But now I have the button twice.
On Button is in the top left of the post under the post title, the other button is rightof the Quote button.

And is it normal that they are no more notification are in the forum and topic list like in the old thanks mod for phpbb 3.0.x?

MfG
MDuss

CoinHELP
Registered User
Posts: 104
Joined: Fri Oct 16, 2009 6:41 pm

Re: [DEV] Thanks for posts

Post by CoinHELP » Sun Aug 02, 2015 9:33 pm

I completed this process as stated in a previous post.
So, open up the viewtopic_body_post_buttons_list_after from the template/event folder,

Delete <ul class="post-buttons"> from line 3,

Delete </ul> from line 7,

Then rename the same file from viewtopic_body_post_buttons_list_after.html to viewtopic_body_post_buttons_after.html - ie removing the '_list'.

I've also had to create my custom template folder in ext/gfksx/ThanksForPosts/styles/customthemename and copy in everything from the ProSilver folder to get it all correct.

Also I've had to leave the file viewtopic_body_post_buttons_list_after.html in the prosilver folder but delete all the contents of the file, as it was still using that inheritance and putting the duplicate class and button in.
I copied the prosilver contents into my custom theme from the local unzipped thanks for post file. I am not sure if I was supposed to copy the prosilver content from my root to the new custom style.

However, if it doesn't matter then I still don't have thanks ability, button nor permissions to look at the thanks list. I am an admin. I also can't add the permission since it's not in misc.

Some of you are well above my knowledge range on PHP so please remember that general responses might leave out a detail or two and I will miss something.

Would someone please help me with my issue? I can provide screen shots or whatever you need to help me. I am trying my best to learn all this. I even looked for 3.0 code to delete in case that was the issue.

Any help would be much appreciated.

Locked

Return to “Extensions in Development”