[CDB] Board3 Portal 2.1.0-RC2

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
Kerrith
Registered User
Posts: 474
Joined: Mon Mar 28, 2005 10:16 am
Location: Pahoa, Hawaii
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Kerrith » Mon May 11, 2015 3:00 am

Kerrith wrote:I just uploaded board3 to ext directory and via ACP > Customise > Manage Extensions> I enabled Board3 Portal but I don't see what to do next. When I click on the word Portal on http://www.comcom121.org/phpBB/ it's a blank page.
Tip please,
Thanks,

Kerry

Update: I just installed B3P on our other forum http://www.comcom121.org/forums/app.php/portal and it works fine. What I see is that with the one in which Portal works there is am Extensions tab in the ACP > whereas with the forum that doesn't show the modules http://www.comcom121.org/phpBB/app.php/portal there is no Extensions tab.
Last edited by Kerrith on Mon May 11, 2015 9:10 pm, edited 1 time in total.

User avatar
TheLastDivision
Registered User
Posts: 4
Joined: Mon May 11, 2015 2:10 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by TheLastDivision » Mon May 11, 2015 4:18 pm

Hi,
I already posted this in the Styles Support Forum (viewtopic.php?f=481&t=2315296), but was advised to post here as it concerns extensions.

I did install the Board 3 Portal Extension and set up some costum blocks with images that act as a navigation box (looks like this now : http://thelastdivision.de/forum/app.php/portal).
As our community was mostly german when it was founded, the images had german text on them as well. Now the language shifted a bit more to english and other languages, so we have to adapt and make our forum (at least) bilingual.
For 'normal' text we just used the language variables and adapted them to our needs, but now I ran into the problem where I have images.

My first try was using the variable system from the style template, which looked like this :

Code: Select all

<!-- IF S_USER_LANG eq 'de' -->
<a href="http://thelastdivision.de/forum/viewtopic.php?f=85&t=91" class="postlink">
<img src="http://i.imgur.com/ZyXwZqF.png" class="postimage" alt="Vorstellung"></a>
<!-- ENDIF -->

<!-- IF S_USER_LANG eq 'en' -->
<a href="http://thelastdivision.de/forum/viewtopic.php?f=85&t=91" class="postlink">
<img src="http://i.imgur.com/k71WrtR.png" class="postimage" alt="Introduction"></a>
<!-- ENDIF -->
<br>
This however didn't work and thus showed the two buttons at the same time. Is there something wrong with the code or does the template code only work on styles and not on the costum portal boxes ?

Thanks in advance for any help given.

User avatar
LorenzoBR
Registered User
Posts: 11
Joined: Sun May 10, 2015 5:10 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by LorenzoBR » Tue May 19, 2015 1:11 am

*** This is for version 2.1.0-RC3 ***

Every time I go into portal from anywhere else while logged in, I get logged off.

Here is how the portal link is situated: Clicking on either home next to it or on the nav bar or ANYWHERE coming from portal, logs me out. The second blue nav bar is the Navigation Buttons Extension
http://s14.postimg.org/88zohlb6p/portal1.jpg

The Portal settings:
http://s24.postimg.org/lqpkqzwmd/portal2.jpg

List of other extensions in use on this particular board:
http://postimg.org/image/5hmcxyii7/

This board is on 3.1.4 Help!

(it did this in RC2 as well)

Kerrith
Registered User
Posts: 474
Joined: Mon Mar 28, 2005 10:16 am
Location: Pahoa, Hawaii
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Kerrith » Tue May 19, 2015 1:36 am

Hi LorenzoBR,

Where's the download for 2.1.0-RC3?

Thanks, Kerry

User avatar
LorenzoBR
Registered User
Posts: 11
Joined: Sun May 10, 2015 5:10 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by LorenzoBR » Tue May 19, 2015 3:57 am

Kerrith wrote:Hi LorenzoBR,

Where's the download for 2.1.0-RC3?

Thanks, Kerry
I found it on an Italian language site "somewhere" but for the life of me couldn't find it again. Life is like that sometimes! However, I still had the download of the RC3 and when I checked at github and clicked on download for the latest one listed there as RC2 it is an exact name match of Board3-Portal-2.1.x.zip and precise size match at 724kb

Try it and if not, I'll put the file I have up here for you.

https://github.com/board3/Board3-Portal

Kerrith
Registered User
Posts: 474
Joined: Mon Mar 28, 2005 10:16 am
Location: Pahoa, Hawaii
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Kerrith » Tue May 19, 2015 9:32 am

Thanks LorenzoBR,

I'm going to try a clean install of phpBB 3.1.4 because B3P 2.1.0-RC2 works with my other forum.

Aloha,

Kerry

User avatar
KillBill.
Registered User
Posts: 596
Joined: Tue Jun 02, 2009 4:07 pm
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by KillBill. » Thu May 21, 2015 7:39 am

Marc wrote:
KillBill. wrote:Hi Marc!

If disabled b3portal ext = bug

Code: Select all

Fatal error: Uncaught exception 'Symfony\Component\DependencyInjection\Exception\InvalidArgumentException' with message 'The service definition "board3.portal.version.check" does not exist.
fixed:

open ext/board3/portal/acp/portal_info.php


inline find (3 found)

Code: Select all

acl_a_manage_portal
inline replace

Code: Select all

ext_board3/portal && acl_a_manage_portal
Please add next release + update module table. ;)
Where does this exception pop up?
This bug is still not fixed.

1. Go ACP/Customise/Manage extensions - Board3 Portal :: Click Disable
2. Go ACP/Extensions/ and you can see the problem

The module permissions Read more: viewtopic.php?p=13526171#p13526171

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5387
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Marc » Thu May 21, 2015 3:08 pm

It's kind of hard to keep track of reported issues in this thread. This is also why I specifically refer to the issue tracker on github in the first post of this topic. I have now added your report to it: https://github.com/board3/Board3-Portal/issues/550

Kinsman
Registered User
Posts: 207
Joined: Sun Jan 02, 2005 6:04 am
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Kinsman » Sat May 23, 2015 10:58 am

Looking great so far, even on PBTech, I've never used Board3 before, so newbie question, is there a way to make it the homepage when someone visits your domain?

Currently they go to the forum (index.php) I have my own apache if I need to add something there?

http://jwtest.servegame.org/

User avatar
archivar
Registered User
Posts: 209
Joined: Sun Sep 13, 2009 1:00 pm
Location: Deutschland

Re: [RC] Board3 Portal 2.1.0-RC2

Post by archivar » Sun May 24, 2015 2:44 pm

Change the "htaccess"
htaccess
Best regards, Archivar
Sorry for my English Google Translation.

Kinsman
Registered User
Posts: 207
Joined: Sun Jan 02, 2005 6:04 am
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Kinsman » Sun May 24, 2015 9:08 pm

Perfect, thanks. :mrgreen:

Anonymous_et_EE
Registered User
Posts: 138
Joined: Sun Jul 07, 2013 2:27 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Anonymous_et_EE » Thu May 28, 2015 3:40 pm

Temporary estonian translation can be seen, and download here:
https://github.com/phpBBeesti/Board3Portal

sgtevmckay
Registered User
Posts: 200
Joined: Tue Apr 27, 2010 4:32 am
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by sgtevmckay » Fri May 29, 2015 6:41 am

where would be an appropriate area to make requests for "Modules", and report potential bugs???

Anonymous_et_EE
Registered User
Posts: 138
Joined: Sun Jul 07, 2013 2:27 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Anonymous_et_EE » Mon Jun 01, 2015 3:59 am

Estonian translation is now ready!

https://github.com/phpBBeesti/Board3Portal.

PR send it.

User avatar
KillBill.
Registered User
Posts: 596
Joined: Tue Jun 02, 2009 4:07 pm
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by KillBill. » Mon Jun 01, 2015 12:42 pm

1. bug
The team - module

If ACP use Manage team and added +1 group no see / The team portal module

2. ACP bug

If disabled every second module after click delete the disabled module
Result :: all disabled modules disappear!
If you reload the web page to appear in the disabled modules.

3. bug

If disabled all modules after enabled 1 module example Left Menu after go portal page = NO display module.

if enable 2 modules example Left Menu and Right User menu = Display Error

---------------------------------------

request: calendar module - next month use ajax :oops:

Locked

Return to “Extensions in Development”