[CDB] Board3 Portal 2.1.0-RC2

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
random_rodder
Registered User
Posts: 48
Joined: Thu Mar 05, 2015 12:30 am
Location: Florida, USA
Name: Brian Blake
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by random_rodder » Wed Aug 26, 2015 6:49 pm

I have an issue with a Moderator on my forum who cannot log in from his computer (Windows 8 using Firefox and I.E. 10) when the Board3 Portal Extension is active. If I disable the portal, he can log in. Even more confusing, if I use his login credentials on my PC, I can log in just fine with or without the portal being activated, regardless of the browser.

Anyone have any ideas what might be causing this weird behavior?

User avatar
nero
Registered User
Posts: 321
Joined: Fri Mar 13, 2015 8:18 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by nero » Wed Aug 26, 2015 7:23 pm

random_rodder wrote:I have an issue with a Moderator on my forum who cannot log in from his computer (Windows 8 using Firefox and I.E. 10) when the Board3 Portal Extension is active. If I disable the portal, he can log in. Even more confusing, if I use his login credentials on my PC, I can log in just fine with or without the portal being activated, regardless of the browser.

Anyone have any ideas what might be causing this weird behavior?
Try and get him to delete his cookies, and all temp files? Just a suggestion.

&&

Purge the cache in the ACP.

User avatar
random_rodder
Registered User
Posts: 48
Joined: Thu Mar 05, 2015 12:30 am
Location: Florida, USA
Name: Brian Blake
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by random_rodder » Wed Aug 26, 2015 7:33 pm

nero wrote:
Try and get him to delete his cookies, and all temp files? Just a suggestion.

&&

Purge the cache in the ACP.

Done both, but, I'm not opposed to doing so again. ;)

xneo70
Registered User
Posts: 66
Joined: Tue Jul 28, 2015 7:16 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by xneo70 » Thu Aug 27, 2015 4:22 pm

Hi.

No one knows an answer to my question?

I have some registered users that cannot see the portal. How can i apply permissions to see or not to see the portal?

Thanks.

arb
Registered User
Posts: 14
Joined: Tue Jun 15, 2010 2:45 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by arb » Thu Aug 27, 2015 4:54 pm

xneo70 wrote:Hi.

No one knows an answer to my question?

I have some registered users that cannot see the portal. How can i apply permissions to see or not to see the portal?

Thanks.
Go in ACP, click the tab Permissions, and then Group permissions, select: 'registered users' from the drop menu, click advanced permissions and select misc. Check 'yes' beside 'Can view the Portal'

xneo70
Registered User
Posts: 66
Joined: Tue Jul 28, 2015 7:16 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by xneo70 » Thu Aug 27, 2015 5:12 pm

that's it. Thanks man. Very good. many many thanks.

User avatar
random_rodder
Registered User
Posts: 48
Joined: Thu Mar 05, 2015 12:30 am
Location: Florida, USA
Name: Brian Blake
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by random_rodder » Tue Sep 01, 2015 3:33 pm

nero wrote:
Purge the cache in the ACP.
Well, this has been tried several times. After having no luck resolving the problem, I tried the Kiss portal as well, and the same user has the same problem - with either portal enabled, he cannot log in to the forum. When he tries to log in, the screen goes back to the portal page, he can view the forum, but cannot post, even though the Who Is Online shows him as being logged in. When the portal is deactivated, he can post and do whatever he wants as normal. So far, no other users have reported this problem - in fact, new users have signed up and posted without issue while the portals were active.

Mystifying....

..777..
Registered User
Posts: 150
Joined: Tue Oct 28, 2014 5:43 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by ..777.. » Thu Sep 03, 2015 3:37 pm

..777.. wrote:Hi, love your portal.

I am getting some weird spacing issue I was wondering if there is a fix for.

Thank you for your time.

http://imgur.com/TEV7KP7

http://imgur.com/8LCvZ25
Hi, this is still not fixed. Its messed up across a few of my styles. :(


Can I please get some help to fix this?

raypeatforum.com

User avatar
KillBill.
Registered User
Posts: 596
Joined: Tue Jun 02, 2009 4:07 pm
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by KillBill. » Thu Sep 03, 2015 11:14 pm

..777.. wrote:
..777.. wrote:Hi, love your portal.

I am getting some weird spacing issue I was wondering if there is a fix for.

Thank you for your time.

http://imgur.com/TEV7KP7

http://imgur.com/8LCvZ25
Hi, this is still not fixed. Its messed up across a few of my styles. :(


Can I please get some help to fix this?

raypeatforum.com
This no portal bug!

If I removed this css /ext/tatiana5/profileSideSwitcher your source code, it appears all is well.
You disable this extension.

-----------------------------------------------------------------
Other

portal rc3 bug if enabled all page example left block
portal css overwrites default phpBB css EX: <dt> 130% or 100% more block no good display!

This function can not be used.

Image
Last edited by KillBill. on Thu Sep 03, 2015 11:38 pm, edited 1 time in total.

..777..
Registered User
Posts: 150
Joined: Tue Oct 28, 2014 5:43 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by ..777.. » Thu Sep 03, 2015 11:28 pm

KillBill. wrote:This no portal bug!

If I removed this css /ext/tatiana5/profileSideSwitcher your source code, it appears all is well.
You disable this extension.
Thank you, I was able to resolve the issue now. :D

Other

portal rc3 bug if enabled all page example left block
portal css overwrites default phpBB css EX: <dt> 130% or 100% more block no good display!

This function can not be used.
Was this meant for me? I dont understand.

User avatar
KillBill.
Registered User
Posts: 596
Joined: Tue Jun 02, 2009 4:07 pm
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by KillBill. » Thu Sep 03, 2015 11:35 pm

..777.. wrote:Was this meant for me? I dont understand.
no :D

twc1968
Registered User
Posts: 1
Joined: Wed Sep 09, 2015 9:10 pm

Re: [RC] Board3 Portal 2.1.0-RC2

Post by twc1968 » Wed Sep 09, 2015 9:13 pm

Got it installed and it shows on the forums, but when I go to ACP and click on "EXTENSIONS" I get the below:

Code: Select all

Fatal error: Uncaught exception 'RuntimeException' with message 'Connection refused' in /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php:269 Stack trace: #0 /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php(227): phpbb\version_helper->get_versions(true, false) #1 /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php(206): phpbb\version_helper->get_versions_matching_stability(true, false) #2 /srv/disk10/1948976/www/campbellsweb.com/ext/board3/portal/includes/version_check.php(79): phpbb\version_helper->get_suggested_updates(true) #3 /srv/disk10/1948976/www/campbellsweb.com/ext/board3/portal/acp/portal_module.php(163): board3\portal\includes\version_check->check() #4 /srv/disk10/1948976/www/campbellsweb.com/includes/functions_module.php(674): board3\portal\acp\portal_module->main('\\board3\\portal\\...', 'config') #5 /srv/disk10/1948976/www/campbellsweb.com/adm/index.php(81): p_master->load_active() #6 {main} thrown in /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php on line 269
Any idea?

BriniaSona
Registered User
Posts: 387
Joined: Sun Sep 18, 2011 4:32 pm
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by BriniaSona » Fri Sep 11, 2015 9:28 pm

keep booting me from the ACP and logging me out

User avatar
Marc
Development Team Leader
Development Team Leader
Posts: 5408
Joined: Tue Oct 30, 2007 10:57 pm
Location: Munich, Germany
Name: Marc
Contact:

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Marc » Sat Sep 12, 2015 3:28 pm

KillBill. wrote: Other

portal rc3 bug if enabled all page example left block
portal css overwrites default phpBB css EX: <dt> 130% or 100% more block no good display!

This function can not be used.

Image
Should work better in the next version. There have been a few modifications to the CSS rules.
twc1968 wrote:Got it installed and it shows on the forums, but when I go to ACP and click on "EXTENSIONS" I get the below:

Code: Select all

Fatal error: Uncaught exception 'RuntimeException' with message 'Connection refused' in /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php:269 Stack trace: #0 /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php(227): phpbb\version_helper->get_versions(true, false) #1 /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php(206): phpbb\version_helper->get_versions_matching_stability(true, false) #2 /srv/disk10/1948976/www/campbellsweb.com/ext/board3/portal/includes/version_check.php(79): phpbb\version_helper->get_suggested_updates(true) #3 /srv/disk10/1948976/www/campbellsweb.com/ext/board3/portal/acp/portal_module.php(163): board3\portal\includes\version_check->check() #4 /srv/disk10/1948976/www/campbellsweb.com/includes/functions_module.php(674): board3\portal\acp\portal_module->main('\\board3\\portal\\...', 'config') #5 /srv/disk10/1948976/www/campbellsweb.com/adm/index.php(81): p_master->load_active() #6 {main} thrown in /srv/disk10/1948976/www/campbellsweb.com/phpbb/version_helper.php on line 269
Any idea?
Should also be fixed by the next version and shouldn't happen if www.board3.de is up.
BriniaSona wrote:keep booting me from the ACP and logging me out
Please check your cookie settings. If the domain is not configured correctly this might happen. Although this is probably not caused by the portal.

Miri4ever
Registered User
Posts: 409
Joined: Sat Mar 07, 2015 11:18 am

Re: [RC] Board3 Portal 2.1.0-RC2

Post by Miri4ever » Sun Sep 13, 2015 9:54 am

Miri4ever wrote:Why still using Icons ?? Why not replace with Font Awesome Icons, that work on every style and at every size. And often looking much better. I think all future Icon display is working with this one instead of classical old icons that must be loaded over images.

Font Awesome would looking much better und no more problems with paths or anything.


And still got no answer about this:

random_member.php
user_menu.php


If found this line of code inside both:

Code: Select all

get_user_rank($row['user_rank'], $row['user_posts'], $rank_title, $rank_img, $rank_img_src); 
What this function does, I needed to remove to work with topic realpostcount mod. Everything seems working fine, so wondering what this are needed for.
Still not answered and explained. Font Awesome Icons would look nicer and cause no more Problems. Also if this piece of code line is needed I quoted out.
Homepage: Terra Oceanica

Locked

Return to “Extensions in Development”