[CDB] RH Topic Tags

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
combuster
Registered User
Posts: 351
Joined: Sun Oct 26, 2008 11:58 pm

Re: [BETA] RH Topic Tags

Post by combuster »

FomenkoAndrey wrote:
when i use russian characters in tags, and go to that tags, i have url
http://site/tag/%25D0%25B1%25D0%25BB%25D1%258F
is converted to a safer representation internally
its bad and not correct.
will good or russian in an address, or a transliteration of characters.
Hi FomenkoAndrey,

while I totally understand that it is "nicer" to have a readable URL, it is NOT ALLOWED by the URL standard!

There exist several standards around Internet technology and one of these is the RFC1738 by the internet engineering task force. This RFC defines the Uniform Resoruce Locators (URL) https://www.ietf.org/rfc/rfc1738.txt (the current version from 2005 has the same unreserved characters http://tools.ietf.org/html/rfc3986 )

Now search on this page for "unreserved". You will find this:
lowalpha = "a" | "b" | "c" | "d" | "e" | "f" | "g" | "h" |
"i" | "j" | "k" | "l" | "m" | "n" | "o" | "p" |
"q" | "r" | "s" | "t" | "u" | "v" | "w" | "x" |
"y" | "z"
hialpha = "A" | "B" | "C" | "D" | "E" | "F" | "G" | "H" | "I" |
"J" | "K" | "L" | "M" | "N" | "O" | "P" | "Q" | "R" |
"S" | "T" | "U" | "V" | "W" | "X" | "Y" | "Z"

// ...

alpha = lowalpha | hialpha
digit = "0" | "1" | "2" | "3" | "4" | "5" | "6" | "7" |
"8" | "9"
safe = "$" | "-" | "_" | "." | "+"
extra = "!" | "*" | "'" | "(" | ")" | ","

unreserved = alpha | digit | safe | extra
This is what is allowed in an URL without encoding it! Any other character is not conforming to this standard. Most browsers can deal with it, but many systems don't. If we would develop without conformin to this standard, that would mean that some users might not be able to visit the tag-links.

Now the good thing is, that RH topic tags is developed in the way that all links conform to the standard which guarantees that the links work for all users on any device. However, you still can use a tag link with some (not all, e.g. "/" would break the url) special characters, because the decoder does not touch them.

The encoding was explicitly introduced to resolve issue #32: https://github.com/RobertHeim/phpbb-ext ... /issues/32
User avatar
DesignerMix
Registered User
Posts: 40
Joined: Thu Jul 17, 2014 11:03 am
Location: Russia, Belgorod
Contact:

Re: [BETA] RH Topic Tags

Post by DesignerMix »

combuster wrote:@DesignerMix could you disable all other extensions and try if the bug still exists?
I do it on local machine, but even when i disable and then i remove all data that extension save in DB problem stay. Then i uninstall RH Topic Tags and reinstall it - problem solved. Sorry if i cause inconvenience :oops: . Waiting for Release :arrow:
combuster
Registered User
Posts: 351
Joined: Sun Oct 26, 2008 11:58 pm

Re: [BETA] RH Topic Tags

Post by combuster »

DesignerMix wrote:
combuster wrote:@DesignerMix could you disable all other extensions and try if the bug still exists?
I do it on local machine, but even when i disable and then i remove all data that extension save in DB problem stay. Then i uninstall RH Topic Tags and reinstall it - problem solved. Sorry if i cause inconvenience :oops: . Waiting for Release :arrow:
I think I found the issue with this. At least there was a bug in some of the master branches when editing replies of a topic with tags: https://github.com/RobertHeim/phpbb-ext ... /issues/55 This is resolved in current master branch and will be in RC1.
combuster
Registered User
Posts: 351
Joined: Sun Oct 26, 2008 11:58 pm

Re: [RC] RH Topic Tags

Post by combuster »

The first Release Candidate has been published!

Note that it requires phpBB 3.1.4!

The first post of the topic contains the download links!

Changelog: viewtopic.php?p=13739006#p13739006

Have fun! =)
combuster
Registered User
Posts: 351
Joined: Sun Oct 26, 2008 11:58 pm

Re: [RC] RH Topic Tags

Post by combuster »

The extension was submitted to the Extensions DB!

Version 1.0.0 has been submitted to the extensions data base!

Changelog: viewtopic.php?p=13739006#p13739006

Have fun! =)
Richarda
Registered User
Posts: 6
Joined: Mon Jun 22, 2015 3:33 pm

Re: [RC] RH Topic Tags

Post by Richarda »

I installed this extension, but have a problem.
Image
There is no place to write the whitelist and the blacklist.
combuster
Registered User
Posts: 351
Joined: Sun Oct 26, 2008 11:58 pm

Re: [RC] RH Topic Tags

Post by combuster »

Richarda wrote:I installed this extension, but have a problem.
Image
There is no place to write the whitelist and the blacklist.
Strange, could you pleas go that page again and if you do not see the field hit "F5" (reload page). Is it now visible?
Richarda
Registered User
Posts: 6
Joined: Mon Jun 22, 2015 3:33 pm

Re: [RC] RH Topic Tags

Post by Richarda »

Very strange, I did refresh many times before and nothing, but now it's there!
Thanks!
User avatar
DesignerMix
Registered User
Posts: 40
Joined: Thu Jul 17, 2014 11:03 am
Location: Russia, Belgorod
Contact:

Re: [RC] RH Topic Tags

Post by DesignerMix »

Hello, i have some trouble, can you tell me if it is from my side or from extension?

Problem is:
I added tags to several topics on forum and if i click on tag from index or from actually topic - for one tag search work good, but for another it won't work (There are no topics tagged with any of these tags:). Beside in database and in ACP all tags exist.

I try recalculate tag-counts, but it won't help.

If it's important i use this regular expression:

Code: Select all

/^[\- a-zячсмитьбюэждлорпавыфйцукенгшщзхъёЯЧСМИТЬБЮЭЖДЛОРПАВЫФЙЦУКЕНГШЩЗХЁ0-9+]{2,60}$/i
Link to one of problem topic (it has 3 tags - FlashBench, тест-скорости, тестирование):
http://dmyt.ru/forum/viewtopic.php?f=52&t=724

Link to search result:
http://dmyt.ru/forum/app.php/tag/FlashBench

Update:
Can problem be connected with that i create tags which don't searchable before i updated to 0.0.14-RC1?
combuster
Registered User
Posts: 351
Joined: Sun Oct 26, 2008 11:58 pm

Re: [RC] RH Topic Tags

Post by combuster »

@DesignerMix I cannot access the tag search at your forum
User avatar
DesignerMix
Registered User
Posts: 40
Joined: Thu Jul 17, 2014 11:03 am
Location: Russia, Belgorod
Contact:

Re: [RC] RH Topic Tags

Post by DesignerMix »

@combuster, i try forum as guest and when i click at tag search working... But as i wrote earlier it works at some tag and won't work at another.

Example working tag search - http://dmyt.ru/forum/app.php/tag/%25D0% ... %25D0%25BE

And link i giving in previous message is example tag that won't search. I mean tag is exist, but when i search it by clicking at tag it show me nothing.

Hope i can explain now
combuster
Registered User
Posts: 351
Joined: Sun Oct 26, 2008 11:58 pm

Re: [RC] RH Topic Tags

Post by combuster »

@DesignerMixer do you have any white and/or blacklist entries enabled?

Ans what is your other configuration? Can you make a screenshot of your RH Topic Tags config?
Do you see the not working tags in the "manage tags" page in ACP?
User avatar
DesignerMix
Registered User
Posts: 40
Joined: Thu Jul 17, 2014 11:03 am
Location: Russia, Belgorod
Contact:

Re: [RC] RH Topic Tags

Post by DesignerMix »

combuster wrote:do you have any white and/or blacklist entries enabled?
Blacklist is on, whitelist is off (it will be on screenshot). But i try off blacklist and nothing changes.
combuster wrote:Ans what is your other configuration? Can you make a screenshot of your RH Topic Tags config?
BlackList - https://yadi.sk/i/nyqA1dCshpi5T
WhiteList - https://yadi.sk/i/BJGzpS3Vhpi6n
Main setting - https://yadi.sk/i/LZ7yBuzihpi6z
combuster wrote:Do you see the not working tags in the "manage tags" page in ACP?
There list of my tags at manage tag page - https://yadi.sk/i/ryLcsM-Ahpi7b
Tag FlashBench is in this list but it not works. Some other tags from this list not works to, but other works fine :?
svennson
Registered User
Posts: 60
Joined: Wed Jun 01, 2005 4:54 pm
Location: Belguim
Contact:

Re: [RC] RH Topic Tags

Post by svennson »

I cannot see the whitelist/blacklist field to enter new tags. (clean forum -only different style-)
Image

Not sure what I am missing. (i tried the git version)

This was the page : http://dumptext.com/06msRen5

// edit
F5 din't work, so I cleared my cache, however I still find it weird, as I run "Hercompileer oude stijl componenten:yes" recompile old style elements.

// edit 2

Still not working, perhaps this is style related.

// edit 3
I removed the extension completely (even "remove data" from acp); then removed it from ssh (files gone); then recopy from git; installed, -same issue as above-; cleaned cache; now its working as intended. (even whitelisting)

// edit 4
I guess there is a limit to how many words can be whitelisted ?

Code: Select all

SQL ERROR [ mysqli ]

Data too long for column 'config_value' at row 1 [1406]

SQL

UPDATE phpbb3_config SET config_value = '[\"huren\",\"kopen\",\"lenen\",\"erfenis\",\"test\",\"tezaead\",\"ezadezda\",\"dazedazeda\",\"zedzedddd\",\"ezdzedzedeed\",\"eazezaeaze\",\"eazezaead\",\"azdrcrec\",\"dfgstgerv\",\"rvrte\",\"rfgerf\",\"qsds\",\"fezfzefz\",\"dezdzedez\",\"peer\",\"appel\",\"groen\",\"geel\",\"rood\",\"blauw\",\"oranje\",\"boompje\"]' WHERE config_name = 'robertheim_topictags_whitelist'

BACKTRACE
elawrenc
Registered User
Posts: 136
Joined: Thu Jul 21, 2011 2:41 pm

Re: [RC] RH Topic Tags

Post by elawrenc »

I like this theme, it's really well developed.
Locked

Return to “Extensions in Development”