[BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
JoshyPHP
Code Contributor
Posts: 756
Joined: Mon Jul 11, 2011 12:28 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by JoshyPHP » Fri Sep 29, 2017 8:33 pm

I don't know. If you post a link after the extension is installed then it should be replaced by the video. Try a new post and make sure the extension is installed and enabled. Check for conflicting extensions too. A custom YouTube BBCode could interfere with it too.
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

User avatar
RomaamoR
Registered User
Posts: 78
Joined: Tue Feb 24, 2015 4:45 pm
Contact:

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by RomaamoR » Fri Sep 29, 2017 9:43 pm

iframe.
It would be beautiful. Inserting a video.

rxu
Extensions Development Team
Posts: 2770
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by rxu » Fri Oct 06, 2017 1:57 am

Can't say if it's a bug or intended behavior:
if you use a starting point to play Youtube video, f.e. https://youtu.be/is8GEEwJSVM?t=9m0s, it starts from 9 min as it should. But if you skip the seconds here, like https://youtu.be/is8GEEwJSVM?t=9m, it starts from the 0 mins 9 sec point instead. If you follow the latter link in the browser, it starts ok (from the 9 mins point).

User avatar
JoshyPHP
Code Contributor
Posts: 756
Joined: Mon Jul 11, 2011 12:28 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by JoshyPHP » Fri Oct 06, 2017 8:26 am

I'd call the behaviour expected; I have encountered 3 kinds of timestamps generated by YouTube: t=X, t=XhXmXs and t=XmXs, where X is a number. The embedded player only accepts the first kind so we need to do some arithmetic to convert the other two. Adding more timestamp formats increases the template's complexity, that's why it only covers real-world usage rather than any theoretical input. Do you know how that link was generated?
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

rxu
Extensions Development Team
Posts: 2770
Joined: Wed Oct 25, 2006 12:46 pm
Location: Siberia, Russian Federation
Name: Ruslan
Contact:

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by rxu » Fri Oct 06, 2017 1:46 pm

JoshyPHP wrote:
Fri Oct 06, 2017 8:26 am
Do you know how that link was generated?
Yes. F.e. open Youtube video page in browser (paused), set the time slider at 9.00 mins, then click "Share" below and check the "Start at:" checkbox in the window opened. The link generated will get t=9m parameter (without seconds).

User avatar
JoshyPHP
Code Contributor
Posts: 756
Joined: Mon Jul 11, 2011 12:28 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by JoshyPHP » Fri Oct 06, 2017 4:05 pm

Alright, then I'm going to look for a solution that's backward compatible. Until then you can get a link with the timestamp in seconds by right-clicking on the video and choosing "Copy video URL at current time". Thanks for the heads up.
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

Mick2015
Registered User
Posts: 38
Joined: Sun Feb 02, 2014 9:58 pm
Location: Newcastle
Name: michael lambert
Contact:

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by Mick2015 » Fri Oct 20, 2017 3:50 pm

nice plugin working great on my forum, jsut wanting to ask is their a way to add the following sites to this extension

Raptr Plays.tv

User avatar
JoshyPHP
Code Contributor
Posts: 756
Joined: Mon Jul 11, 2011 12:28 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by JoshyPHP » Fri Oct 20, 2017 3:58 pm

Plays.tv is already supported, you just need to use a VOD URL such as https://plays.tv/video/59e91b3c9b6c0c3fc6

Raptr is half past dead and should be offline any day now: http://about.raptr.com/goodbye-raptr/
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

Mick2015
Registered User
Posts: 38
Joined: Sun Feb 02, 2014 9:58 pm
Location: Newcastle
Name: michael lambert
Contact:

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by Mick2015 » Fri Oct 20, 2017 6:01 pm

JoshyPHP wrote:
Fri Oct 20, 2017 3:58 pm
Plays.tv is already supported, you just need to use a VOD URL such as https://plays.tv/video/59e91b3c9b6c0c3fc6

Raptr is half past dead and should be offline any day now: http://about.raptr.com/goodbye-raptr/
thanksf or the reply and just noticed was wasnt posting the correct link on my forum and for raptr its a shame if it dos :cry:

User avatar
libralion
Registered User
Posts: 335
Joined: Tue May 13, 2003 9:25 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by libralion » Sun Oct 29, 2017 11:53 am

Hi everybody,
I try to add a vidme video to my board. According to the manual of this extension I should just add the url.
I did that, but the video isn't displayed. I only see the link.
This is the link: https://vid.me/SeBee
What can I do?

Johanna

User avatar
JoshyPHP
Code Contributor
Posts: 756
Joined: Mon Jul 11, 2011 12:28 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by JoshyPHP » Sun Oct 29, 2017 7:19 pm

The extension depends on the s9e\TextFormatter library that's bundled with phpBB and the version that's currently bundled isn't up to date with Vidme's current website.

Until it gets updated you can post Vidme's videos manually like this: [media=vidme]SeBee[/media]
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

User avatar
libralion
Registered User
Posts: 335
Joined: Tue May 13, 2003 9:25 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by libralion » Mon Oct 30, 2017 4:45 am

JoshyPHP wrote:
Sun Oct 29, 2017 7:19 pm
The extension depends on the s9e\TextFormatter library that's bundled with phpBB and the version that's currently bundled isn't up to date with Vidme's current website.

Until it gets updated you can post Vidme's videos manually like this: [media=vidme]SeBee[/media]
Thanks a lot. That works like a charm. 😃
Will this code still work after the update?

Johanna

User avatar
JoshyPHP
Code Contributor
Posts: 756
Joined: Mon Jul 11, 2011 12:28 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by JoshyPHP » Mon Oct 30, 2017 5:31 am

Yes, as long as Vidme is supported that code is supported.
I wrote the thing that does the BBCodes in 3.2. Unless it broke yours, in which case it was somebody else with a similar name.

User avatar
libralion
Registered User
Posts: 335
Joined: Tue May 13, 2003 9:25 am

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by libralion » Mon Oct 30, 2017 5:59 am

JoshyPHP wrote:
Mon Oct 30, 2017 5:31 am
Yes, as long as Vidme is supported that code is supported.
Great! Thanks Josh. :)

Johanna

maco8024
Registered User
Posts: 7
Joined: Tue Aug 09, 2016 2:44 pm
Location: Altay

Re: [BETA] s9e/mediaembed - Embed videos and third-party content without a single BBCode

Post by maco8024 » Mon Oct 30, 2017 7:22 am

Hi, Mail.ru portal is not working, the extension is installed, the link example https://altaygarden.ru/viewtopic.php?p=346#p346 :?:

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: No registered users and 14 guests

cron