[RC] phpBB Gallery

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Thu Dec 17, 2015 11:02 pm

Siava wrote:
Satanasov wrote:1. Please explain. I don't get it.
See example search by word 'pic': https://siava.ru/forum/gallery/search?keywords=pic
Try go to 2nd and other pages of search results.

forum config:
URL Rewriting is enabled in server configuration.
URL forced settings to https:// protocol, 443 port, path /forum.
I will take a look at this ...

About 2:

There is pagination

Image

Image
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Thu Dec 17, 2015 11:09 pm

Siava wrote:
Satanasov wrote:1. Please explain. I don't get it.
See example search by word 'pic': https://siava.ru/forum/gallery/search?keywords=pic
Try go to 2nd and other pages of search results.

forum config:
URL Rewriting is enabled in server configuration.
URL forced settings to https:// protocol, 443 port, path /forum.
This is routing issue ...

Have you used some .htaccess forwarding or rewriting?
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

User avatar
Siava
Registered User
Posts: 134
Joined: Wed Jan 26, 2005 10:07 am
Contact:

Re: [BETA] phpBB Gallery

Post by Siava » Thu Dec 17, 2015 11:15 pm

Satanasov wrote: About 2:

There is pagination

Image

Image
I mean another pagination.
For example, I want to move a lot of images from gallery one to gallery two.
Open any gallery, go to moderation panel >> moderate album >> queue (see my screenshot). There is no pagination...
This is routing issue ...

Have you used some .htaccess forwarding or rewriting?
I think this is conflict with Ultimate SEO.. I remembered that another extension had similar problems. Try to fix myself.

User avatar
GoBieN
Registered User
Posts: 538
Joined: Fri Mar 05, 2004 5:22 pm
Location: Belgium
Contact:

Re: [BETA] phpBB Gallery

Post by GoBieN » Thu Dec 17, 2015 11:17 pm

Satanasov wrote:Can you check if you can access the log from ACP->Extesnions -> phpBB Gallery -> logs.
Confirmed. From "Extensions -> phpBB Gallery - Log" it works fine. Only from maintenance tab it doesn't.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Thu Dec 17, 2015 11:21 pm

GoBieN wrote:
Satanasov wrote:Can you check if you can access the log from ACP->Extesnions -> phpBB Gallery -> logs.
Confirmed. From "Extensions -> phpBB Gallery - Log" it works fine. Only from maintenance tab it doesn't.
I think this is using requesting the old module ...
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Thu Dec 17, 2015 11:22 pm

Siava wrote:
Satanasov wrote: About 2:

There is pagination

Image

Image
I mean another pagination.
For example, I want to move a lot of images from gallery one to gallery two.
Open any gallery, go to moderation panel >> moderate album >> queue (see my screenshot). There is no pagination...
This is routing issue ...

Have you used some .htaccess forwarding or rewriting?
I think this is conflict with Ultimate SEO.. I remembered that another extension had similar problems. Try to fix myself.
No pagination in top right corner? And you have more then 15 images in that album?
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

User avatar
GoBieN
Registered User
Posts: 538
Joined: Fri Mar 05, 2004 5:22 pm
Location: Belgium
Contact:

Re: [BETA] phpBB Gallery

Post by GoBieN » Thu Dec 17, 2015 11:27 pm

Satanasov wrote: I think this is using requesting the old module ...
If I disable the gallery extension there is no longer a link to Gallery Log in Maintenance tab. So I think it's not with the old module.

But in Module management I checked and in extensionstab the ACP_GALLERY_LOGS is pointing to the correct module file. But in Maintenance tab it's not. I have changed this manually and the error is gone.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Thu Dec 17, 2015 11:29 pm

GoBieN wrote:
Satanasov wrote: I think this is using requesting the old module ...
If I disable the gallery extension there is no longer a link to Gallery Log in Maintenance tab. So I think it's not with the old module.

But in Module management I checked and in extensionstab the ACP_GALLERY_LOGS is pointing to the correct module file. But in Maintenance tab it's not. I have changed this manually and the error is gone.
This, I think, is a common mistake when upgrading from 3.0 - by some strange reason the log in maintenance is not cleared, so it is not linked to the new module.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Thu Dec 17, 2015 11:29 pm

GoBieN wrote:
Satanasov wrote: I think this is using requesting the old module ...
If I disable the gallery extension there is no longer a link to Gallery Log in Maintenance tab. So I think it's not with the old module.

But in Module management I checked and in extensionstab the ACP_GALLERY_LOGS is pointing to the correct module file. But in Maintenance tab it's not. I have changed this manually and the error is gone.
This, I think, is a common mistake when upgrading from 3.0 - by some strange reason the log in maintenance is not cleared, so it is not linked to the new module.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

User avatar
Siava
Registered User
Posts: 134
Joined: Wed Jan 26, 2005 10:07 am
Contact:

Re: [BETA] phpBB Gallery

Post by Siava » Fri Dec 18, 2015 9:55 am

Satanasov wrote:
Siava wrote:
Satanasov wrote: About 2:

There is pagination

Image

Image
I mean another pagination.
For example, I want to move a lot of images from gallery one to gallery two.
Open any gallery, go to moderation panel >> moderate album >> queue (see my screenshot). There is no pagination...

No pagination in top right corner? And you have more then 15 images in that album?
Exactly!

P.S.
I'm sorry... it was my mistake :oops:
Fixed!
Last edited by Siava on Fri Dec 18, 2015 1:32 pm, edited 1 time in total.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Fri Dec 18, 2015 11:12 am

Siava wrote:
Satanasov wrote:
Siava wrote:
Satanasov wrote: About 2:

There is pagination

Image

Image
I mean another pagination.
For example, I want to move a lot of images from gallery one to gallery two.
Open any gallery, go to moderation panel >> moderate album >> queue (see my screenshot). There is no pagination...

No pagination in top right corner? And you have more then 15 images in that album?
Exactly!
Really tried but can't replicate.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

gecko1977
Registered User
Posts: 1
Joined: Fri Dec 18, 2015 12:41 pm

Re: [BETA] phpBB Gallery

Post by gecko1977 » Fri Dec 18, 2015 1:17 pm

Need some help:
Web host is godaddy
www.ohioabdl.com
In the root of the website I have wordpress installed
I have PHPbb 3.1 installed in folder www.ohioabdl.com/forums

It does not matter if I have the url re-write turned on or off in PHPBB, I get a 404 error when I click the gallery link at the top right of the board.

If I go into my UCP I can create an album, edit it, delete it, but if I try to either go to the album or upload, I get a 404 error

a user account you can use is demouser1 with pass of Demo12

User avatar
Siava
Registered User
Posts: 134
Joined: Wed Jan 26, 2005 10:07 am
Contact:

Re: [BETA] phpBB Gallery

Post by Siava » Fri Dec 18, 2015 1:45 pm

Satanasov wrote:Really tried but can't replicate.
I'm sorry... in was my mistake. I forgot update moderate.php.. :oops:

Another one found.
EXIF metadata always shows only for admin, anyway enabled or disabled it in ucp.
Other registered users doesn't view EXIF.

User avatar
Siava
Registered User
Posts: 134
Joined: Wed Jan 26, 2005 10:07 am
Contact:

Re: [BETA] phpBB Gallery

Post by Siava » Fri Dec 18, 2015 1:48 pm

gecko1977 wrote: If I go into my UCP I can create an album, edit it, delete it, but if I try to either go to the album or upload, I get a 404 error
Looks like url rewrite problems.
If URL rewrite enabled in server configuration the .htaccess file in /forums/ dir must contain

Code: Select all

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Fri Dec 18, 2015 3:57 pm

Siava wrote:
Satanasov wrote:Really tried but can't replicate.
I'm sorry... in was my mistake. I forgot update moderate.php.. :oops:

Another one found.
EXIF metadata always shows only for admin, anyway enabled or disabled it in ucp.
Other registered users doesn't view EXIF.
Hah! I will take look at this. :)
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Locked

Return to “Extensions in Development”