[RC] phpBB Gallery

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Fri Feb 27, 2015 10:24 pm

scoub29 wrote:Hello,

Is it possible to hide private album for guest ? Actually, guest could see album whith an interdiction pict.

Image

Best regards ;) .
Hello there - I will see what I can do. If not in the final release in 1.2.1 it will be fixed.

Adding it to the bug report ...
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Mon Mar 02, 2015 2:20 am

Ok. Some bugfixes:

Now you are unable to see album if the permission can see album is set to no (previously - it showed no access).
Now you have a contact field that links to user gallery (Controllable in settings).
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

User avatar
thebigmattb
Registered User
Posts: 47
Joined: Tue Jan 29, 2008 8:21 pm
Location: Sheffield, UK

Re: [BETA] phpBB Gallery

Post by thebigmattb » Mon Mar 02, 2015 8:37 pm

Lucifer4o any chance you are going to move where the gallery icon appears? Currently on my test board it is on the right after the user ID. Any chance you could move it to the left along with FAQ etc. If not can you add it before the user name?

I am a bit OCD when it comes to the appearance of my forum and the drop down user menu in my mind belongs far right. :)

Also on another note a "Personal albums" Link on the drop down menu (where User CP is etc) Would be cool :ugeek:

User avatar
tamarin
Registered User
Posts: 117
Joined: Tue Feb 03, 2015 9:02 pm
Location: Germany
Name: Ed

Re: [BETA] phpBB Gallery

Post by tamarin » Tue Mar 03, 2015 6:32 am

I clicked on the Gallery log in ACP and happened this:

Code: Select all

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 563
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
Can you help me please?
Thank you.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Tue Mar 03, 2015 3:09 pm

thebigmattb wrote:Lucifer4o any chance you are going to move where the gallery icon appears? Currently on my test board it is on the right after the user ID. Any chance you could move it to the left along with FAQ etc. If not can you add it before the user name?

I am a bit OCD when it comes to the appearance of my forum and the drop down user menu in my mind belongs far right. :)

Also on another note a "Personal albums" Link on the drop down menu (where User CP is etc) Would be cool :ugeek:
OK. Moving icons left and right is going to be troublesome. This is not something that depends entirely on me. I could, probably, hack something up but this will not be so how the extensions are supposed to be build. I will see what kind of events I have and I will do it.

Link to the personal album is a good idea ... I will need some time and will probably leave it for 1.2.1
tamarin wrote:I clicked on the Gallery log in ACP and happened this:

Code: Select all

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 563
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
Can you help me please?
Thank you.

Please provide more of the log. This is something that I can't reproduce.

I have favor to ask - can you check if you can see the new contact field for users with personal albums (one on vewprofile and one on the contacts in the small profile on posts), because there seems to be some issue with travis and dynamically added CPFs.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

elawrenc
Registered User
Posts: 122
Joined: Thu Jul 21, 2011 2:41 pm

Re: [BETA] phpBB Gallery

Post by elawrenc » Tue Mar 03, 2015 4:31 pm

This may be due to not having all the module activated in the ACP.

I noticed that when I migrated from the old gallery on the 3.0 board to 3.1 and beyond, there were still some remnants in the DB that would cause errors in the ACP.

Most of these issues were fixed by going into SYSTEM >MODULE MANAGEMENT>ADMINISTRATION CONTROL PANEL>Extensions>PhpBB Gallery and adding the required modules. But I still get an error when I try to go into Configure Gallery

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/ext/phpbbgallery/core/acp/config_module.php
LINE: 27
CALL: trigger_error()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: phpbbgallery\core\acp\config_module->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()


So I think there is some database cleanup to do. Or at least an entry needs to be added that's not there.

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Tue Mar 03, 2015 4:36 pm

elawrenc wrote:This may be due to not having all the module activated in the ACP.

I noticed that when I migrated from the old gallery on the 3.0 board to 3.1 and beyond, there were still some remnants in the DB that would cause errors in the ACP.

Most of these issues were fixed by going into SYSTEM >MODULE MANAGEMENT>ADMINISTRATION CONTROL PANEL>Extensions>PhpBB Gallery and adding the required modules. But I still get an error when I try to go into Configure Gallery

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/ext/phpbbgallery/core/acp/config_module.php
LINE: 27
CALL: trigger_error()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: phpbbgallery\core\acp\config_module->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()


So I think there is some database cleanup to do. Or at least an entry needs to be added that's not there.
Please remove all modules related to the gallery before activating it for first time. ACP and UCP modules will overwrite routes to the new modules and you will have this error. Fix is - Go to ACP -> System -> Administrator control Panel -> Extensions -> Gallery and remove all modules, then add them manually.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

mj1985
Registered User
Posts: 79
Joined: Sun Oct 18, 2009 9:11 pm

Re: [BETA] phpBB Gallery

Post by mj1985 » Thu Mar 05, 2015 4:19 pm

Hey,
I just installed the extension, works fine so far.
I also use phpbbseo (the extension), and would like to keep my old URLs before migration.

This is the old mod:
http://downloads.phpbb-seo.com/phpbb-se ... ry-70.html
(I think that is not the latest mod, I might find the latest zip in my download-folder)

Should I ask you or the phpbbseo developer to update the mod?
www.drhouse-forum.de - House MD Forum

scoub29
Registered User
Posts: 9
Joined: Mon Nov 10, 2014 12:24 pm

Re: [BETA] phpBB Gallery

Post by scoub29 » Fri Mar 06, 2015 10:07 am

Lucifer4o wrote:Ok. Some bugfixes:

Now you are unable to see album if the permission can see album is set to no (previously - it showed no access).
Now you have a contact field that links to user gallery (Controllable in settings).
Thank you very much :)

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Fri Mar 06, 2015 11:54 am

mj1985 wrote:Hey,
I just installed the extension, works fine so far.
I also use phpbbseo (the extension), and would like to keep my old URLs before migration.

This is the old mod:
http://downloads.phpbb-seo.com/phpbb-se ... ry-70.html
(I think that is not the latest mod, I might find the latest zip in my download-folder)

Should I ask you or the phpbbseo developer to update the mod?
Please do - this is new extension with new ways to build the URLs. He should take a look and corect his rom, or better yet - if he can make a "switchable" patch for core it will be appritiated. If not - I can set this for 1.2.2 and add it my self.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

mj1985
Registered User
Posts: 79
Joined: Sun Oct 18, 2009 9:11 pm

Re: [BETA] phpBB Gallery

Post by mj1985 » Fri Mar 06, 2015 2:10 pm

Thank you!

Just an ordinary questions, do you prefer bugreports here or through github?
www.drhouse-forum.de - House MD Forum

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Fri Mar 06, 2015 5:01 pm

mj1985 wrote:Thank you!

Just an ordinary questions, do you prefer bugreports here or through github?
Wherever you prefer. But in GitHub I can track it better.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

elawrenc
Registered User
Posts: 122
Joined: Thu Jul 21, 2011 2:41 pm

Re: [BETA] phpBB Gallery

Post by elawrenc » Sun Mar 08, 2015 4:26 am

I followed your fix instructions but Configure Gallery is still not working properly.

General Error
No mode specified.

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/ext/phpbbgallery/core/acp/config_module.php
LINE: 27
CALL: trigger_error()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: phpbbgallery\core\acp\config_module->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()

Any ideas?

Satanasov
Registered User
Posts: 1180
Joined: Sun Jul 29, 2012 5:48 am
Name: Stanislav Atanasov
Contact:

Re: [BETA] phpBB Gallery

Post by Satanasov » Sun Mar 08, 2015 5:03 pm

Ok ... please remove modules from System -> Admin control panel and add them one by one.
For list of all my extensions go to https://github.com/satanasov
If you want custom functions in some of my products - PM me and we will discuss it.

elawrenc
Registered User
Posts: 122
Joined: Thu Jul 21, 2011 2:41 pm

Re: [BETA] phpBB Gallery

Post by elawrenc » Sun Mar 08, 2015 7:38 pm

That's what I have done but for some reason everything else works except Configure Gallery.

Locked

Return to “Extensions in Development”