Page 55 of 85

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 3:40 pm
by Fast_Eddie
This part?
phpbb.phpbb_gallery_albums] status: OK
phpbb.phpbb_gallery_albums_track] status: OK
phpbb.phpbb_gallery_comments] status: OK
phpbb.phpbb_gallery_contests] status: OK
phpbb.phpbb_gallery_favorites] status: OK
phpbb.phpbb_gallery_images] status: OK
phpbb.phpbb_gallery_log] status: OK
phpbb.phpbb_gallery_modscache] status: OK
phpbb.phpbb_gallery_permissions] status: OK
phpbb.phpbb_gallery_rates] status: OK
phpbb.phpbb_gallery_reports] status: OK
phpbb.phpbb_gallery_roles] status: OK
phpbb.phpbb_gallery_users] status: OK
phpbb.phpbb_gallery_watch] status: OK

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 3:46 pm
by Fast_Eddie
I just looked directly ( i think) at the db table and the status for all images is ''1''

Here is something odd I noticed in the admin logs, though it does not look related to gallery

Code: Select all

Anonymous 	208.115.113.94 	Wed Dec 16, 2015 1:33 pm 	Images from posts cleared thumbnails cache

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 3:50 pm
by Satanasov
Fast_Eddie wrote:I just looked directly ( i think) at the db table and the status for all images is ''1''
There is column in phpbb_gallery_images called image_filemissing ... there should be 0

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 3:54 pm
by Fast_Eddie
yes, they are all 0

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 3:59 pm
by Satanasov
Siava wrote:Now search by author is ok!
But where no pagination in search results.
Siava - fixed now ... few months back I was experimenting with something and it appears I have forgot to revert the changes ...

Please update and test.

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 4:02 pm
by Satanasov
Fast_Eddie wrote:yes, they are all 0
Please send me a pm with your board link and some test user so I can take a look.

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 4:15 pm
by Fast_Eddie
ok, all set. and thank you

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 8:06 pm
by GoBieN
I have updated the gallery yesterday to the latest from github. It's working excellent I created a number of albums and added images. I have only one small problem.
When in the ACP I check under maintenance there is a Gallery Log but it throws an error when trying to open that Gallery Log. I translated the first 2 lines to English.

Code: Select all

General Error
Module not accessible[*]

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 563
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 8:38 pm
by Satanasov
GoBieN wrote:I have updated the gallery yesterday to the latest from github. It's working excellent I created a number of albums and added images. I have only one small problem.
When in the ACP I check under maintenance there is a Gallery Log but it throws an error when trying to open that Gallery Log. I translated the first 2 lines to English.

Code: Select all

General Error
Module not accessible[*]

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/functions_module.php
LINE: 563
CALL: trigger_error()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
I don't know why is this happening ... please check if you are not use old module.

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 8:50 pm
by Calman
Sorry to drop in the middle of this technical convo ..

I just wanted to say that I am really looking forward to a new phpBB Gallery, as I tried to bridge a client forum with Coppermine and hit nothing but problems, so this is "one to watch" for myself.

Keep up the great work!

All the best,
Cal :)

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 9:09 pm
by GoBieN
Satanasov wrote: I don't know why is this happening ... please check if you are not use old module.
Before I upgraded to 3.1, I removed all non default ACP/MCP/UCP modules using the STK.
Furthermore I replaced all files with default files.
Furthermore I removed all extra tables and rows using the STK.
After that I upgraded to 3.1. I installed the gallery from fresh did not import old data.
It would surprise me that an old module would still be present.

Can you confirm that in the new version there should be a link for Gallery log under maintenance?

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 9:43 pm
by Satanasov
GoBieN wrote:
Satanasov wrote: I don't know why is this happening ... please check if you are not use old module.
Before I upgraded to 3.1, I removed all non default ACP/MCP/UCP modules using the STK.
Furthermore I replaced all files with default files.
Furthermore I removed all extra tables and rows using the STK.
After that I upgraded to 3.1. I installed the gallery from fresh did not import old data.
It would surprise me that an old module would still be present.

Can you confirm that in the new version there should be a link for Gallery log under maintenance?
https://github.com/satanasov/phpbbgalle ... #L100-L105

Here is where it is defined.

Can you check if you can access the log from ACP->Extesnions -> phpBB Gallery -> logs.

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 10:07 pm
by Siava
Satanasov wrote:
Siava wrote:Now search by author is ok!
But where no pagination in search results.
No paggination?

I will dig in to this.
Thank you!
I don't know why, but path to 2nd and other pages is duplicated in this pagination of search results:
http://mydomain/forum/gallery/forum/gal ... ...deleted.....

2.
Another missed pagination in Moderator Control Panel of any album. Moderate album >> Queue.
In the bottom right of this page:
Image


3.
Moderator Control Panel link shows for any registered user in header of main album page.

4.
Still not fixed...
viewtopic.php?p=14258676#p14258676

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 10:43 pm
by Satanasov
Siava wrote:
Satanasov wrote:
Siava wrote:Now search by author is ok!
But where no pagination in search results.
No paggination?

I will dig in to this.
Thank you!
I don't know why, but path to 2nd and other pages is duplicated in this pagination of search results:
http://mydomain/forum/gallery/forum/gal ... ...deleted.....

2.
Another missed pagination in Moderator Control Panel of any album. Moderate album >> Queue.
In the bottom right of this page:
Image


3.
Moderator Control Panel link shows for any registered user in header of main album page.

4.
Still not fixed...
viewtopic.php?p=14258676#p14258676
1. Please explain. I don't get it.

2. I will take a look.

3. If the user has any m_ ACL they will see it. I will fix it in future versions.

4. I will do my best ... but I think I was unable to reproduce it ...

Re: [BETA] phpBB Gallery

Posted: Thu Dec 17, 2015 10:58 pm
by Siava
Satanasov wrote:1. Please explain. I don't get it.
See example search by word 'pic': https://siava.ru/forum/gallery/search?keywords=pic
Try go to 2nd and other pages of search results.

forum config:
URL Rewriting is enabled in server configuration.
URL forced settings to https:// protocol, 443 port, path /forum.