[CDB] mChat

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
User avatar
alex75
Registered User
Posts: 358
Joined: Sun Jun 10, 2012 9:09 am
Location: Italy
Name: Alessandro
Contact:

Re: [DEV] mChat

Post by alex75 » Tue Dec 29, 2015 2:49 pm

you are right! I confirm that quote one message containing "123" nothing happens; He does not write anything!

User avatar
evilpeppard
Registered User
Posts: 75
Joined: Wed Jan 30, 2008 6:05 pm
Location: Denver, CO USA

Re: [DEV] mChat

Post by evilpeppard » Tue Dec 29, 2015 5:07 pm

I initially had this same issue. Using phpBB 3.1.6, getting an error when trying to install the 0.3.2 version. I even tried clearing the data, but still get this same error quoted below.

I ended up completely deleting the 'mchat' folder on my server, then re-copying the new mchat files back over. The mchat extension then loaded correctly.

Hope that helps.
joe92 wrote:version 0.32 don't work

Code: Select all

SQL ERROR [ mysqli ]

Duplicate entry 'refresh' for key 'PRIMARY' [1062]

SQL

INSERT INTO phpbb_mchat_config (config_name, config_value) VALUES ('refresh', '10'), ('message_limit', '10'), ('archive_limit', '25'), ('flood_time', '0'), ('max_message_lngth', '500'), ('custom_page', '1'), ('date', 'D M d, Y g:i a'), ('whois', '1'), ('bbcode_disallowed', ''), ('prune_enable', '0'), ('prune_num', '0'), ('location', '1'), ('whois_refresh', '30'), ('static_message', ''), ('index_height', '250'), ('custom_height', '350'), ('override_min_post_chars', '0'), ('timeout', '0'), ('override_smilie_limit', '0'), ('pause_on_input', '0'), ('rules', ''), ('avatars', '1'), ('message_num', '10')

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 650
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 377
CALL: phpbb\db\driver\driver->sql_multi_insert()

FILE: [ROOT]/ext/dmzx/mchat/migrations/mchat_schema_sample_data.php
LINE: 129
CALL: phpbb\db\driver\factory->sql_multi_insert()

FILE: (not given by php)
LINE: (not given by php)
CALL: dmzx\mchat\migrations\mchat_schema_sample_data->insert_sample_data()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 550
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 496
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 322
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 202
CALL: phpbb\db\migrator->try_apply()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 185
CALL: phpbb\db\migrator->update_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 80
CALL: phpbb\db\migrator->update()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 187
CALL: phpbb\extension\base->enable_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 179
CALL: phpbb\extension\manager->enable_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 674
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 81
CALL: p_master->load_active()
deleded the old version,cleared the cache and new installation on v3.16 phpbb
"My actions are not revenge...they are punishment..."

User avatar
dmzx
Registered User
Posts: 768
Joined: Fri Sep 05, 2014 6:48 am
Location: The Netherlands
Contact:

Re: [DEV] mChat

Post by dmzx » Tue Dec 29, 2015 5:39 pm

Updated download Fixed quoting and liking of messages
Contact me on dmzx-web.net
 Need a Host or buy me a beer Donate and try binance.com

joe92
Registered User
Posts: 50
Joined: Sun Oct 04, 2015 1:04 pm

Re: [DEV] mChat

Post by joe92 » Wed Dec 30, 2015 2:15 pm

dmzx wrote:Updated download Fixed quoting and liking of messages
now work fine :)

Jon_Hart
Registered User
Posts: 18
Joined: Tue Dec 29, 2015 10:03 am

Re: [DEV] mChat

Post by Jon_Hart » Sat Jan 02, 2016 4:00 am

I updated to 0.3.2 and the sounds aren't playing anymore. The checkbox won't stay checked if you refresh or reload the page so I assume it's related.

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3778
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [DEV] mChat

Post by kasimi » Sat Jan 02, 2016 1:36 pm

Jon_Hart wrote:The checkbox won't stay checked if you refresh or reload the page so I assume it's related.
Please check your UCP settings for mChat. If you disable sound in your UCP, checking the checkbox below the chat is only temporary: when reloading the page, the checkbox is not checked again, i.e. you will have no sound. On the other hand, if you have sound enabled in your UCP, unchecking the checkbox below the chat is permanent: when reloading the page, you still won't have sound.

This is how it always worked, it hasn't been changed in 0.3.2.

User avatar
Dr.Death
QA Team
Posts: 363
Joined: Fri Apr 25, 2003 10:04 am
Location: Germany
Contact:

Re: [DEV] mChat

Post by Dr.Death » Sat Jan 02, 2016 3:02 pm

Small controler bug found: https://github.com/dmzx/mChat-Extension/issues/40

Click the button "Purge" in the mChat on index (MCHAT_CLEAN)
You will receive a confirmation popup. "Remove all messages?" (MCHAT_DELALLMESS)
Click "NO"

Error message from controller:
Information

The controller must return a response (null given). Did you forget to add a return statement somewhere in your controller?
Doc.

Jon_Hart
Registered User
Posts: 18
Joined: Tue Dec 29, 2015 10:03 am

Re: [DEV] mChat

Post by Jon_Hart » Sun Jan 03, 2016 6:24 am

kasimi wrote:
Jon_Hart wrote:The checkbox won't stay checked if you refresh or reload the page so I assume it's related.
Please check your UCP settings for mChat. If you disable sound in your UCP, checking the checkbox below the chat is only temporary: when reloading the page, the checkbox is not checked again, i.e. you will have no sound. On the other hand, if you have sound enabled in your UCP, unchecking the checkbox below the chat is permanent: when reloading the page, you still won't have sound.

This is how it always worked, it hasn't been changed in 0.3.2.
It was for everyone on the board so it wasn't a settings issue. It did randomly start working again so I think it was a cookie issue that resolved itself.

User avatar
evilpeppard
Registered User
Posts: 75
Joined: Wed Jan 30, 2008 6:05 pm
Location: Denver, CO USA

Re: [DEV] mChat

Post by evilpeppard » Sun Jan 03, 2016 3:32 pm

kasimi wrote:
Jon_Hart wrote:The checkbox won't stay checked if you refresh or reload the page so I assume it's related.
Please check your UCP settings for mChat. If you disable sound in your UCP, checking the checkbox below the chat is only temporary: when reloading the page, the checkbox is not checked again, i.e. you will have no sound. On the other hand, if you have sound enabled in your UCP, unchecking the checkbox below the chat is permanent: when reloading the page, you still won't have sound.

This is how it always worked, it hasn't been changed in 0.3.2.
I have mChat sound enabled in my UCP, but I too am seeing this same behavior since upgrading to mChat 0.3.2. Every time I refresh my site the 'use sound' checkbox below my mChat window is uncheck. I can recheck it all day long and after each page refresh, it us unchecked again.
"My actions are not revenge...they are punishment..."

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3778
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [DEV] mChat

Post by kasimi » Sun Jan 03, 2016 4:51 pm

I stand corrected. It'll be fixed in the next version, thanks for reporting. :)

User avatar
evilpeppard
Registered User
Posts: 75
Joined: Wed Jan 30, 2008 6:05 pm
Location: Denver, CO USA

Re: [DEV] mChat

Post by evilpeppard » Sun Jan 03, 2016 4:55 pm

kasimi wrote:I stand corrected. It'll be fixed in the next version, thanks for reporting. :)
Excellent! Thank you for the feedback!
"My actions are not revenge...they are punishment..."

entonox
Registered User
Posts: 24
Joined: Fri Jan 17, 2014 10:51 am

Re: [DEV] mChat

Post by entonox » Wed Jan 06, 2016 12:46 pm

I'm having difficulties using 0.3.2 mchat with the we_universal style on phpbb 3.1.6. In the prosilver style all is working well. In the we_universal style, whenever i click on a buton nothing happens. (smilies not shown, bbcodes not shown, message not send to chat). Seems like a javascript is not found or not working propperly?

Can you check on this?

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3778
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [DEV] mChat

Post by kasimi » Wed Jan 06, 2016 8:21 pm

No issues with the we_universal style on my machine. Is this on localhost or can you provide a test account? In case you're wondering, I've been helping out with the development of mChat lately. If there's a problem with JavaScript it's most likely my fault. :)

entonox
Registered User
Posts: 24
Joined: Fri Jan 17, 2014 10:51 am

Re: [DEV] mChat

Post by entonox » Thu Jan 07, 2016 12:46 pm

PM sent with test account details ;)

EDIT: and solved by a quick reply of kasimi ;)

Langleu
Registered User
Posts: 2
Joined: Thu Jan 07, 2016 10:14 am

Re: [DEV] mChat

Post by Langleu » Thu Jan 07, 2016 5:20 pm

how exactly did you fix it now? I have the same problem.

Locked

Return to “Extensions in Development”