Page 92 of 98

Re: [RC] mChat

Posted: Fri Oct 28, 2016 4:25 pm
by besciak
hi,

i have fast question :)

how change place mchat'a on index.php ( forum )? i'd like, to be at the bottom part of the page?

Re: [RC] mChat

Posted: Fri Oct 28, 2016 4:27 pm
by Tarantino
You have that option on ACP or UCP.

Re: [RC] mChat

Posted: Fri Oct 28, 2016 4:39 pm
by besciak
yes, but ..

my setup:

Image

and this on webpage:

Image

Re: [RC] mChat

Posted: Fri Oct 28, 2016 4:56 pm
by Tarantino
You need to first overwrite the settings to all users to yes, both last options.

Re: [RC] mChat

Posted: Fri Oct 28, 2016 5:10 pm
by besciak
i am beginner, ... How do it ? Thank You for answer.

Re: [RC] mChat

Posted: Fri Oct 28, 2016 5:33 pm
by kasimi
I assume you have checked in your UCP and you don't see the setting there? This means that you don't have the permission to change it. The settings you see in your first screenshot only take effect if a user does not have permission to customize them. To change these permission go to ACP, Permissions tab, User rules, edit a role and go to the mChat in UCP tab.

If you don't want your users to be able change this setting in the UCP and instead overwrite it for everyone, go to the Global user settings and look at the bottom of the page. You can see the section at the bottom of your first screenshot too.

Re: [RC] mChat

Posted: Fri Oct 28, 2016 5:37 pm
by besciak
Very, Very, Thank You ...

Re: [RC] mChat

Posted: Mon Oct 31, 2016 9:03 pm
by evilpeppard
Upgraded from 2.0.0-RC6 to 2.0.0-RC7 with no issues.

Thank you very much!

Re: [RC] mChat

Posted: Wed Nov 02, 2016 8:08 pm
by eunaumtenhoid
kasimi wrote:I assume you have checked in your UCP and you don't see the setting there? This means that you don't have the permission to change it. The settings you see in your first screenshot only take effect if a user does not have permission to customize them. To change these permission go to ACP, Permissions tab, User rules, edit a role and go to the mChat in UCP tab.

If you don't want your users to be able change this setting in the UCP and instead overwrite it for everyone, go to the Global user settings and look at the bottom of the page. You can see the section at the bottom of your first screenshot too.

any news on the multiroom addon? I'm crazy about it

Re: [RC] mChat

Posted: Mon Nov 07, 2016 1:45 pm
by sakm
I have just found a bit of a problem

Users can post images with no limit on size which will then kill the chat depending on the browser they use

Can chat no use the set limits on attachments?

Re: [RC] mChat

Posted: Mon Nov 07, 2016 2:07 pm
by kasimi
Users should not be able to post images that have a larger dimension than what the settings in ACP > Posting > Post Settings > Maximum image width/height per post are set to. If these limits don't apply to images in mChat then that certainly is a bug.

Attachments are handled differently, their checks don't apply to the [img] BBCode.

Re: [RC] mChat

Posted: Mon Nov 07, 2016 2:10 pm
by sakm
The images may well have been from an external source using the [img] tags

Re: [RC] mChat

Posted: Mon Nov 07, 2016 2:35 pm
by sakm
I can confirm the images where posted with the [img] tag

It seems to be chrome that doesn't like large images! firefox will load them

Re: [RC] mChat

Posted: Mon Nov 07, 2016 9:06 pm
by ALX™
Greek language. (unfortunately in this topic I can't upload attachment)

https://dl.dropboxusercontent.com/u/163 ... nguage.rar

Re: [RC] mChat

Posted: Mon Nov 07, 2016 10:34 pm
by hejowicz
I have problem with permissions.
I want to give users edit and delete their own messages.

I setted User roles - Newly Registered User Features - Mchat to all "NO" instead of NEVER
and assigned that role to NRU group

Same with RU, i editted Standard features and gave in Mchat all "YES"

But users can't sill edit/delete messages

In View user based permissions -NRU group has all options set to "NEVER"
I don't have "NEVER" setted anywhere on forum

If i set Newly Registered User Features - Mchat to all "YES" in VUBP i see YES, but users still don't have that permissions.