[CDB] mChat

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: [RC] mChat

Post by DougE » Mon Nov 21, 2016 9:37 pm

DougE wrote:Information
The installation as been aborted.
There are remnant modules from the mChat MOD for phpBB 3.0.x in the database. The mChat extension does not work correctly with these modules present.
You need to entirely uninstall the mChat MOD before being able to install the mChat extension. Specifically, the modules with the following IDs need to be deleted from the phpbb_modules table: 242


See, it keeps making a new one
I ran modisson_reset_3110. php a couple times. It fails to find one of the tables, but I don't recall which. I can run it again and get that message if you want me to

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [RC] mChat

Post by 3Di » Mon Nov 21, 2016 9:46 pm

That tool resets the modules and permissions to the current vanilla phpBB 3.1.10, it's also able to erase AutoMOD from the DB. Nothing else.

Feel free to PM me such an error, this topic isn't devoted to this tool and I don't want to give support here to that one.

As I said before, though, I am of the idea your upgrade went wrong from the start.
Or is a problem with 3.1.10? That could also be.

Let's wait kasimi for further infos.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: [RC] mChat

Post by DougE » Mon Nov 21, 2016 10:42 pm

3Di wrote:That tool resets the modules and permissions to the current vanilla phpBB 3.1.10, it's also able to erase AutoMOD from the DB. Nothing else.

Feel free to PM me such an error, this topic isn't devoted to this tool and I don't want to give support here to that one.
PM sent
As I said before, though, I am of the idea your upgrade went wrong from the start.
Or is a problem with 3.1.10? That could also be.
I have the latest mchat version running on a 3.1.10 test board on localhost and it seems to be running fine. I upgraded the test board from 3.1.6 to 3.1.10 and put the latest version of mchat on there before I converted my live board from 3.0 to 3.1

User avatar
3Di
Former Team Member
Posts: 13769
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [RC] mChat

Post by 3Di » Tue Nov 22, 2016 1:27 am

Try to purge your cache.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
👨‍🏫 | Take a tour to | The Studio | 👨‍🏫

DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: [RC] mChat

Post by DougE » Tue Nov 22, 2016 1:42 am

3Di wrote:Try to purge your cache.
Did that through ACP as well as manually on the server

DougE
Registered User
Posts: 47
Joined: Tue Jul 12, 2011 5:38 pm
Location: Richmond,Ky
Contact:

Re: [RC] mChat

Post by DougE » Wed Nov 23, 2016 1:18 am

DougE wrote:I just migrated from 3.0.12 to 3.1.10. I didn't completely uninstall the old mods first since it didn't say to do so, but I have run modission_reset_3110.php.

When I try to enable mchat, I get the following message:
Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.
A required module does not exist: ACP_CAT_MCHAT
Return to the extension list
If I try again to enable it, I get this message:
Information
The installation as been aborted.
There are remnant modules from the mChat MOD for phpBB 3.0.x in the database. The mChat extension does not work correctly with these modules present.
You need to entirely uninstall the mChat MOD before being able to install the mChat extension. Specifically, the modules with the following IDs need to be deleted from the phpbb_modules table: 240
I go into System/module management/ACP/Extensions and the module ACP_CAT_MCHAT is now in there and the error is telling me I need to delete it. If I do that and try again, I start all over with the module does not exist message. I've been through all of my modules and there are no remnants from the old mods in there anywhere.

If I look at my database in phpmyadmin, there is a phpbb_mods table there and I'm wondering if that is causing the problem when I try to enable the mchat extension? I have mchat running on a 3.1.10 test board so I know it works with 3.1.10. I've been running 3.1 on a test board since it was first released, so I'm fairly familiar with it. I just hadn't converted my live board until yesterday.

Here is a screenshot from phpmyadmin. there is something for mchat inside phpbb_mods

Image

I have mchat working now. What I had to do is let mchat do it's error and let it create the module I knew it was going to then tell me to delete. Rather than deleting the module directly from the database with phpmyadmin or doing it through module management in the system tab, I used the delete data link on the extension itself. I then tried to enable it again and was able to.

I also went through my database and made sure there were no traces left from the old mods and dropped the phpbb_mods table before doing the above, but don't know that it had anything to do with the problem I was having.

Marshmellooo
Registered User
Posts: 16
Joined: Tue Aug 23, 2016 8:53 pm

Re: [RC] mChat

Post by Marshmellooo » Wed Nov 23, 2016 9:00 am

After updating from 3.1.9 to 3.1.10 i've got this error

Code: Select all

Fatal error: Uncaught exception 'Symfony\Component\DependencyInjection\Exception\ParameterNotFoundException' with message 'The service "dmzx.mchat.functions" has a dependency on a non-existent parameter "dmzx.mchat.table.mchat_log". Did you mean one of these: "dmzx.mchat.table.mchat", "dmzx.mchat.table.mchat_sessions"?' in /home/u883369033/public_html/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php:86 Stack trace: #0 /home/u883369033/public_html/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(202): Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->get('dmzx.mchat.tabl...') #1 /home/u883369033/public_html/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php(173): Symfony\Component\DependencyInjection\ParameterBag\ParameterBag->resolveString('%dmzx.mchat.tab...', Array) #2 /home/u883369033/public_html/vendor/symfony/dependency-injection/Symfony/Comp in /home/u883369033/public_html/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/ParameterBag/ParameterBag.php on line 86

I have no idea why it appears can anyone help me, i used the auto updater and ftp method

Marshmellooo
Registered User
Posts: 16
Joined: Tue Aug 23, 2016 8:53 pm

Re: [RC] mChat

Post by Marshmellooo » Wed Nov 23, 2016 9:30 am

I've deleted mchat and dropped the tables from the database and it's still showing

Marshmellooo
Registered User
Posts: 16
Joined: Tue Aug 23, 2016 8:53 pm

Re: [RC] mChat

Post by Marshmellooo » Wed Nov 23, 2016 10:07 am

Nevermind i've used my old backup and im so afraid to update to 3.1.10 again

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3717
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [RC] mChat

Post by kasimi » Wed Nov 23, 2016 12:49 pm

Meykota wrote:there is one module missing, this one is called ucp_mchat_config
You completely uninstall mChat and when enabling the latest mChat version you get an error about a missing module? Can you post the exact error you're getting?
Meykota wrote:Btw. if I just try to update the version of mChat from 0.1.4 to 2.0.0-RC7, the system also does not do this and tells me that there is one module already existing.
Again, can you post the exact error you're getting? Keep in mind that any version prior to 2.0.0-RC3 didn't have incremental upgrades which means you need to completely uninstall mChat before installing a new version.
ALX™ wrote:But, I have a problem. Don't work anything from bbcodes (smilies it works fine)

I have the we_clearblue style in 3.1.10 phpbb
It works fine for me. Make sure you also have the latest version of the style, clear the board cache as well as your browser cache.

Image
mrgtb wrote:Any chance the theme "bootlike for phpBB 3.1.10" can be supported?
It definitely can be. I got mChat partly running on it by adding parent = prosilver at the bottom of style.cfg before installing the style. However, there are a few issues with JavaScript and CSS, for example smilies don't work. If you (or anyone else) manages to fix those issues I'm more than happy to include them in the next release.
micheloupatrick wrote:Is there a french translation for mChat 2 ?
Yes, there is: https://kasimi.net/viewforum.php?f=10
Marshmellooo wrote:After updating from 3.1.9 to 3.1.10 i've got this error
Sounds like a caching issue. Did you try clearing your board cache or alternatively deleting all files in your cache folder except for index.html and .htaccess?

User avatar
ALX™
Registered User
Posts: 224
Joined: Thu Jun 26, 2014 4:47 pm

Re: [RC] mChat

Post by ALX™ » Thu Nov 24, 2016 6:45 am

kasimi wrote: It works fine for me. Make sure you also have the latest version of the style, clear the board cache as well as your browser cache.

Image
Yes... I have the latest version of we_clearblue style and I have cleared the cache many times. It is strange that everything work fine, except bbcodes. Μaybe is not compatible with some other extensions that I have installed. But... which of all? (I have many ext)

Also
(If I paste a link into the img tag to display the image in mchat, after send, appears a inactive text link. When I paste image link without img tag, appears a active text link to image, but not show me the photo in mchat)
Forgive me for my bad english :oops:

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3717
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [RC] mChat

Post by kasimi » Thu Nov 24, 2016 9:53 am

ALX™ wrote:Μaybe is not compatible with some other extensions
Yes, it seems most likely at this point. Do you have any extensions that add or manipulate BBCodes? Did you check your browser's error console? Sometimes you can find some hints there. If your board is online feel free to send me a PM with a link and an account with access to mChat and I'll have a look.

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3717
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [RC] mChat

Post by kasimi » Thu Nov 24, 2016 5:29 pm

ALX™ wrote:It is strange that everything work fine, except bbcodes.
It's not an incompatibility after all. Remove the last | character from your list of disallowed BBCodes in mChat's global settings in the ACP. This should fix BBCodes, including images.

User avatar
ALX™
Registered User
Posts: 224
Joined: Thu Jun 26, 2014 4:47 pm

Re: [RC] mChat

Post by ALX™ » Fri Nov 25, 2016 9:15 am

kasimi wrote:
ALX™ wrote:It is strange that everything work fine, except bbcodes.
It's not an incompatibility after all. Remove the last | character from your list of disallowed BBCodes in mChat's global settings in the ACP. This should fix BBCodes, including images.
Image incredible blunder!
Sorry my friend and Image very much for your help!
Forgive me for my bad english :oops:

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3717
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [RC] mChat

Post by kasimi » Fri Nov 25, 2016 1:39 pm

Don't worry. :) I didn't know leading and trailing | characters have this effect and I think the code can be improved to ignore them so that admins don't have to be 100% exact.

Locked

Return to “Extensions in Development”