[3.2][BETA] User Topic Count

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
martti
Registered User
Posts: 573
Joined: Thu Jul 31, 2014 8:23 am
Location: Belgium

Re: [ALPHA] User Topic Count

Post by martti » Sat Jan 17, 2015 9:02 am

djnerve wrote:Not a problem for me but noticed it doesn't show in private messages, might be something you can addd in the future. Well done very good extension.
I will add the topic count there too.
Bear in mind it's not counting correctly yet. The aim is to show the number of the visible topics. (That might be different to the number of results you get from the search link. The search is depending on your permissions.)

User avatar
advocatus
Registered User
Posts: 290
Joined: Tue Aug 12, 2014 11:58 am
Location: Ontario, Canada.
Contact:

Re: [ALPHA] User Topic Count

Post by advocatus » Sun Jan 18, 2015 4:11 pm

Can you remove the topic counter from the posting information when on mobile? It looks really out of place with nothing else showing.
Hi, I'm advocatus and I own www.forumgames.in.

User avatar
martti
Registered User
Posts: 573
Joined: Thu Jul 31, 2014 8:23 am
Location: Belgium

Re: [ALPHA] User Topic Count

Post by martti » Sun Jan 18, 2015 6:42 pm

advocatus wrote:Can you remove the topic counter from the posting information when on mobile? It looks really out of place with nothing else showing.
Did you download the code recently?

User avatar
advocatus
Registered User
Posts: 290
Joined: Tue Aug 12, 2014 11:58 am
Location: Ontario, Canada.
Contact:

Re: [ALPHA] User Topic Count

Post by advocatus » Sun Jan 18, 2015 10:17 pm

Two or three days ago.
Hi, I'm advocatus and I own www.forumgames.in.

User avatar
martti
Registered User
Posts: 573
Joined: Thu Jul 31, 2014 8:23 am
Location: Belgium

Re: [ALPHA] User Topic Count

Post by martti » Mon Jan 19, 2015 6:06 am

advocatus wrote:Two or three days ago.
I've updated now and it should be fixed.

Other changes:
  • The topic count is above the post count.
  • It's showing also in ucp pm.

User avatar
FuGu
Registered User
Posts: 20
Joined: Fri Nov 05, 2010 10:11 am

Re: [ALPHA] User Topic Count

Post by FuGu » Tue Jan 20, 2015 4:32 pm

Hi martti,

i use the newest version of your EXT. If i delete a topic out of the mcp i receive the following debug message:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/ext/marttiphpbb/usertopiccount/event/listener.php on line 215: array_diff()[function.array-diff]: Argument #2 is not an array 

User avatar
martti
Registered User
Posts: 573
Joined: Thu Jul 31, 2014 8:23 am
Location: Belgium

Re: [ALPHA] User Topic Count

Post by martti » Tue Jan 20, 2015 4:57 pm

FuGu wrote:Hi martti,

i use the newest version of your EXT. If i delete a topic out of the mcp i receive the following debug message:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/ext/marttiphpbb/usertopiccount/event/listener.php on line 215: array_diff()[function.array-diff]: Argument #2 is not an array 
Hello FuGu, that can't be the newest version (master), because that file does not exist anymore. It's split up in three files.

User avatar
FuGu
Registered User
Posts: 20
Joined: Fri Nov 05, 2010 10:11 am

Re: [ALPHA] User Topic Count

Post by FuGu » Tue Jan 20, 2015 8:31 pm

Hello martti,
i don't know what went wrong but you're right. I've done the same again and now everything is fine!

Nice work!


User avatar
advocatus
Registered User
Posts: 290
Joined: Tue Aug 12, 2014 11:58 am
Location: Ontario, Canada.
Contact:

Re: [ALPHA] User Topic Count

Post by advocatus » Sat Jan 24, 2015 2:06 am

When I'm hard deleting a post, I'm getting the following error. Parts of the error message reference this extension, so I'm assuming that it's related. :P

Code: Select all

SQL ERROR [ mysql4 ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 536
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 441
CALL: phpbb\db\driver\driver->sql_in_set()

FILE: [ROOT]/ext/marttiphpbb/usertopiccount/event/hard_update_listener.php
LINE: 166
CALL: phpbb\db\driver\factory->sql_in_set()

FILE: (not given by php)
LINE: (not given by php)
CALL: marttiphpbb\usertopiccount\event\hard_update_listener->core_delete_posts_after()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php
LINE: 164
CALL: call_user_func()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php
LINE: 53
CALL: Symfony\Component\EventDispatcher\EventDispatcher->doDispatch()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/ContainerAwareEventDispatcher.php
LINE: 167
CALL: Symfony\Component\EventDispatcher\EventDispatcher->dispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 40
CALL: Symfony\Component\EventDispatcher\ContainerAwareEventDispatcher->dispatch()

FILE: [ROOT]/includes/functions_admin.php
LINE: 956
CALL: phpbb\event\dispatcher->trigger_event()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1288
CALL: delete_posts()

FILE: [ROOT]/includes/functions_posting.php
LINE: 2576
CALL: delete_post()

FILE: [ROOT]/posting.php
LINE: 439
CALL: phpbb_handle_post_delete()
I got a similar General Error when I deleted two test accounts. I didn't copy that information though, because I was on my iPod when I did that. I can recreate that for you to get the error message, if you'd like. In the mean time, I am going to disable this. :(

[Edit: After disabling your extension, deleting posts works fine now.]
Hi, I'm advocatus and I own www.forumgames.in.

User avatar
martti
Registered User
Posts: 573
Joined: Thu Jul 31, 2014 8:23 am
Location: Belgium

Re: [ALPHA] User Topic Count

Post by martti » Sat Jan 24, 2015 9:48 am

advocatus wrote:When I'm hard deleting a post, I'm getting the following error. Parts of the error message reference this extension, so I'm assuming that it's related. :P

Code: Select all

SQL ERROR [ mysql4 ]

[0]

SQL

No values specified for SQL IN comparison

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 536
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 441
CALL: phpbb\db\driver\driver->sql_in_set()

FILE: [ROOT]/ext/marttiphpbb/usertopiccount/event/hard_update_listener.php
LINE: 166
CALL: phpbb\db\driver\factory->sql_in_set()

FILE: (not given by php)
LINE: (not given by php)
CALL: marttiphpbb\usertopiccount\event\hard_update_listener->core_delete_posts_after()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php
LINE: 164
CALL: call_user_func()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/EventDispatcher.php
LINE: 53
CALL: Symfony\Component\EventDispatcher\EventDispatcher->doDispatch()

FILE: [ROOT]/vendor/symfony/event-dispatcher/Symfony/Component/EventDispatcher/ContainerAwareEventDispatcher.php
LINE: 167
CALL: Symfony\Component\EventDispatcher\EventDispatcher->dispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 40
CALL: Symfony\Component\EventDispatcher\ContainerAwareEventDispatcher->dispatch()

FILE: [ROOT]/includes/functions_admin.php
LINE: 956
CALL: phpbb\event\dispatcher->trigger_event()

FILE: [ROOT]/includes/functions_posting.php
LINE: 1288
CALL: delete_posts()

FILE: [ROOT]/includes/functions_posting.php
LINE: 2576
CALL: delete_post()

FILE: [ROOT]/posting.php
LINE: 439
CALL: phpbb_handle_post_delete()
I got a similar General Error when I deleted two test accounts. I didn't copy that information though, because I was on my iPod when I did that. I can recreate that for you to get the error message, if you'd like. In the mean time, I am going to disable this. :(

[Edit: After disabling your extension, deleting posts works fine now.]
Thank you for reporting. This error should be fixed now. But this extension is still far from complete. The topic count is not correct. I think we need extra php events in the core to make it function as intended.

User avatar
Galixte de EzCom
Registered User
Posts: 897
Joined: Mon Oct 04, 2004 11:14 pm
Location: France
Name: Raphaël M.
Contact:

Re: [ALPHA] User Topic Count

Post by Galixte de EzCom » Mon Apr 13, 2015 2:38 pm

Communau EzCom
📖 « Traductions d’extensions & styles pour phpBB 3.1.x & 3.2.x ».
📋Lists of all extensions identified for phpBB 3.1.x & 3.2.x.
📋 Lists of all styles identified for phpBB 3.1.x & 3.2.x.

Image Tu as un forum et tu veux aussi un site web ? Regarde par ici.

User avatar
nero
Registered User
Posts: 321
Joined: Fri Mar 13, 2015 8:18 am

Re: [ALPHA] User Topic Count

Post by nero » Mon Apr 13, 2015 8:38 pm

When will BETA be releasing?

User avatar
Raul [ThE KuKa]
Jr. Extension Validator
Posts: 4210
Joined: Mon Dec 08, 2003 9:24 pm
Location: Spain
Name: Raul Arroyo
Contact:

Re: [ALPHA] User Topic Count

Post by Raul [ThE KuKa] » Mon Apr 13, 2015 8:54 pm

Hi martti

"PR" Spanish translation ready. :wink:
If you like my styles, translations, etc. and want to show some appreciation, then feel free to Donate with Image
phpBB International Support Team (Spanish - Español) :flag_es: Online Since 2003 - 15th anniversary
🎨phpBB Professional Premium Themes🔥
Author Translations (Spanish - Spain) :two_hearts:

:warning: I don't support those without the copyright Spanish translation. :warning:

User avatar
Komanche
Registered User
Posts: 232
Joined: Thu Aug 02, 2007 10:49 am
Location: Czech Republic

Re: [ALPHA] User Topic Count

Post by Komanche » Mon May 18, 2015 9:22 am

sometimes not working... some users have 0 topics, but they have topics...

tried to resync as described on github, but worked only partially...

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: feruchio, Leinad4Mind, maxco73, remoss, Technicalsain and 21 guests