[CDB] Topic Solved

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
User avatar
david63
Registered User
Posts: 18452
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [RC] Topic Solved

Post by david63 »

systemcrack wrote:Hello, I have tried to install your extension, but I get this message and can not complete the installation.

"The extension selected can not be activated, check the requirements of the extension."

I have tried both the extension upload extension, either manually, but to no avail.

The route is ext/tierra/topicsolved

Can you help me please.
I would guess that you are trying to install it on a version of phpBB less than 3.1.3 - this extension requires 3.1.3
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored
systemcrack
Registered User
Posts: 158
Joined: Thu Jun 24, 2010 4:35 pm
Location: Italy
Contact:

Re: [RC] Topic Solved

Post by systemcrack »

david63 wrote:
systemcrack wrote:Hello, I have tried to install your extension, but I get this message and can not complete the installation.

"The extension selected can not be activated, check the requirements of the extension."

I have tried both the extension upload extension, either manually, but to no avail.

The route is ext/tierra/topicsolved

Can you help me please.
I would guess that you are trying to install it on a version of phpBB less than 3.1.3 - this extension requires 3.1.3
I tried installing it on a 3.1.3 board, but it did not work anyway.
Also I do not understand if you should see the additional panels in acp.
Sorry for my bad English ..
mikkatzzz
Registered User
Posts: 6
Joined: Sun Mar 01, 2015 6:41 pm

Re: [RC] Topic Solved

Post by mikkatzzz »

Hi Bryan,

Thanks for this extremly useful extension! I´ve got a problem: i can activate it, but it doesn´t show up in the extensions menu (i use PHPBB 3.1.3).

Thanks,
mikka

ps
(my board is german so as a quick fix i copied the language/en folder and renamed it to language/de)
User avatar
bpetty
Registered User
Posts: 124
Joined: Thu Jan 08, 2015 5:35 am
Name: Bryan Petty

Re: [RC] Topic Solved

Post by bpetty »

systemcrack wrote:Also I do not understand if you should see the additional panels in acp.
Please see the Getting Started documentation in the readme:
https://github.com/tierra/topicsolved/b ... ng-started
User avatar
bpetty
Registered User
Posts: 124
Joined: Thu Jan 08, 2015 5:35 am
Name: Bryan Petty

Re: [RC] Topic Solved

Post by bpetty »

mikkatzzz wrote:but it doesn´t show up in the extensions menu
If you were able to activate it, I'm assuming it did show up under the "Extensions Manager". The extension doesn't add any new menus to the ACP at all, just the topic solved settings for each forum in the forum administration sections. Also see the Getting Started docs I linked above.
mikkatzzz wrote:(my board is german so as a quick fix i copied the language/en folder and renamed it to language/de)
Once you get everything working right, and understand how it works, consider sending me those files translated into German, and I'll include them in the next release.
systemcrack
Registered User
Posts: 158
Joined: Thu Jun 24, 2010 4:35 pm
Location: Italy
Contact:

Re: [RC] Topic Solved

Post by systemcrack »

bpetty wrote:
systemcrack wrote:Also I do not understand if you should see the additional panels in acp.
Please see the Getting Started documentation in the readme:
https://github.com/tierra/topicsolved/b ... ng-started
Ok.. sorry.. thank's
Sorry for my bad English ..
User avatar
Geronimoz
Registered User
Posts: 27
Joined: Wed Jan 28, 2015 5:57 pm
Location: Toulouse (France)
Contact:

Re: [BETA] Topic Solved

Post by Geronimoz »

bpetty wrote:I've now added basic support for PBTech (fixed post button, still no post solved indicator), and also added basic support for Subsilver2, which could still use new post button graphics.

Hi there

Thank you so much. I'll try it now :)
I'll say to you if it works good ;)

Have a nice day
"Nothing is not inside nothing"
SCS MODS FR
User avatar
Geronimoz
Registered User
Posts: 27
Joined: Wed Jan 28, 2015 5:57 pm
Location: Toulouse (France)
Contact:

Re: [RC] Topic Solved

Post by Geronimoz »

Yop

Installed on our forum which has the pbtech style, and works perfectly for now :)
Thank you so much for your work :)

Have a nice day !!!
"Nothing is not inside nothing"
SCS MODS FR
mikkatzzz
Registered User
Posts: 6
Joined: Sun Mar 01, 2015 6:41 pm

Re: [RC] Topic Solved

Post by mikkatzzz »

bpetty wrote:
mikkatzzz wrote:but it doesn´t show up in the extensions menu
If you were able to activate it, I'm assuming it did show up under the "Extensions Manager". The extension doesn't add any new menus to the ACP at all, just the topic solved settings for each forum in the forum administration sections. Also see the Getting Started docs I linked above.
mikkatzzz wrote:(my board is german so as a quick fix i copied the language/en folder and renamed it to language/de)
Once you get everything working right, and understand how it works, consider sending me those files translated into German, and I'll include them in the next release.
Thank you - the new settings are indeed available for each forum - i was blind :-)

I will send you my translations, but i´m not satisfied with them yet - and i ran into a problem testing it: every time i try to mark a topic as solved the page reloads, i get logged out and subsequently the topic is not marked as solved :-/

how could i debug this?

thanks,
mikka
User avatar
bpetty
Registered User
Posts: 124
Joined: Thu Jan 08, 2015 5:35 am
Name: Bryan Petty

Re: [RC] Topic Solved

Post by bpetty »

mikkatzzz wrote:every time i try to mark a topic as solved the page reloads, i get logged out and subsequently the topic is not marked as solved
I think it's possible for this to happen if the session id isn't properly appended to the URLs used for marking topics as solved, or the redirect sent back after to the post after it has been marked.

I was careful to make sure the URLs included the session ID for any direct links to solved posts:
https://github.com/tierra/topicsolved/b ... #L214-L215

Although, I guess I just relied on the new phpBB 3.1+ router to automatically handle this for the links that actually mark a post as solved/unsolved:
https://github.com/tierra/topicsolved/b ... #L319-L338

It doesn't look like $this->helper->route() actually appends the session ID. So maybe that causes it, but if that was the problem, I would have expected everyone to have this same problem, but you're the first person to report it.

Does anyone have any advice or suggestions on this?
User avatar
bpetty
Registered User
Posts: 124
Joined: Thu Jan 08, 2015 5:35 am
Name: Bryan Petty

Re: [RC] Topic Solved

Post by bpetty »

bpetty wrote:Although, I guess I just relied on the new phpBB 3.1+ router to automatically handle this for the links that actually mark a post as solved/unsolved:
https://github.com/tierra/topicsolved/b ... #L319-L338
Apparently I didn't make any mistakes relying on the new router to automatically append this, it is supposed to:
https://github.com/phpbb/phpbb/blob/rel ... r.php#L178
User avatar
bpetty
Registered User
Posts: 124
Joined: Thu Jan 08, 2015 5:35 am
Name: Bryan Petty

Re: [RC] Topic Solved

Post by bpetty »

It seems to work fine without logging me out even without the session ID added to the URL for marking topics as solved.
nero_the_god
I am too lazy to register

Re: [RC] Topic Solved

Post by nero_the_god »

I will be attempting to run this on my live board. Will let you know the result.
mikkatzzz
Registered User
Posts: 6
Joined: Sun Mar 01, 2015 6:41 pm

Re: [RC] Topic Solved

Post by mikkatzzz »

bpetty wrote:It seems to work fine without logging me out even without the session ID added to the URL for marking topics as solved.
It was a problem with the cookie - now its running perfecly :)
lordrichy
Registered User
Posts: 34
Joined: Wed May 26, 2010 8:49 pm

Re: [RC] Topic Solved

Post by lordrichy »

Very nice extension.
1) Is there any way to add your own custom image?
2) Can you have the text appear as a prefix, as opposed to a suffix (how it is currently)?
Locked

Return to “Extensions in Development”