[RC] Teamspeak Viewer EXT

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
BlueSelune
Registered User
Posts: 3
Joined: Wed Sep 16, 2015 7:42 pm

Re: [RC] Teamspeak Viewer EXT

Post by BlueSelune » Fri Sep 18, 2015 10:05 pm

Tecwar wrote:
BlueSelune wrote:Hello

I get a :

Code: Select all

ERROR 0x400: invalid serverID
And I don't know how to solve it !

Thanks for help
Ensure that the query-client has sufficient privileges (this is mostly the case for teamspeak hosters)?
I tried with the serveradmin query user, which has full privileges on the server, and I get the same error.
I don't use a hoster, we have our own dedicated server.

Cheers
Selune

BlueSelune
Registered User
Posts: 3
Joined: Wed Sep 16, 2015 7:42 pm

Re: [RC] Teamspeak Viewer EXT

Post by BlueSelune » Fri Sep 18, 2015 10:13 pm

Okay it works now. My bad : I entered a bad port number in the configuration !

Thanks for help, and for the great work !

User avatar
aduh
Registered User
Posts: 212
Joined: Thu Jul 05, 2012 7:29 pm
Location: Poland
Name: Hans'
Contact:

Re: [RC] Teamspeak Viewer EXT

Post by aduh » Sat Oct 10, 2015 5:39 pm

This plugin broke mobile header layout in Elegance style:
https://www.phpbb.com/customise/db/styl ... pic/151246

Tecwar
Registered User
Posts: 42
Joined: Mon Jun 25, 2007 4:45 pm

Re: [RC] Teamspeak Viewer EXT

Post by Tecwar » Mon Oct 12, 2015 10:52 am

hi,
It will be a completely revised ts-viewer version.
Unfortunately I have very much to do, so it still little time.

Sippan
Registered User
Posts: 173
Joined: Thu Jan 27, 2011 6:23 am
Contact:

Re: [RC] Teamspeak Viewer EXT

Post by Sippan » Wed Nov 11, 2015 6:45 pm

Got problem have not chyange anything on site or Teamspeak veiwer ....last week it was ok and now i get this
ERROR 0xd01: connection failed, you are banned (you may retry in 1040 seconds)
Thisis weird
Host says they have not change anything even...

Sippan
Registered User
Posts: 173
Joined: Thu Jan 27, 2011 6:23 am
Contact:

Re: [RC] Teamspeak Viewer EXT

Post by Sippan » Wed Nov 11, 2015 7:16 pm

Iam sorry now it works again...must be host :twisted:

Slechtvalk
Registered User
Posts: 34
Joined: Tue Jan 15, 2008 12:56 pm

Re: [RC] Teamspeak Viewer EXT

Post by Slechtvalk » Sat Jan 16, 2016 3:31 pm

Caching does not work for the viewer page itself. Forum Index caching works
ERROR 0xd03: flood ban

I set the cache to 600 / 900 seconds but everytime someone opens the forum index or the tsviewer page it connects which leads into a flood ban.

Code: Select all

16.01.2016 15:24:56	VirtualServer	Info	query client connected 'xxxxxx from xxxxxxxxxxx:51944'(id:1848)	
16.01.2016 15:24:57	VirtualServerBase	Info	query client disconnected 'xxxxx from xxxxx:51944'(id:1848) reason 'reasonmsg=disconnecting'	
16.01.2016 15:25:08	VirtualServer	Info	query client connected 'xxx from xxxxxxx:51948'(id:1848)	
16.01.2016 15:25:13	VirtualServerBase	Info	query client disconnected 'xxxxxx from xxxxxxx:51948'(id:1848) reason 'reasonmsg=connection lost'	
16.01.2016 15:37:06	VirtualServer	Info	query client connected 'xxxxx from xxxxxx:51976'(id:1848)	
16.01.2016 15:37:09	VirtualServerBase	Info	query client disconnected 'xxxxxxx from xxxxxxxxx:51976'(id:1848) reason 'reasonmsg=connection lost'	
Can it be changed that caching time also means no connection for that time? I cant set the viewer to whitelist because that server is on a dyndns with non-static ip

PHPBB 3.1.7-PL1
PHP Version 5.5.30
TS_Viewer 1.5.0_RC

Slechtvalk
Registered User
Posts: 34
Joined: Tue Jan 15, 2008 12:56 pm

Re: [RC] Teamspeak Viewer EXT

Post by Slechtvalk » Sun Jan 17, 2016 8:32 am

And another Problem:
Rightmanagement missing:

Image

Tried to deactivate and reactivate the ext.

Tecwar
Registered User
Posts: 42
Joined: Mon Jun 25, 2007 4:45 pm

Re: [RC] Teamspeak Viewer EXT

Post by Tecwar » Tue Jan 19, 2016 11:48 am

Slechtvalk wrote:And another Problem:
Rightmanagement missing:

Image

Tried to deactivate and reactivate the ext.
new version 1.5.1RC

links in the fist post

1.5.0RC to 1.5.1RC
fix compatibility to phpBB 3.1.7-PL1 in acp-permissions

Slechtvalk wrote:Caching does not work for the viewer page itself. Forum Index caching works
ERROR 0xd03: flood ban

I set the cache to 600 / 900 seconds but everytime someone opens the forum index or the tsviewer page it connects which leads into a flood ban.

Code: Select all

16.01.2016 15:24:56	VirtualServer	Info	query client connected 'xxxxxx from xxxxxxxxxxx:51944'(id:1848)	
16.01.2016 15:24:57	VirtualServerBase	Info	query client disconnected 'xxxxx from xxxxx:51944'(id:1848) reason 'reasonmsg=disconnecting'	
16.01.2016 15:25:08	VirtualServer	Info	query client connected 'xxx from xxxxxxx:51948'(id:1848)	
16.01.2016 15:25:13	VirtualServerBase	Info	query client disconnected 'xxxxxx from xxxxxxx:51948'(id:1848) reason 'reasonmsg=connection lost'	
16.01.2016 15:37:06	VirtualServer	Info	query client connected 'xxxxx from xxxxxx:51976'(id:1848)	
16.01.2016 15:37:09	VirtualServerBase	Info	query client disconnected 'xxxxxxx from xxxxxxxxx:51976'(id:1848) reason 'reasonmsg=connection lost'	
Can it be changed that caching time also means no connection for that time? I cant set the viewer to whitelist because that server is on a dyndns with non-static ip

PHPBB 3.1.7-PL1
PHP Version 5.5.30
TS_Viewer 1.5.0_RC
check this viewtopic.php?f=456&t=2306326&start=30#p14039041

Slechtvalk
Registered User
Posts: 34
Joined: Tue Jan 15, 2008 12:56 pm

Re: [RC] Teamspeak Viewer EXT

Post by Slechtvalk » Tue Jan 19, 2016 1:31 pm

Thank you, works Perfect! Rightmanagement working, and no floodban until now! :D

orangutan69
Registered User
Posts: 7
Joined: Thu May 26, 2016 5:42 pm

Re: [RC] Teamspeak Viewer EXT

Post by orangutan69 » Fri May 27, 2016 2:14 pm

We'd love to use this, so I installed it. I am not the TS3 person, so I need to properly convey to him what he needs to give me to use it.

We'd like it to query the server as shown, but we don't need it to login a client. Not that it can't but we just want forum uses to see who's on line.

I asked him to add our server IP to the query_ip_whitelist.txt, where can he find this file?
I know the IP of the server we connect to and the port (at least for the TS3 client).

Do I also need him to provide me a query user and password? I assume so, but want to confirm.

If I add our server IP and the default port (with the default user/pass) I get this error:

ERROR 0x0: invalid URI supplied

Any assistance is appreciated.

EDIT: phpBB 3.1.9

orangutan69
Registered User
Posts: 7
Joined: Thu May 26, 2016 5:42 pm

Re: [RC] Teamspeak Viewer EXT

Post by orangutan69 » Fri Jun 03, 2016 4:11 pm

I was able to resolve my issue in the above post after getting the proper values, but now I have a new issue.

The footer info is showing:

Clients Online (7): ....

But the link shows a broken page with the following:

ERROR 0x803: file not found

Any ideas on what specifically it is looking for and how to fix?

Tecwar
Registered User
Posts: 42
Joined: Mon Jun 25, 2007 4:45 pm

Re: [RC] Teamspeak Viewer EXT

Post by Tecwar » Mon Jun 06, 2016 8:30 am

hi,
check your servers permission settings, (icon permission)

the TS server group of TS-Viewer (query) does not have enough rights

orangutan69
Registered User
Posts: 7
Joined: Thu May 26, 2016 5:42 pm

Re: [RC] Teamspeak Viewer EXT

Post by orangutan69 » Thu Jun 09, 2016 5:22 pm

Tecwar wrote:hi,
check your servers permission settings, (icon permission)

the TS server group of TS-Viewer (query) does not have enough rights
OK, so we cannot change this. We sent this to the support folks, and they laughed, and said that there is no reason why it needs more rights to "see" an image.

Any other suggestions?

Tecwar
Registered User
Posts: 42
Joined: Mon Jun 25, 2007 4:45 pm

Re: [RC] Teamspeak Viewer EXT

Post by Tecwar » Fri Jun 10, 2016 8:42 am

There is only the possibility that the right to the icon is not sufficient , the missing down load or the icon on the TS itself

Post Reply

Return to “Extensions in Development”