[CDB] Youtube Videos Gallery

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
dmzx
Registered User
Posts: 770
Joined: Fri Sep 05, 2014 6:48 am
Location: The Netherlands
Contact:

Re: [DEV] Youtube Videos Gallery

Post by dmzx » Wed Apr 22, 2015 7:14 pm

First post updated
Contact me on dmzx-web.net
 Need a Host or buy me a beer Donate and try binance.com

swstarone
Registered User
Posts: 87
Joined: Sun Jun 02, 2013 12:48 pm

Re: [DEV] Youtube Videos Gallery

Post by swstarone » Sat Apr 25, 2015 7:43 pm

Dear sir

the directory /video is not opening !!!
even I have added one Categery from the ACP.

User avatar
dmzx
Registered User
Posts: 770
Joined: Fri Sep 05, 2014 6:48 am
Location: The Netherlands
Contact:

Re: [DEV] Youtube Videos Gallery

Post by dmzx » Sat Apr 25, 2015 7:50 pm

swstarone wrote:Dear sir

the directory /video is not opening !!!
even I have added one Categery from the ACP.
Don't know what you mean, PM me link of your board.
Contact me on dmzx-web.net
 Need a Host or buy me a beer Donate and try binance.com

Miri4ever
Registered User
Posts: 409
Joined: Sat Mar 07, 2015 11:18 am

Re: [DEV] Youtube Videos Gallery

Post by Miri4ever » Sat Apr 25, 2015 10:49 pm

Getting those 2 Errors. First looks like the current setup doens't work with every server:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php on line 139: DOMDocument::load(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0
[phpBB Debug] PHP Warning: in file [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php on line 139: DOMDocument::load(http://gdata.youtube.com/feeds/api/videos/): failed to open stream: no suitable wrapper could be found
[phpBB Debug] PHP Warning: in file [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php on line 139: DOMDocument::load(): I/O warning : failed to load external entity "http://gdata.youtube.com/feeds/api/videos/"
And second if try to add an video url:

Code: Select all

Allgemeiner Fehler
SQL ERROR [ mysql4 ]

Column 'video_title' cannot be null [1048]

SQL

INSERT INTO PHPBB3_video (video_id, video_url, video_title, video_cat_id, username, user_id, youtube_id, create_time, video_views) VALUES (0, 'https://www.youtube.com/watch?v=m3qzLWVerF4', NULL, 2, 'Transwarp', 2, 'm3qzLWVerF4', 1430002038, 0)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 181
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php
LINE: 249
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: dmzx\youtubegallery\controller\youtubegallery->handle_video()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 117
CALL: call_user_func_array()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 61
CALL: Symfony\Component\HttpKernel\HttpKernel->handleRaw()

FILE: [ROOT]/app.php
LINE: 33
CALL: Symfony\Component\HttpKernel\HttpKernel->handle()
Homepage: Terra Oceanica

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8355
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [DEV] Youtube Videos Gallery

Post by _Vinny_ » Sat Apr 25, 2015 11:38 pm

Miri4ever wrote:Getting those 2 Errors. First looks like the current setup doens't work with every server:

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php on line 139: DOMDocument::load(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0
[phpBB Debug] PHP Warning: in file [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php on line 139: DOMDocument::load(http://gdata.youtube.com/feeds/api/videos/): failed to open stream: no suitable wrapper could be found
[phpBB Debug] PHP Warning: in file [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php on line 139: DOMDocument::load(): I/O warning : failed to load external entity "http://gdata.youtube.com/feeds/api/videos/"
And second if try to add an video url:

Code: Select all

Allgemeiner Fehler
SQL ERROR [ mysql4 ]

Column 'video_title' cannot be null [1048]

SQL

INSERT INTO PHPBB3_video (video_id, video_url, video_title, video_cat_id, username, user_id, youtube_id, create_time, video_views) VALUES (0, 'https://www.youtube.com/watch?v=m3qzLWVerF4', NULL, 2, 'Transwarp', 2, 'm3qzLWVerF4', 1430002038, 0)

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 855
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysql.php
LINE: 181
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysql->sql_query()

FILE: [ROOT]/ext/dmzx/youtubegallery/controller/youtubegallery.php
LINE: 249
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: dmzx\youtubegallery\controller\youtubegallery->handle_video()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 117
CALL: call_user_func_array()

FILE: [ROOT]/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpKernel.php
LINE: 61
CALL: Symfony\Component\HttpKernel\HttpKernel->handleRaw()

FILE: [ROOT]/app.php
LINE: 33
CALL: Symfony\Component\HttpKernel\HttpKernel->handle()
Be sure that your server supports allow_url_fopen, if so turn it on. When activated, the two errors will be corrected.

Miri4ever
Registered User
Posts: 409
Joined: Sat Mar 07, 2015 11:18 am

Re: [DEV] Youtube Videos Gallery

Post by Miri4ever » Sun Apr 26, 2015 10:18 am

Ok but still having a problem with removing data from the server:

Code: Select all

Während der Anpassung der Datenbank ist etwas falsch gelaufen und ein Fehler aufgetreten. Die Änderungen, die vor dem Fehler durchgeführt wurden, wurden so weit wie möglich rückgängig gemacht. Du solltest jedoch prüfen, ob dein Board fehlerfrei funktioniert.
Die Berechtigungs-Rolle „“ existiert unerwarteterweise nicht.
Something is missing inside the database, so this mod seems could not be removed. Reinstall and try again also didn't work.
Homepage: Terra Oceanica

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8355
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [DEV] Youtube Videos Gallery

Post by _Vinny_ » Mon Apr 27, 2015 6:35 am

Miri4ever wrote:Ok but still having a problem with removing data from the server:

Code: Select all

Während der Anpassung der Datenbank ist etwas falsch gelaufen und ein Fehler aufgetreten. Die Änderungen, die vor dem Fehler durchgeführt wurden, wurden so weit wie möglich rückgängig gemacht. Du solltest jedoch prüfen, ob dein Board fehlerfrei funktioniert.
Die Berechtigungs-Rolle „“ existiert unerwarteterweise nicht.
Something is missing inside the database, so this mod seems could not be removed. Reinstall and try again also didn't work.
Uninstall: https://github.com/dmzx/youtubegallery#uninstall

Miri4ever
Registered User
Posts: 409
Joined: Sat Mar 07, 2015 11:18 am

Re: [DEV] Youtube Videos Gallery

Post by Miri4ever » Mon Apr 27, 2015 2:58 pm

I know how to disable and delete data from the extension menu. Need no guide for this, even not one telling me nothing more as the normal doing. Sure I could delete the folder, but the pieces inside the database still remain whatever inside the user permissions roole " what could not deleted.

Fresh installing and try again still doesn't remove the bad table that got created. Maybe an updated version would or the see what tables created while install to remove from hand. That's a little bit the bad part of PHPBB 3.1 extensions not to see the changes made, to reverse them from hand, if some extension not willing to uninstall like they should be.

I activated debug mode from server, but still got none error to see where the uninstall part stopped working to find the bad table. All I can say it's something inside the permissions table like the forum told me.
Homepage: Terra Oceanica

User avatar
tamarin
Registered User
Posts: 117
Joined: Tue Feb 03, 2015 9:02 pm
Location: Germany
Name: Ed

Re: [DEV] Youtube Videos Gallery

Post by tamarin » Tue Apr 28, 2015 6:01 am

Hello.
I uploaded 15 videos.
But I see only 10.
Displays "page 1 of 2," but there is no possibility to somehow switch.
Can you help me please?
Thank you in advance.

User avatar
_Vinny_
Style Customisations
Style Customisations
Posts: 8355
Joined: Tue Aug 11, 2009 12:45 am
Location: Brazil
Name: Marcus Vinicius
Contact:

Re: [DEV] Youtube Videos Gallery

Post by _Vinny_ » Tue Apr 28, 2015 6:50 am

Miri4ever wrote:I know how to disable and delete data from the extension menu. Need no guide for this, even not one telling me nothing more as the normal doing. Sure I could delete the folder, but the pieces inside the database still remain whatever inside the user permissions roole " what could not deleted.

Fresh installing and try again still doesn't remove the bad table that got created. Maybe an updated version would or the see what tables created while install to remove from hand. That's a little bit the bad part of PHPBB 3.1 extensions not to see the changes made, to reverse them from hand, if some extension not willing to uninstall like they should be.

I activated debug mode from server, but still got none error to see where the uninstall part stopped working to find the bad table. All I can say it's something inside the permissions table like the forum told me.
Ok, I'll take a look.
tamarin wrote:Hello.
I uploaded 15 videos.
But I see only 10.
Displays "page 1 of 2," but there is no possibility to somehow switch.
Can you help me please?
Thank you in advance.
The pagination is unfinished :| , you must wait for an update soon.

User avatar
dmzx
Registered User
Posts: 770
Joined: Fri Sep 05, 2014 6:48 am
Location: The Netherlands
Contact:

Re: [DEV] Youtube Videos Gallery

Post by dmzx » Wed Apr 29, 2015 8:05 pm

First post updated
Contact me on dmzx-web.net
 Need a Host or buy me a beer Donate and try binance.com

Lazy2000
Registered User
Posts: 13
Joined: Sun Apr 26, 2015 11:33 am

Re: [DEV] Youtube Videos Gallery

Post by Lazy2000 » Wed Apr 29, 2015 8:19 pm

at first this is a great ext and thank you for working on it!

a small issue now.
a 404 at ***.com/video

this happened after i installed the ext "Social Login for phpBB 3.1.x" from here: https://docs.oneall.com/plugins/guide/s ... b/?v=3.1.x
BUT this (404) happens only if i login with FB account etc.
If i login normally (username - pass) everything is working fine.

i am not asking for a solution (although i would like one) i am just informing.
anyways, i 100% prefer to use the gallery and remove the social connection ext.
thanks for your time dmzx and _Vinny_ :)
if you want breakfast in bed, sleep in the kitchen.

User avatar
dmzx
Registered User
Posts: 770
Joined: Fri Sep 05, 2014 6:48 am
Location: The Netherlands
Contact:

Re: [DEV] Youtube Videos Gallery

Post by dmzx » Wed Apr 29, 2015 8:39 pm

Lazy2000 wrote:at first this is a great ext and thank you for working on it!

a small issue now.
a 404 at ***.com/video

this happened after i installed the ext "Social Login for phpBB 3.1.x" from here: https://docs.oneall.com/plugins/guide/s ... b/?v=3.1.x
BUT this (404) happens only if i login with FB account etc.
If i login normally (username - pass) everything is working fine.

i am not asking for a solution (although i would like one) i am just informing.
anyways, i 100% prefer to use the gallery and remove the social connection ext.
thanks for your time dmzx and _Vinny_ :)

Looks like the Social Login redirects you to /video instead of app.php/video
Contact me on dmzx-web.net
 Need a Host or buy me a beer Donate and try binance.com

User avatar
tamarin
Registered User
Posts: 117
Joined: Tue Feb 03, 2015 9:02 pm
Location: Germany
Name: Ed

Re: [DEV] Youtube Videos Gallery

Post by tamarin » Wed Apr 29, 2015 9:31 pm

Very nice extension.
It works good.
Thank you very much.

User avatar
dmzx
Registered User
Posts: 770
Joined: Fri Sep 05, 2014 6:48 am
Location: The Netherlands
Contact:

Re: [DEV] Youtube Videos Gallery

Post by dmzx » Mon May 11, 2015 9:41 am

First post updated
Contact me on dmzx-web.net
 Need a Host or buy me a beer Donate and try binance.com

Locked

Return to “Extensions in Development”