[CDB] Amazon Affiliate

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Anti-Spam Guide
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Locked
xprojectsx
Registered User
Posts: 51
Joined: Thu Apr 27, 2006 7:46 pm
Location: U.S.A.

Re: [RC6] Amazon Affiliate

Post by xprojectsx » Thu Aug 13, 2015 4:35 pm

I'm using the s9e mediaembedder. I'm a little confused by your Read This post. Are you stating that every time a user posts an Amazon link from the front end they need to wrap it with url tags?

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC6] Amazon Affiliate

Post by HiFiKabin » Fri Aug 14, 2015 10:02 am

*DELETED*

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC6] Amazon Affiliate

Post by HiFiKabin » Fri Aug 14, 2015 12:39 pm

I have found what the problem is. If you have mediaembed enabled, and an AdBlocking ad-on in your web browser, some of the Amazon links will not appear as the AdBlock sees the mediaembed as an advert while the link is OK.

Also if mediaembed is enabled and transforms the link to an advert, the Affiliate ID will be striped out but not added.

So, to ensure your Amazon Link always shows and has the Affiliate code added, wrap the link in BBCode.

In the screenshot below both posts have the same link. The first link is not wrapped, the second is wrapped in [url] where you can see my-affiliate-code has been changed to AFFILIATE-FR

Image
image post

xprojectsx
Registered User
Posts: 51
Joined: Thu Apr 27, 2006 7:46 pm
Location: U.S.A.

Re: [RC6] Amazon Affiliate

Post by xprojectsx » Fri Aug 14, 2015 3:29 pm

I am still unclear if you mean that this tag is added automatically or if it is the responsibility of the individual user?

If the answer is that the only way this works with s9e is if the users post with the bbcode instead of just a link then in my experience that means that it will happen pretty much never. Maybe other people's forums are different but my users almost never use the URL tag.

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC6] Amazon Affiliate

Post by HiFiKabin » Fri Aug 14, 2015 3:35 pm

I have updated the mediaembed note on my download site to help make things clearer.

Basically if the user copy/pastes an Amazon URL into a post, mediaembed will strip any existing affiliate code, but Amazon Affiliate will not be able to add yours. mediaembed will still append your referring URL as before.

If the link is posted with BBCode formatting your affiliate code will be added.

Nully
Registered User
Posts: 453
Joined: Thu Jan 29, 2009 10:11 pm
Location: France
Contact:

Re: [RC6] Amazon Affiliate

Post by Nully » Fri Aug 14, 2015 3:50 pm

For me its clear.
In my forum, with not many users, I'm the only one posting amazon links, just when I want to give information about new books or musics. So, I'll use bbcode url ;)

TriKe27
Registered User
Posts: 18
Joined: Wed Feb 25, 2015 6:30 pm

Re: [RC6] Amazon Affiliate

Post by TriKe27 » Tue Aug 25, 2015 6:42 am

Hello,

using RC6, I posted some Amazon-Links as well. In the preview mode of a topic the extension works fine and my partner-id is added, but when I save the topic there are just the links, no partner-id is added anymore.

See for example: http://www.schueler-talk.de/viewtopic.php?f=12&t=819

Is there a solution for this?


Thanks in advance

Martin

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC6] Amazon Affiliate

Post by HiFiKabin » Tue Aug 25, 2015 8:34 am

TriKe27 wrote:Hello,

using RC6, I posted some Amazon-Links as well. In the preview mode of a topic the extension works fine and my partner-id is added, but when I save the topic there are just the links, no partner-id is added anymore.

See for example: http://www.schueler-talk.de/viewtopic.php?f=12&t=819

Is there a solution for this?


Thanks in advance

Martin
Your ID is not added to the posted link, but only when the link is hovered/clicked on. The extension requires JavaScript to work. See the screenshot below

Image
imgurl

TriKe27
Registered User
Posts: 18
Joined: Wed Feb 25, 2015 6:30 pm

Re: [RC6] Amazon Affiliate

Post by TriKe27 » Tue Aug 25, 2015 8:41 am

Good to see that it works for you. Then it will also for the visitors of my board. Maybe I can't see the links because of browser caching. Otherwise I cleaned the cache and could see the correct links in preview mode.

Image


But then is all fine :) I try it later with another browser.


TY

Greetings
Martin

TriKe27
Registered User
Posts: 18
Joined: Wed Feb 25, 2015 6:30 pm

Re: [RC6] Amazon Affiliate

Post by TriKe27 » Wed Aug 26, 2015 8:11 am

Is it possible that the link is just not shown for admins? I saw the tag when I logged out.

Who can see the tag? Guests, bots, registered users?

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC6] Amazon Affiliate

Post by HiFiKabin » Wed Aug 26, 2015 10:03 am

Thats strange. Everyone should be able to see the added code (as long as JavaScript is enabled in the viewing browser) I can see it in my test forum no matter my log in/out status.

Try purging the forum cache, the browser cache and restart the browser.

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC7] Amazon Affiliate

Post by HiFiKabin » Sat Aug 29, 2015 10:21 am

1.0.0_rc7 More Affiliate TLD's added. AR translation included. s9e/mediaembed users must read this

Update from previous version:
  • Download the latest release and unzip it.
  • Disable Amazon Affiliate in the ACP
  • Delete amazonaffiliate folder from the server
  • Upload the the folder hifikabin to root/ext/ and enable it in the ACP

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC] Amazon Affiliate

Post by HiFiKabin » Mon Sep 21, 2015 11:06 am

1.0.0 Release Version

Update from previous version:
  • Download the latest release and unzip it.
  • Disable Amazon Affiliate in the ACP
  • Delete amazonaffiliate folder from the server
  • Upload the the folder hifikabin to root/ext/ and enable it in the ACP

Swanny
Registered User
Posts: 444
Joined: Sun Apr 14, 2002 2:11 am
Location: Canada

Re: [RC] Amazon Affiliate

Post by Swanny » Wed Oct 07, 2015 11:26 pm

I had a forum where I was not using this extension, so I added it today. I uploaded, enabled, added my code, cleared the cache and it doesn't seem to work at all. Any ideas why? I can see the javascript code in the HTML source code. It's a standard amazon.com URL link. The "hover over" link and the actual URL that you click and go to does not contain &tag=affiliateid

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 4016
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [RC] Amazon Affiliate

Post by HiFiKabin » Thu Oct 08, 2015 7:12 am

What other extensions do you have enabled? It is likely to be a conflict with one of those

Locked

Return to “Extensions in Development”