[3.2][RC] Glossary 2.1.5

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Kaffe
Registered User
Posts: 64
Joined: Tue Nov 01, 2016 6:18 pm

Re: [3.1][3.2][RC] Glossary 2.0.0

Post by Kaffe » Mon Feb 05, 2018 10:03 am

Deleted the ext (old version) and tried to install it again, and I get this error:

Parse error: syntax error, unexpected '->' (T_OBJECT_OPERATOR) in /......../ext/lmdi/gloss/migrations/release_1.php on line 108

User avatar
pierredu
Registered User
Posts: 880
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Glossary 2.0.0

Post by pierredu » Mon Feb 05, 2018 12:53 pm

I just found this one.

Find
$sql = "alter table ${this->table_prefix}glossary convert to character set utf8 collate utf8_unicode_ci";
and replace with
$sql = "alter table {$this->table_prefix}glossary convert to character set utf8 collate utf8_unicode_ci";

I'll update the repository.

User avatar
eunaumtenhoid
Registered User
Posts: 760
Joined: Wed Jun 03, 2009 12:46 am
Location: ????

Re: [3.1][3.2][RC] Glossary 2.0.0

Post by eunaumtenhoid » Mon Feb 05, 2018 11:01 pm

folder:
board?? no folder ext why??
My translations of the extensions for Brazilian Portuguese
https://github.com/phpBBTraducoes

User avatar
pierredu
Registered User
Posts: 880
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Glossary 2.0.0

Post by pierredu » Tue Feb 06, 2018 7:12 am

If you used the former version of the extension and uploaded graphic files to illustrate the glossary items, those files were stored in the folder board/ext/lmdi/gloss/glossaire. On the other hand, if you didn't use graphic files, you can ignore what I said.

Kaffe
Registered User
Posts: 64
Joined: Tue Nov 01, 2016 6:18 pm

Re: [3.1][3.2][RC] Glossary 2.0.0

Post by Kaffe » Tue Feb 06, 2018 9:08 am

pierredu wrote:
Mon Feb 05, 2018 12:53 pm
I just found this one.

Find
$sql = "alter table ${this->table_prefix}glossary convert to character set utf8 collate utf8_unicode_ci";
and replace with
$sql = "alter table {$this->table_prefix}glossary convert to character set utf8 collate utf8_unicode_ci";

I'll update the repository.
This one solved it :) Once again - thanks for this great ext. It's great, and you're great!

User avatar
pierredu
Registered User
Posts: 880
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Glossary 2.1.0

Post by pierredu » Tue Mar 27, 2018 8:41 am

I uploaded on github a new version (2.1.0) which takes in account the remarks of the testers in the validation process. No changes in the user interface.

BIABrewer
Registered User
Posts: 53
Joined: Sun Nov 08, 2015 12:37 pm
Location: Perth, Australia

Re: [3.1][3.2][RC] Glossary 2.1.0

Post by BIABrewer » Sat Jul 28, 2018 7:04 am

Hi there Pierre and thanks for all your time and hard work!

This is my first time installing your extension and am having a little trouble. I read through all of this thread to make sure I wasn't doing something completely stupid (which I probably am :D). Just thought I'd post the following in case I've missed something obvious.

I'm using phpBB 3.2.2 and...

1. Downloaded the latest zip from github (March 27th version).
2. Extracted, renamed and uploaded to /ext/lmdi/gloss
3. Changed owner and group of all files and directories from root:root to www-data:www-data to match other extensions
4. All folders are 755 and files are 644 (same as my other extension files)
5. Tried enabling using both Update Extensions and the usual Manage Extensions but received the error (see Pic 1).
6. Noticed also that at some point I also lost access to ACP (see Pic 2). Fixed it by clearing cache on server.

Image


Image

My style is not prosilver but I uploaded a copy of lmdi/gloss/styles/prosilver with prosilver renamed to my style (brinf) as that fixes a lot of extension problems but still no luck.

Also...

A. Checked database and saw that phpbb_glossary table was there.
B. Went back to ACP / Customise / Manage Extensions and clicked Delete Data
C. Checked database to check phpbb_glossary had been removed. (It was).
D. Purged cache
E. Tried again but still no luck. Received the Pic 1 error again)
F. I then tried to trigger the error in Pic 2. Pressed Delete Data and then Enabled. Pic 2 didn't happen.
G. Just pressed Enable without doing Delete Data first. Pic 2 error didn't happen.
H. Tried it in Upload Extensions and was unable to trigger Pic 2 there either so can't work out how I managed to trigger the Pic 2 problem sorry.

I did notice that when I did get the Pic 2 error, my cache folder had a subfolder called /installer as well as /production. Without the Pic 2 error, the /installer folder isn't present.

Image

Hope I haven't written too much or posted too many pics.

Also appreciate the way you've answered everyone's questions here as I know that in itself takes a lot of time.

Cheers,
Pat

Image

User avatar
pierredu
Registered User
Posts: 880
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Glossary 2.1.0

Post by pierredu » Sat Jul 28, 2018 8:28 am

This error message (1st one) was also reported by one of the testers in the validation process.
I could not yet find the reason.
I don't have any time free for now. I'll try to fix the matter in a couple of weeks.

User avatar
kasimi
Extension Customisations
Extension Customisations
Posts: 3296
Joined: Sat Sep 10, 2011 7:12 pm
Location: Germany
Contact:

Re: [3.1][3.2][RC] Glossary 2.1.0

Post by kasimi » Sat Jul 28, 2018 9:16 am

Regarding the migration error, this line:

Code: Select all

array('config.add' => array('lmdi_glossary_version', '1324')),
should be

Code: Select all

array('config.add', array('lmdi_glossary_version', '1324')),

BIABrewer
Registered User
Posts: 53
Joined: Sun Nov 08, 2015 12:37 pm
Location: Perth, Australia

Re: [3.1][3.2][RC] Glossary 2.1.0

Post by BIABrewer » Sat Jul 28, 2018 9:35 am

Was just about to post the below and then saw your post kasimi...
Thanks Pierre ;)
Wish I could be of some help to you however the coding skills I have are only just enough for me to get into trouble :lol:
Can't wait to try it out and thanks again for your time.
That worked kasimi - thanks a heap for that and your other work too!
Added "test" in a post and it worked in my style. Will look forward to going exploring now :)

BIABrewer
Registered User
Posts: 53
Joined: Sun Nov 08, 2015 12:37 pm
Location: Perth, Australia

Re: [3.1][3.2][RC] Glossary 2.1.0

Post by BIABrewer » Sat Jul 28, 2018 11:27 am

Just had a play (in my style and ProSilver) and thought I better post the following in case it helps.

Maybe it's an easy fix as the three debug errors shown in the pic below all have exactly the same line...

Code: Select all

foreach ($abc_table as $l)

Image


Here's a pic of Line 240 of helper.php and what surrounds it...


Image


The only other thing I noticed was that in the next pic, if I clicked "Click here" nothing happened. Hopefully it's related to the above?


Image


Wish I could contribute to help you solve these things but I have no idea what any of the above even means :? :)

User avatar
pierredu
Registered User
Posts: 880
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Glossary 2.1.0

Post by pierredu » Sat Jul 28, 2018 1:53 pm

Thanks a lot to Kasimi for pointing the cause.
I'll try to cure the other points before leaving.

Edit: I can't do it just now. On the other hand, the former version (see on github) works for months and years on my board.

2nd edit: if you click the glossary link a second time, it works and the three error messages disappear. I'm not satisfied with this pseudo solution, but this lets you test the extension.
I'll do my job when returning.

User avatar
pierredu
Registered User
Posts: 880
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.2][RC] Glossary 2.1.2

Post by pierredu » Sun Aug 19, 2018 4:19 pm

I'm back, and with a fresh mind, I cured the problems.
A new version 2.1.2 was uploaded on github.

BIABrewer
Registered User
Posts: 53
Joined: Sun Nov 08, 2015 12:37 pm
Location: Perth, Australia

Re: [3.2][RC] Glossary 2.1.2

Post by BIABrewer » Tue Sep 04, 2018 10:25 am

Welcome back Pierre. Hope you had a great break :)

I've been caught on a long job so only just tried new version out now. On installation, I still ran into the migration error so checked /lmdi/gloss/migrations/release_1_3.php file and noticed the => that kasimi mentioned above was still there. I changed that to a comma and that fixed that.

Unfortunately, not having much luck with the Glossary Editor page, even in ProSilver or after clicking the button twice so I'm not sure what's happening there sorry.

If there's no solution, I'll just add my terms directly via the database. That will do the job ;)

Thanks again for all your efforts,
Pat

User avatar
pierredu
Registered User
Posts: 880
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.2][RC] Glossary 2.1.3

Post by pierredu » Tue Sep 04, 2018 11:46 am

I must have mixed my test configurations.
I uploaded a version 2.1.3 on github which should work as advertised.

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: lopoto, Mr Røbøt, Siava and 26 guests