[3.1][3.2][RC] Autolinks 1.2.5

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.21

Post by pierredu » Wed Feb 22, 2017 9:06 am

Are you sure to use the latest version (1.0.21)?

Bruce Banner
Registered User
Posts: 628
Joined: Thu Sep 25, 2014 10:36 am

Re: [RC] Autolinks 1.0.21

Post by Bruce Banner » Wed Feb 22, 2017 4:31 pm

pierredu wrote:
Wed Feb 22, 2017 9:06 am
Are you sure to use the latest version (1.0.21)?
Yep. Clicking the all forums box was doing nothing. Then I disabled another extension and tried the all forums box again and it worked. So I thought it was the other extension that had been blocking it. But then, as an experiment, I re-enabled the other extension, tried the all forums box again, expecting it would go back to not working with the other extension re-enabled, but it still worked. So I'm completely lost. Seems the all forums box is just moody. Sometimes it'll work and sometimes it won't.

User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.21

Post by pierredu » Wed Feb 22, 2017 8:23 pm

This feature uses javascript, exposed by the core. I never took the time to look precisely at what it does and how. Maybe it's time to do it.

sakkiotto
Registered User
Posts: 225
Joined: Mon Jun 13, 2005 9:45 pm

Re: [RC] Autolinks 1.0.21

Post by sakkiotto » Sun Mar 12, 2017 2:57 am

there is a 3.2 version?

User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [RC] Autolinks 1.0.21

Post by pierredu » Sun Mar 12, 2017 8:05 am

There is a little correction that I'll publish very soon.

For the time being, it only works in posts without quotation blocks or smileys.

PS
I uploaded a new version 1.1.0 which works under 3.2.0.

lizardx
Registered User
Posts: 21
Joined: Fri Feb 24, 2017 10:19 am

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by lizardx » Sun Mar 19, 2017 2:15 pm

Nice Ext. Is it possible to put a "nofollow" attribute to the autolinks?

User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu » Sun Mar 19, 2017 3:26 pm

It is possible.
If you're not the only one asking for it, I'll do it.

User avatar
P_I
Registered User
Posts: 860
Joined: Tue Mar 01, 2011 8:35 pm
Location: Calgary
Contact:

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by P_I » Sun Mar 19, 2017 3:41 pm

Or just make it a configurable option and let the board admin make the choice.
Normal people… believe that if it ain’t broke, don’t fix it. Engineers believe that if it ain’t broke, it doesn’t have enough features yet. – Scott Adams

User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu » Sun Mar 19, 2017 4:58 pm

First of all, I would like to know what is the real benefit for the board admin to have such links with the rel="nofollow" option.

User avatar
serek
Registered User
Posts: 50
Joined: Fri Jan 30, 2015 12:47 pm
Location: London
Name: Serge Victor
Contact:

"Spoilered" quotes bug

Post by serek » Thu Mar 23, 2017 12:49 am

Hi, there is a bug when Autolinks parses "spoilered" parts. It randomly links whole paragraphs (!) to a randomly selected links. Unfortunately the forum is not public, so I am not able to provide a link, but it should be easy to reproduce, just observe a forum with a lot of "spoilered" quotes.

User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu » Thu Mar 23, 2017 5:59 am

Can you give me the exact syntax of your spoiler bbcode?

User avatar
serek
Registered User
Posts: 50
Joined: Fri Jan 30, 2015 12:47 pm
Location: London
Name: Serge Victor
Contact:

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by serek » Thu Mar 23, 2017 6:11 am

Code: Select all

[b][i]
Bla Bla Bla[/i][/b]
Ble Ble Ble


[spoiler]
blah blah blah
[/spoiler]
and the whole bla bla and ble ble and blah blah is autolinked to something random from autolinks table.

If you can't reproduce, I am able to send you a link on priv to the forum.

User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu » Thu Mar 23, 2017 6:29 am

I'll try to understand.
Thanks.

User avatar
pierredu
Registered User
Posts: 887
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.2.0

Post by pierredu » Thu Mar 23, 2017 1:17 pm

I just uploaded a new version (1.2.0) which should cure the problem.
I also corrected the log system.

User avatar
karbiko
Registered User
Posts: 77
Joined: Thu Jul 24, 2008 8:47 pm
Location: La Palma, Canary Islands, Spain

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by karbiko » Thu Sep 14, 2017 8:41 pm

I have latest version, updated 2017/03/23, and I had used it for a long time...

Suddenly, in last days I've been informed by my staff that we got this error message:

Image

What can it be happening?

At this moment I had disable this ext, and forum is working with no problem.

thank in advance..

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: Gubkin, mastnacek, Midway, Mohammed AlSarsawi, Siava and 37 guests