Page 13 of 17

Re: [RC] Autolinks 1.0.21

Posted: Wed Feb 22, 2017 9:06 am
by pierredu
Are you sure to use the latest version (1.0.21)?

Re: [RC] Autolinks 1.0.21

Posted: Wed Feb 22, 2017 4:31 pm
by Bruce Banner
pierredu wrote:
Wed Feb 22, 2017 9:06 am
Are you sure to use the latest version (1.0.21)?
Yep. Clicking the all forums box was doing nothing. Then I disabled another extension and tried the all forums box again and it worked. So I thought it was the other extension that had been blocking it. But then, as an experiment, I re-enabled the other extension, tried the all forums box again, expecting it would go back to not working with the other extension re-enabled, but it still worked. So I'm completely lost. Seems the all forums box is just moody. Sometimes it'll work and sometimes it won't.

Re: [RC] Autolinks 1.0.21

Posted: Wed Feb 22, 2017 8:23 pm
by pierredu
This feature uses javascript, exposed by the core. I never took the time to look precisely at what it does and how. Maybe it's time to do it.

Re: [RC] Autolinks 1.0.21

Posted: Sun Mar 12, 2017 2:57 am
by sakkiotto
there is a 3.2 version?

Re: [RC] Autolinks 1.0.21

Posted: Sun Mar 12, 2017 8:05 am
by pierredu
There is a little correction that I'll publish very soon.

For the time being, it only works in posts without quotation blocks or smileys.

PS
I uploaded a new version 1.1.0 which works under 3.2.0.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Sun Mar 19, 2017 2:15 pm
by lizardx
Nice Ext. Is it possible to put a "nofollow" attribute to the autolinks?

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Sun Mar 19, 2017 3:26 pm
by pierredu
It is possible.
If you're not the only one asking for it, I'll do it.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Sun Mar 19, 2017 3:41 pm
by P_I
Or just make it a configurable option and let the board admin make the choice.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Sun Mar 19, 2017 4:58 pm
by pierredu
First of all, I would like to know what is the real benefit for the board admin to have such links with the rel="nofollow" option.

"Spoilered" quotes bug

Posted: Thu Mar 23, 2017 12:49 am
by serek
Hi, there is a bug when Autolinks parses "spoilered" parts. It randomly links whole paragraphs (!) to a randomly selected links. Unfortunately the forum is not public, so I am not able to provide a link, but it should be easy to reproduce, just observe a forum with a lot of "spoilered" quotes.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Thu Mar 23, 2017 5:59 am
by pierredu
Can you give me the exact syntax of your spoiler bbcode?

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Thu Mar 23, 2017 6:11 am
by serek

Code: Select all

[b][i]
Bla Bla Bla[/i][/b]
Ble Ble Ble


[spoiler]
blah blah blah
[/spoiler]
and the whole bla bla and ble ble and blah blah is autolinked to something random from autolinks table.

If you can't reproduce, I am able to send you a link on priv to the forum.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Thu Mar 23, 2017 6:29 am
by pierredu
I'll try to understand.
Thanks.

Re: [3.1][3.2][RC] Autolinks 1.2.0

Posted: Thu Mar 23, 2017 1:17 pm
by pierredu
I just uploaded a new version (1.2.0) which should cure the problem.
I also corrected the log system.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Posted: Thu Sep 14, 2017 8:41 pm
by karbiko
I have latest version, updated 2017/03/23, and I had used it for a long time...

Suddenly, in last days I've been informed by my staff that we got this error message:

Image

What can it be happening?

At this moment I had disable this ext, and forum is working with no problem.

thank in advance..