[3.2][RC] Autolinks 1.3.2

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu »

I'll try to understand what happens.

User avatar
karbiko
Registered User
Posts: 78
Joined: Thu Jul 24, 2008 8:47 pm
Location: La Palma, Canary Islands, Spain

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by karbiko »

I don't know what or why...


I just disabled the ext, desinstalled it, and reinstall the last repository and I thoutht now it was working ok...

But reality is that the problem still remains...

any idea to solve it?


Edit: because I thought is was ok... Just a dream! ;)

User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu »

I tried to understand the very reason of those warnings. According to this Stackoverflow page, since the regex pattern has delimiters, this means that your strings contains this delimiter.
Could you send me the contents of your autolinks table ? I'll send you a mp with my email address.

Movie
Registered User
Posts: 127
Joined: Sun Nov 02, 2014 2:54 pm
Location: Chicago Illinois Area.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by Movie »

I downloaded and unzipped to ext/lmdi and the extension does not show up in Extensions Manager under Disabled Extensions.

Suggestions as to why its not showing up?


PHPBB Current version 3.2.1 is i because its not v3.1 ?

Thanks.
View signatures turned off.

User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu »

The extension works under 3.2.0 and 3.2.1.
The composer.json file should be in folder ext/lmdi/autolinks.

Movie
Registered User
Posts: 127
Joined: Sun Nov 02, 2014 2:54 pm
Location: Chicago Illinois Area.

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by Movie »

pierredu wrote:
Fri Oct 13, 2017 2:07 pm
The extension works under 3.2.0 and 3.2.1.
The composer.json file should be in folder ext/lmdi/autolinks.
There is no ext/lmdi/autolinks just ext/lmdi/with all the other directories this is how the zip file I downloaded extracts.

I created a autolinks directory then moved the files that the zip file extracted into the created autolinks directory and now "LMDI Autolinks" shows up under the Disabled Extensions.

I would suggest you include these instructions next to ALL download links or fix your zip file so it extracts correctly.

I have about 4 other Extensions that are NOT showing up under Disabled Extensions right now I assume I will have to chase down all them also to find out what the correct directory structure is also, NOT sure why some authors Extensions extract correctly and show up then others do not seems like a industry standard needs created in the PHPBB Extension system, I remember a 200+ million dollar multi year space mission crashing and burning over missed details this simple.

Thanks for the help/extension time to test :-)
View signatures turned off.

User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu »

Extensions which are not yet validated are still stored under the github storing scheme.
You'll have to do the mental changes to do your tests.

utagawa
Registered User
Posts: 5
Joined: Mon Jul 27, 2015 2:28 pm

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by utagawa »

hello,

How to configure the exetension to avoid php warnings ?

I tried the regex tip above without success.

I'm trying to redirect urls with this extension eg :

http://www.websiteA.com => https://www.websiteB.com

Can it be done or the extension requires some updates to be able to cope with that ?

User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu »

The Autolinks extension is not conceived to do redirections. For that, use the classical redirection rules in the .htaccess file. This extension is meant to build outgoing URLs from keywords in the messages.

User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu »

I've found the reason of the PHP warnings.
In the keywords, you have one with a slash (Ley 20[b]/[/b]2011). Without the slash, your dataset works correctly.
As a temporary measure, you can delete the entry, or replace it with ley 20-2011, if this doesn't imply too much manual work.
On my side, I'll have to search how to escape the slash on the processing path.

User avatar
3Di
Former Team Member
Posts: 14828
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by 3Di »

pierredu wrote:
Sun Oct 15, 2017 8:21 am
On my side, I'll have to search how to escape the slash on the processing path.
See if this helps (slashes and backslashes as well, replaced by null)

Code: Select all

$ary = ['/ ', '\'];
$string = str_replace($ary, '', $string);
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Premium extensions @ The Studio

User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by pierredu »

Marco,

Thanks for the proposition.
I had found in the mean time the preg_quote function, which is precisely aimed at this situation.

On the other hand, all my Travis tests fail.
The scripts changed heavily in the summertime.

User avatar
karbiko
Registered User
Posts: 78
Joined: Thu Jul 24, 2008 8:47 pm
Location: La Palma, Canary Islands, Spain

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by karbiko »

I have deleted it momentarily and now it is working correctly.

But this could not be the solution, because it is necessary to be able to use the slash as a separator, because in Spanish all laws are mentioned by its own number and the year in which it is promulgated, and both numbers are separated by that symbol.

So, 3Di's may be the option.
Buy where should I do that change?

Edit: Sorry, I did not see that, your last previous post, Pierre

User avatar
pierredu
Registered User
Posts: 1031
Joined: Thu Nov 01, 2012 8:04 am
Location: Paris (France)

Re: [3.1][3.2][RC] Autolinks 1.2.2

Post by pierredu »

The current version (1.2.2) on github should work correctly, even with slashes.
On the other hand, it doesn't pass the travis test suite (error 2 on all *.sh scripts).

User avatar
karbiko
Registered User
Posts: 78
Joined: Thu Jul 24, 2008 8:47 pm
Location: La Palma, Canary Islands, Spain

Re: [3.1][3.2][RC] Autolinks 1.1.0

Post by karbiko »

Problem solved!!!

Thanks to all by your patience and your great support!!

Great ext, Pierre!

Post Reply

Return to “Extensions in Development”