[RC] Servers Board

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Token07
Registered User
Posts: 62
Joined: Thu Mar 03, 2016 4:58 pm

Re: [RC] Servers Board

Post by Token07 » Wed Sep 21, 2016 1:12 pm

chfs wrote:Thanks,

What should be the path to an icon?
That actually shouldn't have been in update. As of right now, it doesn't do anything.
Bogdan. wrote:
Token07 wrote:
Bogdan. wrote:I dont know what i did wrong but it still appears offline - http://lafel.ro/forum/app.php/serversboard
What protocol are you using?

Edit: I did get it working with "Counter Strike 1.5" under won protocol
Yea i tried that too,still doesnt work,i think im gonna give up..
I got it to work on my test board, so the issue is probably a firewall or your host may not allow sockets. The Latest update contains an update contains a tool to test connectivity to a server, which might help.

Bogdan.
Registered User
Posts: 32
Joined: Thu Sep 15, 2016 6:50 pm
Contact:

Re: [RC] Servers Board

Post by Bogdan. » Wed Sep 21, 2016 4:17 pm

Token07 wrote:
chfs wrote:Thanks,

What should be the path to an icon?
That actually shouldn't have been in update. As of right now, it doesn't do anything.
Bogdan. wrote:
Token07 wrote:
Bogdan. wrote:I dont know what i did wrong but it still appears offline - http://lafel.ro/forum/app.php/serversboard
What protocol are you using?

Edit: I did get it working with "Counter Strike 1.5" under won protocol
Yea i tried that too,still doesnt work,i think im gonna give up..
I got it to work on my test board, so the issue is probably a firewall or your host may not allow sockets. The Latest update contains an update contains a tool to test connectivity to a server, which might help.

Code: Select all

Stack trace:
#0 /home/lafelro1/public_html/forum/vendor/symfony/routing/Symfony/Component/Routing/Loader/YamlFileLoader.php(46): Symfony\Component\Config\FileLocator->locate('ext/token07/ser...')
#1 /home/lafelro1/public_html/forum/phpbb/controller/provider.php(77): Symfony\Component\Routing\Loader\YamlFileLoader->load('ext/token07/ser...')
#2 /home/lafelro1/public_html/forum/phpbb/controller/helper.php(94): phpbb\controller\provider->find('./')
#3 /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php(958): phpbb\controller\helper->__construct(Object(phpbb\template\twig\twig), Object(phpbb\user), Object(phpbb\config\db), Object(phpbb\controller\provider), Object(phpbb\extension\manager), Object(phpbb\symfony_r in /home/lafelro1/public_html/forum/vendor/symfony/config/Symfony/Component/Config/FileLocator.php on line 69
[21-Sep-2016 19:13:09 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:13:10 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:13:11 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:13:12 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:13:12 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:11 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:13 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:14 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:14 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:15 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:16 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:17 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:18 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:18 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:19 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:19 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:20 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:14:52 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:15:09 Europe/Bucharest] PHP Fatal error:  require(): Failed opening required './ext/token07/serversboard/event/main_listener.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/phpbb/class_loader.php on line 160
[21-Sep-2016 19:15:10 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:10 Europe/Bucharest] PHP Fatal error:  require_once(): Failed opening required '/home/lafelro1/public_html/forum/ext/token07/serversboard/vendor/composer/autoload_real.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/ext/token07/serversboard/vendor/autoload.php on line 5
[21-Sep-2016 19:15:11 Europe/Bucharest] PHP Fatal error:  require_once(): Failed opening required '/home/lafelro1/public_html/forum/ext/token07/serversboard/vendor/composer/autoload_real.php' (include_path='.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php') in /home/lafelro1/public_html/forum/ext/token07/serversboard/vendor/autoload.php on line 5
[21-Sep-2016 19:15:12 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:13 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:14 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:15 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:16 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:17 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:17 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:20 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
[21-Sep-2016 19:15:21 Europe/Bucharest] PHP Catchable fatal error:  Argument 6 passed to token07\serversboard\event\main_listener::__construct() must be an instance of phpbb\collapsiblecategories\operator\operator, string given, called in /home/lafelro1/public_html/forum/cache/container_0374ec857381230fa83049643ce3cdee.php on line 3352 and defined in /home/lafelro1/public_html/forum/ext/token07/serversboard/event/main_listener.php on line 35
The forum doesnt work now if i use that....i guess is the host or idk

Token07
Registered User
Posts: 62
Joined: Thu Mar 03, 2016 4:58 pm

Re: [RC] Servers Board

Post by Token07 » Wed Sep 21, 2016 5:19 pm

Looks like its missing a couple files

bslgames
Registered User
Posts: 1
Joined: Wed Sep 21, 2016 10:36 pm

Re: [RC] Servers Board

Post by bslgames » Wed Sep 21, 2016 10:39 pm

I have a problem when adding servers some of them work, some - not
http://bsl-games.eu/app.php/serversboard
A server stands on 0/0 and is online.. Sorry for my bad english.

User avatar
nero
Registered User
Posts: 321
Joined: Fri Mar 13, 2015 8:18 am

Re: [RC] Servers Board

Post by nero » Sun Sep 25, 2016 3:09 am

Token07 wrote:
nero wrote:Can you make it work with ravaio style?
Looks like it's a non-free style so I don't have a way to test it. If you have a link to a board using it, I can try. Or perhaps ask the style developer to look into it.
www.travincial.com

chfs
Registered User
Posts: 231
Joined: Mon Feb 04, 2013 10:01 am

Re: [RC] Servers Board

Post by chfs » Mon Oct 03, 2016 9:00 am

chfs wrote:Add a table-type games? Cs, MC, CoD etc. Thanks. 8-)


Status | Server name | IP | Players | Map | Game | Options

Hi, Token07
Will this? Thank you 8-)

great extension, keep it up :roll:
I'm sorry for my english. :?

WISHEXEC
Registered User
Posts: 87
Joined: Fri Dec 04, 2015 12:39 pm

Re: [RC] Servers Board

Post by WISHEXEC » Tue Jan 17, 2017 9:53 am

An update for 3.2 boards ? :)

Token07
Registered User
Posts: 62
Joined: Thu Mar 03, 2016 4:58 pm

Re: [RC] Servers Board

Post by Token07 » Mon Jan 30, 2017 8:59 pm

Should work fine for 3.2

User avatar
</Solidjeuh>
Registered User
Posts: 1147
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: [RC] Servers Board

Post by </Solidjeuh> » Tue Jan 31, 2017 1:48 pm

Can't get it to work for VC.MP = https://vc-mp.org/

Server IP: 178.62.228.75
Port: 8192
We offer fun HTML5 games for young and old.
Register a free account & enjoy all functions!
Save your score, challenge other members or play along with our tournaments.


~~~ https://www.solidjeuh.be ~~~

User avatar
wkuzma
Registered User
Posts: 389
Joined: Sun Sep 02, 2007 10:18 pm
Contact:

Re: [RC] Servers Board

Post by wkuzma » Thu Apr 13, 2017 4:18 am

I am running on 3.2
and found that at times it will not update the servers and I have to disable and re-enable the extension to get it working again
I have the update time set to 5 seconds
any idea why?
I am using version 1.0.0-rc1

Token07
Registered User
Posts: 62
Joined: Thu Mar 03, 2016 4:58 pm

Re: [RC] Servers Board

Post by Token07 » Tue Apr 18, 2017 9:39 pm

wkuzma wrote:
Thu Apr 13, 2017 4:18 am
I am running on 3.2
and found that at times it will not update the servers and I have to disable and re-enable the extension to get it working again
I have the update time set to 5 seconds
any idea why?
I am using version 1.0.0-rc1
Five seconds is extremely often. Some servers might ratelimit requests and that could be a possible cause.

User avatar
wkuzma
Registered User
Posts: 389
Joined: Sun Sep 02, 2007 10:18 pm
Contact:

Re: [RC] Servers Board

Post by wkuzma » Wed Apr 19, 2017 12:59 am

Thanks I will increase it and see how it goes

chfs
Registered User
Posts: 231
Joined: Mon Feb 04, 2013 10:01 am

Re: [RC] Servers Board

Post by chfs » Wed Apr 19, 2017 5:23 pm

Hello Token07, thanks for update


please problem, will fix?
Fatal error: Uncaught TypeError: Argument 7 passed to token07\serversboard\controller\admin_controller::__construct() must be an instance of token07\serversboard\cron\task\update_serversboard, string given, called in
I'm sorry for my english. :?

Token07
Registered User
Posts: 62
Joined: Thu Mar 03, 2016 4:58 pm

Re: [RC] Servers Board

Post by Token07 » Wed Apr 19, 2017 5:50 pm

If you're using latest code from github, I think I forgot to commit something. Should be fixed shortly. But try clearing the cache too.

Edit: Should be fixed...

chfs
Registered User
Posts: 231
Joined: Mon Feb 04, 2013 10:01 am

Re: [RC] Servers Board

Post by chfs » Wed Apr 19, 2017 6:37 pm

Thanks, It works beautifully

Good Job! 8-)
I'm sorry for my english. :?

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: canonknipser, Google [Bot], Gubkin, ImagesGuru, martti, PGreca and 19 guests