Page 10 of 12

Re: [RC] Servers Board

Posted: Thu Apr 20, 2017 4:11 pm
by wkuzma
Token07 wrote:
Tue Apr 18, 2017 9:39 pm
wkuzma wrote:
Thu Apr 13, 2017 4:18 am
I am running on 3.2
and found that at times it will not update the servers and I have to disable and re-enable the extension to get it working again
I have the update time set to 5 seconds
any idea why?
I am using version 1.0.0-rc1
Five seconds is extremely often. Some servers might ratelimit requests and that could be a possible cause.
I raised it to 30 seconds then 1 minute and still have to disable and re-enable the extension for it to register who is in the servers

Re: [RC] Servers Board

Posted: Fri Apr 21, 2017 7:26 pm
by Token07
Can you check on a couple things:
  1. ACP-> General -> SERVER CONFIGURATION -> Server Settings -> Run periodic tasks from system cron
    Is this set to Yes or No?
  2. When it's not updating, the "Last updated" column from servers board
  3. The servers board update frequency
  4. PHP error log for anything relating to files in <your board path>/ext/token07/serversboard
Also try editing a server (you should be able to just click save) and let me know if it updates

Re: [RC] Servers Board

Posted: Sat Apr 22, 2017 5:02 am
by wkuzma
Can you check on a couple things:
  1. ACP-> General -> SERVER CONFIGURATION -> Server Settings -> Run periodic tasks from system cron
    Is this set to Yes or No?

    it is set to no.
  2. When it's not updating, the "Last updated" column from servers board

    Last updated: Fri Apr 21, 2017 11:56 pm
    however time now is Sat April 22 101 am
  3. The servers board update frequency

    set to 30 seconds
  4. PHP error log for anything relating to files in <your board path>/ext/token07/serversboard
error log
Gen Stranger 73.29.175.138 Sun Apr 16, 2017 8:32 pm Error while creating image
» Error in [ROOT]/ext/token07/serversboard/vendor/austinb/gameq/src/GameQ/Protocols/Quake3.php on line 107: array_key_exists(): The first argument should be either a string or an integer
Gen Stranger 73.29.175.138 Sun Apr 16, 2017 8:32 pm Error while creating image
» Error in [ROOT]/ext/token07/serversboard/vendor/austinb/gameq/src/GameQ/Protocols/Quake3.php on line 107: array_key_exists(): The first argument should be either a string or an integer
repeats over and over but with different dates and times

Also try editing a server (you should be able to just click save) and let me know if it updates

if I edit a server it updates but not all the time

if I check in about 5 minutes it shows me in the server even after I left the server until I edit a server
then it shows empty

if I constantly refresh the page if does update after about 5 refreshes

Re: [RC] Servers Board

Posted: Sat Apr 22, 2017 5:29 am
by wkuzma
I have been in the server about 5 minutes and it still does not show me last update shows

Last updated: Sat Apr 22, 2017 12:29 am

its now 1:35 am

ah it just updated
Last updated: Sat Apr 22, 2017 12:34 am

time is 1:37am

Re: [RC] Servers Board

Posted: Sat Apr 22, 2017 6:49 am
by Token07
Try this version from Github and let me know if that fixes the problem.

Re: [RC] Servers Board

Posted: Sat Apr 22, 2017 2:56 pm
by wkuzma
This one works better - ty

I also found why the difference in updated time my time was one hour behind in the user control panel

Re: [RC] Servers Board

Posted: Sat Apr 22, 2017 7:21 pm
by chfs
Hi Token09,
thanks

Re: [RC] Servers Board

Posted: Sat Apr 22, 2017 11:15 pm
by wkuzma
wkuzma wrote:
Sat Apr 22, 2017 2:56 pm
This one works better - ty

I also found why the difference in updated time my time was one hour behind in the user control panel
I guess I spoke too soon

Last updated: Sat Apr 22, 2017 11:13 am
its now 7:14pm and still no update it shows me still in server

Re: [RC] Servers Board

Posted: Sat Apr 22, 2017 11:25 pm
by Token07
wkuzma wrote:
Sat Apr 22, 2017 11:15 pm
wkuzma wrote:
Sat Apr 22, 2017 2:56 pm
This one works better - ty

I also found why the difference in updated time my time was one hour behind in the user control panel
I guess I spoke too soon

Last updated: Sat Apr 22, 2017 11:13 am
its now 7:14pm and still no update it shows me still in server
Is there anything new in php error log

Re: [RC] Servers Board

Posted: Sun Apr 23, 2017 5:39 am
by wkuzma
Token07 wrote:
Sat Apr 22, 2017 11:25 pm
wkuzma wrote:
Sat Apr 22, 2017 11:15 pm
wkuzma wrote:
Sat Apr 22, 2017 2:56 pm
This one works better - ty

I also found why the difference in updated time my time was one hour behind in the user control panel
I guess I spoke too soon

Last updated: Sat Apr 22, 2017 11:13 am
its now 7:14pm and still no update it shows me still in server
Is there anything new in php error log
No - there are no entries in the log at all

Re: [RC] Servers Board

Posted: Sun Apr 23, 2017 9:50 am
by chfs
Will support jQuery effect?

Re: [RC] Servers Board

Posted: Sun Apr 23, 2017 10:49 am
by Token07
chfs wrote:
Sun Apr 23, 2017 9:50 am
Will support jQuery effect?
Not sure what you mean

Re: [RC] Servers Board

Posted: Sun Apr 23, 2017 11:33 am
by chfs
Opening windows in animations

Re: [RC] Servers Board

Posted: Fri Apr 28, 2017 6:22 am
by chfs
This extension will be approved?

This extension is very good and we will all like it when there is a lot of development

thank you very much Token07 8-)

Re: [RC] Servers Board

Posted: Sun Jul 09, 2017 9:01 pm
by dynserver
Hey I was using this on my 3.1.9 board, then upgraded to 3.2 and it still worked, until I noticed it wasnt updating the player amount, so then I went and deleted it and downloaded your most recent github version of it..

Uploaded it..

Went to "Add Server"

and I get :

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/ext/token07/serversboard/controller/admin_controller.php on line 422: dir([ROOT]/ext/token07/serversboard/controller/../vendor/austinb/gameq/src/GameQ/Protocols/): failed to open dir: No such file or directory

Fatal error: Call to a member function read() on boolean in /usr/www/dynclan/public/forums/ext/token07/serversboard/controller/admin_controller.php on line 427

BUT then.. if I just enable it to show on index.. my whole board errors showing:

Code: Select all


SQL ERROR [ mysqli ]

Unknown column 'server_show_gametracker' in 'field list' [1054]

SQL

SELECT server_id, server_status, server_hostname, server_ip, server_players, server_map, server_join_link, server_show_gametracker FROM phpbb_serversboard ORDER BY server_order

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/driver/factory.php
LINE: 329
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/ext/token07/serversboard/event/main_listener.php
LINE: 79
CALL: phpbb\db\driver\factory->sql_query()

FILE: (not given by php)
LINE: (not given by php)
CALL: token07\serversboard\event\main_listener->load_serversboard()

FILE: [ROOT]/vendor/symfony/event-dispatcher/EventDispatcher.php
LINE: 184
CALL: call_user_func()

FILE: [ROOT]/vendor/symfony/event-dispatcher/EventDispatcher.php
LINE: 46
CALL: Symfony\Component\EventDispatcher\EventDispatcher->doDispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 60
CALL: Symfony\Component\EventDispatcher\EventDispatcher->dispatch()

FILE: [ROOT]/phpbb/event/dispatcher.php
LINE: 46
CALL: phpbb\event\dispatcher->dispatch()

FILE: [ROOT]/index.php
LINE: 235
CALL: phpbb\event\dispatcher->trigger_event()



I pretty much did an update from 3.1.9 to 3.2.0

I'm also now trying to delete data and get it out completely to maybe a fresh install but I'm getting this:

Code: Select all


SQL ERROR [ mysqli ]

Table 'dynclan_forum.phpbb_serversboard' doesn't exist [1146]

SQL

SHOW COLUMNS FROM phpbb_serversboard

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 885
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 902
CALL: phpbb\db\tools\tools->sql_list_columns()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 602
CALL: phpbb\db\tools\tools->sql_column_exists()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools\tools->perform_schema_changes()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 711
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 658
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 586
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 514
CALL: phpbb\db\migrator->try_revert()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 488
CALL: phpbb\db\migrator->revert_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 108
CALL: phpbb\db\migrator->revert()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 354
CALL: phpbb\extension\base->purge_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 283
CALL: phpbb\extension\manager->purge_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()



:roll:

honestly if you could just tell me how to bypass those errors when deleting data.. i'd be happy with just removing it...

and maybe then testing a fresh install all over again.. lol