[CDB] Contact Admin

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
wkuzma
Registered User
Posts: 389
Joined: Sun Sep 02, 2007 10:18 pm
Contact:

Re: [RC] Contact Admin

Post by wkuzma » Thu May 26, 2016 4:13 am

RMcGirr83 wrote:Ah okay, thanks for testing that. Everything else seem to work fine?
everything else seems fine so far.

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC] Contact Admin

Post by RMcGirr83 » Thu May 26, 2016 9:14 am

Github has been updated
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
donsenilo
Registered User
Posts: 303
Joined: Wed Oct 08, 2014 6:23 pm
Name: Markus
Contact:

Re: [RC] Contact Admin

Post by donsenilo » Thu May 26, 2016 2:53 pm

hello

when a guest uses your contact form I get the following error messages:
Ein allgemeiner Fehler ist aufgetreten: 401: Authorization Required
» /contactadmin
and
E-Mail-Fehler
» EMAIL/PHP/mail()
/app.php
and the message is not sent.

This happens only with guests.

When I set "Contact method:" to "Private message" I get this error:
[phpBB Debug] PHP Warning: in file [ROOT]/ext/rmcgirr83/contactadmin/controller/main_controller.php on line 301: sprintf(): Too few arguments
But the message is sent but without text.

For now I have to disable this extension.

User avatar
wkuzma
Registered User
Posts: 389
Joined: Sun Sep 02, 2007 10:18 pm
Contact:

Re: [RC] Contact Admin

Post by wkuzma » Thu May 26, 2016 6:11 pm

RMcGirr83 wrote:Github has been updated
I see by the update that you corrected the email part.

all seems to be working fine

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC] Contact Admin

Post by RMcGirr83 » Thu May 26, 2016 6:35 pm

donsenilo wrote:hello

when a guest uses your contact form I get the following error messages:
Ein allgemeiner Fehler ist aufgetreten: 401: Authorization Required
» /contactadmin
and
E-Mail-Fehler
» EMAIL/PHP/mail()
/app.php
and the message is not sent.

This happens only with guests.
Ensure you have translated the email templates found within en folder of the extension. You must have de if that is your language
When I set "Contact method:" to "Private message" I get this error:
[phpBB Debug] PHP Warning: in file [ROOT]/ext/rmcgirr83/contactadmin/controller/main_controller.php on line 301: sprintf(): Too few arguments
But the message is sent but without text.

For now I have to disable this extension.
Use the latest version

https://github.com/rmcgirr83/contactadm ... /tag/1.0.1
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
donsenilo
Registered User
Posts: 303
Joined: Wed Oct 08, 2014 6:23 pm
Name: Markus
Contact:

Re: [RC] Contact Admin

Post by donsenilo » Thu May 26, 2016 6:57 pm

Ensure you have translated the email templates found within en folder of the extension. You must have de if that is your language
Use the latest version
I have done both !

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC] Contact Admin

Post by RMcGirr83 » Thu May 26, 2016 9:29 pm

Well you did something wrong then. Do you have en installed on your forum? If so try with that and see.

FWIW, the language files did change in 1.0.1
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

sakkiotto
Registered User
Posts: 228
Joined: Mon Jun 13, 2005 9:45 pm

Re: [RC] Contact Admin

Post by sakkiotto » Fri May 27, 2016 12:01 pm

i use recaptcha2 i have problem :D could be ??

Code: Select all

The reCAPTCHA you submitted was incorrect
Last edited by sakkiotto on Fri May 27, 2016 12:03 pm, edited 1 time in total.

sakkiotto
Registered User
Posts: 228
Joined: Mon Jun 13, 2005 9:45 pm

Re: [RC] Contact Admin

Post by sakkiotto » Fri May 27, 2016 12:01 pm

sorry double post.

edit: fixed

sakkiotto
Registered User
Posts: 228
Joined: Mon Jun 13, 2005 9:45 pm

Re: [RC] Contact Admin

Post by sakkiotto » Wed Jun 08, 2016 10:11 pm

.

User avatar
Simps
Registered User
Posts: 40
Joined: Thu Jul 23, 2015 11:49 am
Location: Stafford. UK
Name: Simon

Re: [RC] Contact Admin

Post by Simps » Thu Jun 09, 2016 12:09 am

Works a treat, thank you.

User avatar
donsenilo
Registered User
Posts: 303
Joined: Wed Oct 08, 2014 6:23 pm
Name: Markus
Contact:

Re: [RC] Contact Admin

Post by donsenilo » Thu Jun 09, 2016 12:18 am

RMcGirr83 wrote:Well you did something wrong then. Do you have en installed on your forum? If so try with that and see.

FWIW, the language files did change in 1.0.1
Yes, EN is installed. If necessary I add DE-Files manualy.

and btw ...
in the error-protocols I see that the username is "Google Adsense [Bot]" ... maybe this is the problem ?

User avatar
RMcGirr83
Recognised Extension Developer
Posts: 21034
Joined: Wed Jun 22, 2005 4:33 pm
Location: Your display
Name: Rich McGirr
Contact:

Re: [RC] Contact Admin

Post by RMcGirr83 » Thu Jun 09, 2016 9:26 am

donsenilo wrote:in the error-protocols I see that the username is "Google Adsense [Bot]" ... maybe this is the problem ?
I don't know what this means. Bots don't have access to the form.
In times of change, learners inherit the earth, while the learned find themselves beautifully equipped to deal with a world that no longer exists - Eric Hoffer
Former Modifications/Extensions Team Member | My extensions
Appreciate the extensions/mods/support then buy me a beer
All requests for support via PM will be ignored

User avatar
donsenilo
Registered User
Posts: 303
Joined: Wed Oct 08, 2014 6:23 pm
Name: Markus
Contact:

Re: [RC] Contact Admin

Post by donsenilo » Thu Jun 16, 2016 11:54 pm

Hello

Bots have access to my forum.

But what ever ...

I've found now a solution that this ext works for me.

Thank you.

sakkiotto
Registered User
Posts: 228
Joined: Mon Jun 13, 2005 9:45 pm

Re: [RC] Contact Admin

Post by sakkiotto » Fri Jun 17, 2016 7:27 am

because you have adsense code in contact form page (header , footer or sidebar?)

Locked

Return to “Extensions in Development”