[CDB] Official Extension: Media Embed PlugIn

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Get Involved
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
rogerio24
Registered User
Posts: 51
Joined: Sat Jul 05, 2014 1:18 am
Location: Córdoba - Argentina
Name: Roger Biderbost
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by rogerio24 » Mon Jan 09, 2017 11:03 pm

VSE wrote:
Mon Jan 09, 2017 8:30 pm
rogerio24 wrote:
Sun Jan 08, 2017 8:22 pm
Hi
I have upgraded to the latest version , 3.2. Well I have installed the offical extension media sharing. IT was installed without any problem. Well when I click in preview it works perfect but then when I do click in "submit" after that I can not see the media embed in the thread. Any solution?
Thanks


Look this video and you will see what I mean

https://youtu.be/KhnIoG7j3f0


Look with this extension (s9e/mediaembed ) I had the same problem for this reason I chose a official extension.
Well I will wait the fix

Thanks in advance
You appear to have a lot of stuff going on with your forum. Maybe you should try disabling other extension, or just installing this extension alone on a fresh install of phpBB to see if the problem exists on its own first. My suspicion is you have some other extension or issue with your forum causing it.

This extension does not actually do any of the embedding. It is all handled by the s9e textformatter plugin which is part of phpBB package. At any rate since it's not reproducible here, you're gonna have to do some detective work to find out the cause first.
Thanks for your answer, I figured out that your extension does not support http , then I tried the same videos links with https and it works

User avatar
VSE
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 4842
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by VSE » Tue Jan 10, 2017 12:35 am

http and https youtube links work for me.
Dictated but not read.
Official phpBB Extensions My Extensions & MODs
Please do not PM me for support.

User avatar
lopoto
Registered User
Posts: 104
Joined: Thu Feb 12, 2015 3:13 pm

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by lopoto » Tue Jan 10, 2017 12:49 am

VSE wrote:
Tue Jan 10, 2017 12:35 am
http and https youtube links work for me.
for me to :ugeek: thx

rogerio24
Registered User
Posts: 51
Joined: Sat Jul 05, 2014 1:18 am
Location: Córdoba - Argentina
Name: Roger Biderbost
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by rogerio24 » Tue Jan 10, 2017 2:25 am

lopoto wrote:
Tue Jan 10, 2017 12:49 am
VSE wrote:
Tue Jan 10, 2017 12:35 am
http and https youtube links work for me.
for me to :ugeek: thx
and now work for me jajaja it is very strange. Never mind. Now everything is working
Thanks

User avatar
CarpCharacin
Registered User
Posts: 473
Joined: Sat Dec 06, 2014 1:59 pm
Location: Salt Lake City, Utah
Name: James Stewart
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by CarpCharacin » Tue Jan 10, 2017 6:43 am

For some reason it isn't working. I tried putting the youtube video URL inside of the bbcode tags and I tried pasting the URL in without the bbcode and it didn't work. The extension is installed and enabled, but it just dosen't work. Any ideas on how I can get it to work?

User avatar
VSE
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 4842
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by VSE » Tue Jan 10, 2017 6:52 am

CarpCharacin wrote:
Tue Jan 10, 2017 6:43 am
For some reason it isn't working. I tried putting the youtube video URL inside of the bbcode tags and I tried pasting the URL in without the bbcode and it didn't work. The extension is installed and enabled, but it just dosen't work. Any ideas on how I can get it to work?
Make sure you can use youtube. This extension has settings, you should check them.
Dictated but not read.
Official phpBB Extensions My Extensions & MODs
Please do not PM me for support.

User avatar
CarpCharacin
Registered User
Posts: 473
Joined: Sat Dec 06, 2014 1:59 pm
Location: Salt Lake City, Utah
Name: James Stewart
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by CarpCharacin » Tue Jan 10, 2017 6:53 am

VSE wrote:
Tue Jan 10, 2017 6:52 am
CarpCharacin wrote:
Tue Jan 10, 2017 6:43 am
For some reason it isn't working. I tried putting the youtube video URL inside of the bbcode tags and I tried pasting the URL in without the bbcode and it didn't work. The extension is installed and enabled, but it just dosen't work. Any ideas on how I can get it to work?
Make sure you can use youtube. This extension has settings, you should configure them.
I tried with youtube. Everything is enabled in settings and it just don't work. EDIT: i figured out what was wrong. It was conflicting with the old youtube bbcode that used [youtube]videoid[/youtube]. Is there any way to update the old videos embedded to use the new extension?

User avatar
VSE
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 4842
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by VSE » Tue Jan 10, 2017 6:59 am

CarpCharacin wrote:
Tue Jan 10, 2017 6:53 am
VSE wrote:
Tue Jan 10, 2017 6:52 am
CarpCharacin wrote:
Tue Jan 10, 2017 6:43 am
For some reason it isn't working. I tried putting the youtube video URL inside of the bbcode tags and I tried pasting the URL in without the bbcode and it didn't work. The extension is installed and enabled, but it just dosen't work. Any ideas on how I can get it to work?
Make sure you can use youtube. This extension has settings, you should configure them.
I tried with youtube. Everything is enabled in settings and it just don't work. EDIT: i figured out what was wrong. It was conflicting with the old youtube bbcode that used [youtube]videoid[/youtube]. Is there any way to update the old videos embedded to use the new extension?
No. Not really. The MediaEmbed plugin causes that BBCode conflict, and only its author can resolve that. Your best bet in that case is to continue with the old youtube BBCode, and use this extension for all the other media sites out there. Or abandon the old bBCode and understand that will break the old posts.
Dictated but not read.
Official phpBB Extensions My Extensions & MODs
Please do not PM me for support.

User avatar
CarpCharacin
Registered User
Posts: 473
Joined: Sat Dec 06, 2014 1:59 pm
Location: Salt Lake City, Utah
Name: James Stewart
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by CarpCharacin » Tue Jan 10, 2017 7:01 am

The old bbcode uses the old crappy player that youtube is discontinuing. Could I use a SQL query to fix it?

Here is the old bbcode: https://gist.github.com/CarpCharacin/19 ... 2c7efdd483

User avatar
CarpCharacin
Registered User
Posts: 473
Joined: Sat Dec 06, 2014 1:59 pm
Location: Salt Lake City, Utah
Name: James Stewart
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by CarpCharacin » Tue Jan 10, 2017 7:07 am

I added back the old bbcode and removed the plugin, but now there is just a blank spot where the videos used to be.


User avatar
VSE
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 4842
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [3.2][ALPHA] Official Extension: Media Embed PlugIn

Post by VSE » Fri Jan 13, 2017 7:36 am

CarpCharacin wrote:
Tue Jan 10, 2017 7:01 am
The old bbcode uses the old crappy player that youtube is discontinuing. Could I use a SQL query to fix it?

Here is the old bbcode: https://gist.github.com/CarpCharacin/19 ... 2c7efdd483
Just update it to the newer youtube iframe code. It's pretty straight forward, you can get it off any youtube page.

Also, there is no SQL query you can use to "fix" old posts. Basically you'd need a converter for that, but none exists.
Dictated but not read.
Official phpBB Extensions My Extensions & MODs
Please do not PM me for support.

lupus77
Registered User
Posts: 55
Joined: Fri Nov 21, 2014 6:44 pm

Re: [3.2][RC] Official Extension: Media Embed PlugIn

Post by lupus77 » Fri Jan 20, 2017 7:29 pm

Looks like s9e/mediaembed also works with phpBB 3.2? Not sure, what the differences really are. But I guess since this is an official release, I should switch to the offical release if they are really identical?

User avatar
VSE
Extensions Development Coordinator
Extensions Development Coordinator
Posts: 4842
Joined: Sat Jan 17, 2009 9:37 am
Location: Los Angeles, CA
Name: Matt Friedman
Contact:

Re: [3.2][RC] Official Extension: Media Embed PlugIn

Post by VSE » Sat Jan 21, 2017 10:54 pm

lupus77 wrote:
Fri Jan 20, 2017 7:29 pm
Looks like s9e/mediaembed also works with phpBB 3.2? Not sure, what the differences really are. But I guess since this is an official release, I should switch to the offical release if they are really identical?
For now the main differences are the official ext lets you manage which media sites you want to allow, and if you want them appearing in signatures or not.
Dictated but not read.
Official phpBB Extensions My Extensions & MODs
Please do not PM me for support.

rutgermuller
Registered User
Posts: 5
Joined: Thu Jan 12, 2017 3:40 pm

Re: [3.2][RC] Official Extension: Media Embed PlugIn

Post by rutgermuller » Sat Feb 04, 2017 7:16 pm

Edit: sorry, fixed it. It was not clear to me it had to be uploaded in ext/phpbb, i uploaded in ext.
Last edited by rutgermuller on Sat Feb 04, 2017 7:22 pm, edited 2 times in total.

Locked

Return to “Extensions in Development”