[3.2][3.3][RC] Auto db Backup

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
ivailo95
Registered User
Posts: 854
Joined: Tue Sep 05, 2017 8:00 am
Location: Bulgaria
Name: Ivailo
Contact:

Re: [3.2][RC] Auto db Backup

Post by ivailo95 »

Where is this?

User avatar
david63
Registered User
Posts: 17774
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [3.2][RC] Auto db Backup

Post by david63 »

ivailo95 wrote:
Sun Nov 03, 2019 3:23 pm
Where is this?
Where is what?
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
ivailo95
Registered User
Posts: 854
Joined: Tue Sep 05, 2017 8:00 am
Location: Bulgaria
Name: Ivailo
Contact:

Re: [3.2][RC] Auto db Backup

Post by ivailo95 »

Logs of the extension
here is picture of the sittings
Attachments
Screenshot 2019-11-03 17.37.00.png
Screenshot 2019-11-03 17.37.14.png

User avatar
</Solidjeuh>
Registered User
Posts: 1788
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: [3.2][RC] Auto db Backup

Post by </Solidjeuh> »

Did you make a conejob on your server? You have set it to "yes"... so it needs a server cronejob.

User avatar
david63
Registered User
Posts: 17774
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [3.2][RC] Auto db Backup

Post by david63 »

</Solidjeuh> wrote:
Sun Nov 03, 2019 3:44 pm
Did you make a conejob on your server? You have set it to "yes"... so it needs a server cronejob.
Or set System cron to "No" and use phpBB cron
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
tlem
Registered User
Posts: 148
Joined: Sun Jan 24, 2016 4:47 pm
Location: Bordeaux (France)
Name: Thierry
Contact:

Re: [3.2][RC] Auto db Backup

Post by tlem »

Hi.
Here it is the french translation for the RC8.
Rename it without the .txt extention.
Attachments
autodbbackup-3.2-RC8-Lang_Fr.zip.txt
(5.04 KiB) Downloaded 8 times

Tomson
Registered User
Posts: 1
Joined: Sat Aug 24, 2019 9:29 am

Re: [3.2][RC] Auto db Backup

Post by Tomson »

Hey guys. Could use a a little help, if someone knows the solution, have the 3.2.7 version (MySQL(i) 5.6.46 and PHP 7.0.33), all working good for few months now, have just installed AutoDbBackup, all went well, have enabled it, it shows under Maintenance, but when I click on it I get white blank screen. Went and clicked Purge the cache, but still nothing, all I get is blank white screen.

This is what I get in URL when clicking on Auto backup settings

https://forum.kajkupiti.si/adm/index.ph ... &mode=main

Any ideas?

WWu777
Registered User
Posts: 760
Joined: Tue Aug 14, 2007 12:40 pm
Contact:

Re: [3.2][RC] Auto db Backup

Post by WWu777 »

Dear David63,
I tried your backup extension and it was working fine. But isn't working as expected. I set the number of stored backups to 3. However, I found 6 backups in my server under the /store folder. It seems that it is not overwriting the oldest backup and keeping the number to 3. When I click the Restore tab under Maintenance in ACP, I also see more than 3 databases to restore from, organized by date. Do you know why? Should I select Yes or No to "Maintain backup frequency?" Does that make any difference?

I also see a message at the top saying I don't have the latest version of the extension. Where do I get the latest version?

See screenshot below of my settings screen on the ACP.

Untitled.jpg

User avatar
david63
Registered User
Posts: 17774
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [3.2][RC] Auto db Backup

Post by david63 »

WWu777 wrote:
Fri Jan 03, 2020 7:53 am
I set the number of stored backups to 3. However, I found 6 backups in my server under the /store folder.
There could be a number of reasons as to why backups are not being removed.

1. If you have done a manual backup in the intervening period between auto backups then they will be in the store folder.
2. They are old backups in a different file name format.
3. Your server settings do not allow files to be deleted.
3. Your folder permissions are incorrect.
4. You have changed the number of stored backups since the last auto backup run.

As far as I can see on all of my boards that use auto backup the auto removal works as expected.
WWu777 wrote:
Fri Jan 03, 2020 7:53 am
also see a message at the top saying I don't have the latest version of the extension. Where do I get the latest version?
You can ignore that message for now - it is in preparation for phpBB 3.3
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

newmember
Registered User
Posts: 14
Joined: Fri May 24, 2019 10:58 pm

Re: [3.2][RC] Auto db Backup

Post by newmember »

updates to 3.2 autodbbackup after installing the pico one.

manual backups work

the auto backup page fails

"There is a problem with your timezone setting."

I have set the phpBB time to -7 my UPC is -7

ideas how to access the 'autoconfig' page to set the auto backups?

thanks

User avatar
david63
Registered User
Posts: 17774
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [3.2][RC] Auto db Backup

Post by david63 »

@ newmember

Can you post the exact error message that you are getting - not just part of it.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

WWu777
Registered User
Posts: 760
Joined: Tue Aug 14, 2007 12:40 pm
Contact:

Re: [3.2][RC] Auto db Backup

Post by WWu777 »

Hi David,
I just upgraded my forum to phpbb 3.2.8. In the Extensions panel, your auto db backup extension is listed as outdated. A red warning at the top of the Extensions panel says:
[+] Auto database backup is not up to date - Re-Check version
Does it matter? Will it still work ok? When will you update the extension so that the warning message no longer appears?

Thanks.

User avatar
david63
Registered User
Posts: 17774
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Contact:

Re: [3.2][RC] Auto db Backup

Post by david63 »

WWu777 wrote:
Sat Jan 04, 2020 10:02 am
Does it matter? Will it still work ok? When will you update the extension so that the warning message no longer appears?
david63 wrote:
Fri Jan 03, 2020 8:52 am
You can ignore that message for now - it is in preparation for phpBB 3.3
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

WWu777
Registered User
Posts: 760
Joined: Tue Aug 14, 2007 12:40 pm
Contact:

Re: [3.2][RC] Auto db Backup

Post by WWu777 »

david63 wrote:
Fri Jan 03, 2020 8:52 am
WWu777 wrote:
Fri Jan 03, 2020 7:53 am
I set the number of stored backups to 3. However, I found 6 backups in my server under the /store folder.
There could be a number of reasons as to why backups are not being removed.

1. If you have done a manual backup in the intervening period between auto backups then they will be in the store folder.
2. They are old backups in a different file name format.
3. Your server settings do not allow files to be deleted.
3. Your folder permissions are incorrect.
4. You have changed the number of stored backups since the last auto backup run.

As far as I can see on all of my boards that use auto backup the auto removal works as expected.
WWu777 wrote:
Fri Jan 03, 2020 7:53 am
also see a message at the top saying I don't have the latest version of the extension. Where do I get the latest version?
You can ignore that message for now - it is in preparation for phpBB 3.3
Well all those possibilities are eliminated except for #3. How do I determine if my server settings allow files to be automatically deleted? Any idea?

Also in your screen shots above, I see this part of the ACP with server settings:

Image

Do I have to follow the same settings on the server settings shown on that screen shot?

What is "Run periodic tasks from system cron"? Does that make a difference? Am I supposed to enable that? Mine is set to off.

Why did you turn off gzip compression? Isn't it better to have it on to save space and make the forum run faster?

Thanks again.

newmember
Registered User
Posts: 14
Joined: Fri May 24, 2019 10:58 pm

Re: [3.2][RC] Auto db Backup

Post by newmember »

@david63
david63 wrote:
Sat Jan 04, 2020 8:31 am
@ newmember
@david63

Can you post the exact error message that you are getting - not just part of it.
log event when landing on the page:
10.241.99.152 - - [07/Jan/2020:18:52:28 +0000] "GET /adm/index.php?sid=4ec424b93c9b52583ac407f4db159298&i=-david63-autodbbackup-acp-auto_db_backup_module&mode=main HTTP/1.1" 200 2799 "https://answers.DOMAIN.com/adm/index.ph ... 59298&i=24" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.88 Safari/537.36"


phpbbCapture.GIF

Post Reply

Return to “Extensions in Development”