[3.2][RC] Site Logo

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Post Reply
User avatar
david63
Jr. Extension Validator
Posts: 12809
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

[3.2][RC] Site Logo

Post by david63 » Sun Jan 08, 2017 10:59 am

Extension Name: Site Logo
Author: david63

Description: Replace the standard phpBB logo with own custom logo.

Extension Version: [RC] 2.1.0-rc6

Requirements: 3.2.0

Notes:
  • This is an update for phpBB 3.2 of my Site Logo extension for 3.2
Features:
  • Change the site logo with any file, either on your site or remotely
  • Format the logo
  • Position the logo - left, certre or right
  • Move the search box to the nav bar, or remove altogether
  • Add a custom banner
  • Move the site name and description below the logo
  • Override the site name and site description colour
  • Remove the site name and description totally from the display
  • The ability to have an extended site description - more than the current 255 characters)
Changes:
  • Added improved colour picker (RC2)
  • Incorporated Background forum extension by alex75 (at his request) (RC2)
  • Added option for different url attached to Site Logo (RC3)
  • Added option to change header background colour (RC4)
  • Added option for background repeat (RC6)
  • Minified site_logo.js for improved performance (RC6)
Installation:
  • Download the latest release and unzip it.
  • Upload the unzipped files to root/ext/david63/sitelogo and enable it in the ACP

GitHub Repository: https://github.com/david63/david63-sitelogo
Extension Download: https://github.com/david63/david63-site ... ve/3.2.zip
Last edited by david63 on Tue Feb 14, 2017 10:05 pm, edited 6 times in total.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

User avatar
david63
Jr. Extension Validator
Posts: 12809
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Sun Jan 08, 2017 11:02 am

This is quite a complex extension so if you have problems I will only support them if you provide me with the following information:
  • The style that you are using
  • The browser that you are using
  • Details of the relevant settings from the ACP
  • Other extensions installed
  • A link to the site showing the problem
  • If possible an image of the problem
Last edited by david63 on Wed Jan 11, 2017 11:29 am, edited 3 times in total.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

rogerio24
Registered User
Posts: 37
Joined: Sat Jul 05, 2014 1:18 am
Location: Córdoba - Argentina
Name: Roger Biderbost
Contact:

Re: [3.2][RC] Site Logo

Post by rogerio24 » Sun Jan 08, 2017 7:59 pm

Hi
could you add a screenshot or something similer where we should add the path to the photo?
I found this explanation no clear
Thanks

rogerio24
Registered User
Posts: 37
Joined: Sat Jul 05, 2014 1:18 am
Location: Córdoba - Argentina
Name: Roger Biderbost
Contact:

Re: [3.2][RC] Site Logo

Post by rogerio24 » Mon Jan 09, 2017 1:02 am

Hi
I could configure this extension. Very good extension and easy to understand.
I have a issue because in the mobile version browser there is a space between the header and menu (if you see in the picture I draw a red line to understand what I mean). Well is there a way to fix this?

Image

Thanks

User avatar
david63
Jr. Extension Validator
Posts: 12809
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Mon Jan 09, 2017 7:31 am

@ rogerio24

In order for me to know where to start can I refer you to the second post in this topic and please provide those details
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

User avatar
nl1sms
Registered User
Posts: 81
Joined: Wed May 25, 2005 4:24 pm
Location: Holland

Re: [3.2][RC] Site Logo

Post by nl1sms » Mon Jan 09, 2017 8:02 am

I use phpbb 3.2 and installed the site logo extension. All works well but when i view my board on a mobile device (smartphone) then it also shows the top logo whilst beforehand it did not. Can there be an option made into sitelogo to enable disable logo for mobile devices. Or can anyone tell me how i can delete the logo on mobile devices ?

thanx

User avatar
david63
Jr. Extension Validator
Posts: 12809
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Mon Jan 09, 2017 8:12 am

nl1sms wrote:
Mon Jan 09, 2017 8:02 am
I use phpbb 3.2 and installed the site logo extension. All works well but when i view my board on a mobile device (smartphone) then it also shows the top logo whilst beforehand it did not. Can there be an option made into sitelogo to enable disable logo for mobile devices. Or can anyone tell me how i can delete the logo on mobile devices ?

thanx
I'll take a look later
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

User avatar
Scanialady
Registered User
Posts: 141
Joined: Thu Jan 17, 2013 7:09 pm
Location: Germany
Name: Annette
Contact:

Re: [3.2][RC] Site Logo

Post by Scanialady » Mon Jan 09, 2017 1:35 pm

For me it seems to be a good idea to set a smaller logo (or no logo) for responsive view by css file automatically.
(Compare e.g. with style ID_Launch_Fresh - there is an additional smaller logo for responsive view)
Webseite, Blog, Wiki
JV-Arcade / phpBB-Arcade / dmzx-Extensions Übersetzungsteam, andere deutsche Übersetzungen - german language files

rogerio24
Registered User
Posts: 37
Joined: Sat Jul 05, 2014 1:18 am
Location: Córdoba - Argentina
Name: Roger Biderbost
Contact:

Re: [3.2][RC] Site Logo

Post by rogerio24 » Mon Jan 09, 2017 2:33 pm

david63 wrote:
Mon Jan 09, 2017 7:31 am
@ rogerio24

In order for me to know where to start can I refer you to the second post in this topic and please provide those details
Hi
I do not understand what you mean
Thanks

rogerio24
Registered User
Posts: 37
Joined: Sat Jul 05, 2014 1:18 am
Location: Córdoba - Argentina
Name: Roger Biderbost
Contact:

Re: [3.2][RC] Site Logo

Post by rogerio24 » Mon Jan 09, 2017 2:34 pm

nl1sms wrote:
Mon Jan 09, 2017 8:02 am
I use phpbb 3.2 and installed the site logo extension. All works well but when i view my board on a mobile device (smartphone) then it also shows the top logo whilst beforehand it did not. Can there be an option made into sitelogo to enable disable logo for mobile devices. Or can anyone tell me how i can delete the logo on mobile devices ?

thanx
Same problem I have

rogerio24
Registered User
Posts: 37
Joined: Sat Jul 05, 2014 1:18 am
Location: Córdoba - Argentina
Name: Roger Biderbost
Contact:

Re: [3.2][RC] Site Logo

Post by rogerio24 » Mon Jan 09, 2017 2:39 pm

The style that you are using ---->prosilver
The browser that you are using ------>Chrome mobile
Details of the relevant settings from the ACP ----->Nothing relevant
Other extensions installed ------> See details below
Adsense & Ads 1.0.7 Detalles Deshabilitar
Birthday Cake 1.0.0 Detalles Deshabilitar
Boardtalk Fixed Menu for Prosilver 0.0.2 Detalles Deshabilitar
Browser & OS in Viewtopic 1.0.1 Detalles Deshabilitar
Button roll effect 1.0.1 Detalles Deshabilitar
Database Optimize & Repair Tool 1.1.1 Detalles Deshabilitar
Display Last Post 1.1.6 Detalles Deshabilitar
Feed Hover 1.0.0 Detalles Deshabilitar
Fixed footer navbar 1.0.2 Detalles Deshabilitar
Forum name in Topic 1.0.0 Detalles Deshabilitar
Genders 1.0.1 Detalles Deshabilitar
Google Analytics 1.0.1 Detalles Deshabilitar
Google Search & Site Verification 3.2.0 Detalles Deshabilitar
IP Country Flag 1.0.0.0003 Detalles Deshabilitar
Last Post Avatar 1.0.3 Detalles Deshabilitar
Loading indicator 1.0.0 Detalles Deshabilitar
Member Profile Views 1.0.2 Detalles Deshabilitar
Member time counter 1.0.1 Detalles Deshabilitar
Mobile Device 1.0.4 Detalles Deshabilitar
National Flags 2.1.0 Detalles Deshabilitar
Newest members 1.0.1 Detalles Deshabilitar
Notify Admin on Registration 1.0.0 Detalles Deshabilitar
Online Status 1.0.4 Detalles Deshabilitar
phpBB3 SEO Sitemap 1.1.1 Detalles Deshabilitar
phpBB Media Embed PlugIn 1.0.0-a1 Detalles Deshabilitar
Poster IP in Viewtopic 1.0.0 Detalles Deshabilitar
Posting reset button 1.0.3 Detalles Deshabilitar
Post Links 1.0.0 Detalles Deshabilitar
Post Numbers 1.0.4 Detalles Deshabilitar
Precise Similar Topics 1.3.2 Detalles Deshabilitar
Profilefield Image URL 1.0.1 Detalles Deshabilitar
Quickedit 1.0.1 Detalles Deshabilitar
Screen resolution in viewtopic 1.0.0 Detalles Deshabilitar
Scroll Page 1.0.1 Detalles Deshabilitar
Site logo (3.2) 2.1.0-rc1 Detalles Deshabilitar
Social Buttons 1.0.1 Detalles Deshabilitar
tas2580 Social Media Buttons 1.0.0-RC3 Detalles Deshabilitar
TinyPic Link 1.0.0 Detalles Deshabilitar
Topic Age Day 1.0.1 Detalles Deshabilitar
Topic Preview 2.2.3 Detalles Deshabilitar
Topic Views 1.0.0 Detalles Deshabilitar
Top Poster Of The Month 1.0.4 Detalles Deshabilitar
Unique Visits Counter 1.0.2 Detalles Deshabilitar
User Online Time 1.1.1 Detalles Deshabilitar
VigLink 1.0.0 Detalles Deshabilitar
Who Visited This Topic 1.0.5 Detalles Deshabilitar

If possible an image of the problem -----> Already attached

User avatar
david63
Jr. Extension Validator
Posts: 12809
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Mon Jan 09, 2017 4:16 pm

nl1sms wrote:
Mon Jan 09, 2017 8:02 am
I use phpbb 3.2 and installed the site logo extension. All works well but when i view my board on a mobile device (smartphone) then it also shows the top logo whilst beforehand it did not. Can there be an option made into sitelogo to enable disable logo for mobile devices. Or can anyone tell me how i can delete the logo on mobile devices ?

thanx
That should now be fixed - as far as I can see it waorks in the same way as core phpBB
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

User avatar
david63
Jr. Extension Validator
Posts: 12809
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Mon Jan 09, 2017 4:21 pm

@rogerio24

I am not seeing the "gap" problem at all, but with so many extensions installed there is a possibility that one of them is conflicting
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

User avatar
nl1sms
Registered User
Posts: 81
Joined: Wed May 25, 2005 4:24 pm
Location: Holland

Re: [3.2][RC] Site Logo

Post by nl1sms » Mon Jan 09, 2017 4:45 pm

david63 wrote:
Mon Jan 09, 2017 4:16 pm
nl1sms wrote:
Mon Jan 09, 2017 8:02 am
I use phpbb 3.2 and installed the site logo extension. All works well but when i view my board on a mobile device (smartphone) then it also shows the top logo whilst beforehand it did not. Can there be an option made into sitelogo to enable disable logo for mobile devices. Or can anyone tell me how i can delete the logo on mobile devices ?

thanx
That should now be fixed - as far as I can see it waorks in the same way as core phpBB
huh? what do you mean with that should now be fixed? It still don't work on my board. Is there a new version out of sitelogo extension that fixes this ? I don't understand.

User avatar
david63
Jr. Extension Validator
Posts: 12809
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Mon Jan 09, 2017 5:30 pm

nl1sms wrote:
Mon Jan 09, 2017 4:45 pm
s there a new version out of sitelogo extension that fixes this ?
There will be
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email or as they will be ignored

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: Bing [Bot], nou nou, primehalo, RomaamoR, Tbot [Bot] and 18 guests