[3.2][RC] Site Logo

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
david63
Jr. Extension Validator
Posts: 14549
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Thu Dec 14, 2017 9:24 pm

It looks to me to be a sizing issue with the banner/logo - try making it smaller
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

JohnnyBigSpuds
Registered User
Posts: 109
Joined: Tue Apr 22, 2014 5:49 pm

Re: [3.2][RC] Site Logo

Post by JohnnyBigSpuds » Thu Dec 14, 2017 9:41 pm

david63 wrote:
Sun Jan 08, 2017 11:02 am
  • The style that you are using Hexagon
  • The browser that you are using Chrome
  • Details of the relevant settings from the ACP phpbb 3.2.1
  • Use custom banner: yes
  • Path to the custom banner: /images/BG2.png
  • Banner height: 280px
  • Banner radius: 20px
  • Other extensions installed: Board3 Portal
  • A link to the site showing the problem: https://www.walkingsurvival.com/
    • Basically, when i make the browser window smaller, my banner doesnt reduce, also it doesnt show fully on mobile
      it shows a part of the banner and incorrect size
      How do i rectify so that the banner displays correctly on both pc and mobile?
      many thanks

User avatar
david63
Jr. Extension Validator
Posts: 14549
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Thu Dec 14, 2017 9:47 pm

Can you PM me a copy of your banner please.

I am not on my test server at the moment but I will look at it tomorrow.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

JohnnyBigSpuds
Registered User
Posts: 109
Joined: Tue Apr 22, 2014 5:49 pm

Re: [3.2][RC] Site Logo

Post by JohnnyBigSpuds » Fri Dec 15, 2017 12:50 am

many thanks
i have sent pm
crashing out myself as work early in mornin

dtleahy
Registered User
Posts: 167
Joined: Sun Aug 24, 2008 5:47 pm

Re: [3.2][RC] Site Logo

Post by dtleahy » Sun Dec 31, 2017 5:19 pm

david63: nice job on this extension!

phpbb v.3.2.1
Firefox 52.5.3
ActivityButtons, ScrollPage, SiteLogo (3.2), VigLink

A minor bug :

This works:
==========================
Custom header bar colours: Yes
Header bar colour: #1f8268
Use solid colours: Yes
==========================


This does not work (the header bar color does not become a gradient using the picked color, instead, it reverts to ProSilver's default blue color):
==========================
Custom header bar colours: Yes
Header bar colour: #1f8268
Use solid colours: No
==========================



Also, for those that have a problem of the phpbb logo briefly displaying:

The phpbb logo is at phpbb3/styles/prosilver/theme/images/site_logo.gif

Overwrite it. If it doesn't exist, it can't display.

(Thinking back quite a few versions ago), if you can make a gif version of your custom logo, you can name that gif file as "site_logo.gif" and upload it, overwriting this file. Or, search for "site_logo.gif" in the php code and change it to your image's filename (and upload that file into the same directory as site_logo.gif currently is. Or, make a single pixel image file and name it "site_logo.gif" and upload it, overwriting the phpbb logo.

NastyBoy
Registered User
Posts: 74
Joined: Wed May 31, 2017 7:03 pm
Location: Germany
Name: Tim
Contact:

Re: [3.2][RC] Site Logo

Post by NastyBoy » Tue Jan 16, 2018 3:44 pm

Where do I have to upload my logo in the phpbb folder?

janus_zonstraal
Registered User
Posts: 2516
Joined: Sat Aug 30, 2014 1:30 pm

Re: [3.2][RC] Site Logo

Post by janus_zonstraal » Tue Jan 16, 2018 5:53 pm

NastyBoy wrote:
Tue Jan 16, 2018 3:44 pm
Where do I have to upload my logo in the phpbb folder?
Das't matter as long as you use the right address (url) to the image.
Sorry! My English is bat ;) !!!

fo2
Registered User
Posts: 10
Joined: Thu Jan 25, 2018 4:29 am

Re: [3.2][RC] Site Logo

Post by fo2 » Wed Jan 31, 2018 4:26 am

Patriot0311 wrote:
Sat Dec 09, 2017 6:38 pm
david63 wrote:
Fri Nov 24, 2017 4:16 pm
The we_universal style for phpBB3.2 has been abandoned and therefore should not be being used.

I do not provide support for abandoned styles - sorry.
David, I put the logo extension in the correct place in my home files, but it doesn't show up in my extensions in my phpbb ACP.
What info do you need to troubleshoot?

THANKS in advance!

Sonny
I have the same problem. I just downloaded the zip file. The structure of this file is:

david63-sitelogo-3.2/david63-sitelogo-3.2/<various folders ACP, ADM etc>

But the instructions say that I should place the files under root/ext/david63/sitelogo. So, here is a dumb question from a guy who follows directions word by word: which of these installations is correct?

root/ext/david63/sitelogo/david63-sitelogo-3.2/david63-sitelogo-3.2/<various folders ACP, ADM etc>
root/ext/david63/sitelogo/david63-sitelogo-3.2/<various folders ACP, ADM etc>
root/ext/david63/david63-sitelogo-3.2/<various folders ACP, ADM etc> - this one doesn't work
root/ext/david63/sitelogo/<various folders ACP, ADM etc> - this works

fo2
Registered User
Posts: 10
Joined: Thu Jan 25, 2018 4:29 am

Re: [3.2][RC] Site Logo

Post by fo2 » Wed Jan 31, 2018 5:00 am

Thank you! It works nicely!

User avatar
5speed
Registered User
Posts: 24
Joined: Thu Jan 18, 2018 10:00 pm

Re: [3.2][RC] Site Logo

Post by 5speed » Thu Feb 01, 2018 7:34 pm

fo2 wrote:
Wed Jan 31, 2018 4:26 am

I have the same problem. I just downloaded the zip file. The structure of this file is:

david63-sitelogo-3.2/david63-sitelogo-3.2/<various folders ACP, ADM etc>

But the instructions say that I should place the files under root/ext/david63/sitelogo. So, here is a dumb question from a guy who follows directions word by word: which of these installations is correct?

root/ext/david63/sitelogo/david63-sitelogo-3.2/david63-sitelogo-3.2/<various folders ACP, ADM etc>
root/ext/david63/sitelogo/david63-sitelogo-3.2/<various folders ACP, ADM etc>
root/ext/david63/david63-sitelogo-3.2/<various folders ACP, ADM etc> - this one doesn't work
root/ext/david63/sitelogo/<various folders ACP, ADM etc> - this works
my directory is root/ public-html /ext/david63-sitelogo-3.2/ various folders - it isn't showing up in my ACP.

User avatar
david63
Jr. Extension Validator
Posts: 14549
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Thu Feb 01, 2018 7:38 pm

5speed wrote:
Thu Feb 01, 2018 7:34 pm
my directory is root/ public-html /ext/david63-sitelogo-3.2/ various folders - it isn't showing up in my ACP.
Your directory structure should beoot/public-html/ext/david63/sitelogo/various folders
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
5speed
Registered User
Posts: 24
Joined: Thu Jan 18, 2018 10:00 pm

Re: [3.2][RC] Site Logo

Post by 5speed » Thu Feb 01, 2018 7:45 pm

david63 wrote:
Thu Feb 01, 2018 7:38 pm
5speed wrote:
Thu Feb 01, 2018 7:34 pm
my directory is root/ public-html /ext/david63-sitelogo-3.2/ various folders - it isn't showing up in my ACP.
Your directory structure should beoot/public-html/ext/david63/sitelogo/various folders
well Houston..we have a problem. lol
I d/loaded your zipped file, unzipped it and have david63-sitelogo-3.2 /david63-sitelogo-3.2 / various folders

User avatar
david63
Jr. Extension Validator
Posts: 14549
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Site Logo

Post by david63 » Thu Feb 01, 2018 7:51 pm

5speed wrote:
Thu Feb 01, 2018 7:45 pm
well Houston..we have a problem.
No we don't - this is an unfortunate side effect of GitHub.

You need to rename the folders to get the correct structure
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
5speed
Registered User
Posts: 24
Joined: Thu Jan 18, 2018 10:00 pm

Re: [3.2][RC] Site Logo

Post by 5speed » Thu Feb 01, 2018 7:56 pm

david63 wrote:
Thu Feb 01, 2018 7:51 pm
No we don't - this is an unfortunate side effect of GitHub.

You need to rename the folders to get the correct structure
That did it sir. Thank you very much.

User avatar
nl1sms
Registered User
Posts: 111
Joined: Wed May 25, 2005 4:24 pm
Location: Holland

Re: [3.2][RC] Site Logo

Post by nl1sms » Fri Mar 02, 2018 10:41 am

When will there be a final release of this great extension ?

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: PWG-Extension, Thunder_one, v12mike and 21 guests