Page 3 of 7

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Fri Oct 13, 2017 2:48 am
by profKroy
Hey 3Di,

I think I may have found a minor bug, that I'm guessing has emerged with my upgrade to 3.2. Check it out. What happens is the quoted images that are "placed inline" in the original post, when quoted, now seem to be placed at the end of the post, instead of where they were initially placed. However the name of the image file remains in the original position in the quoted post.

I've checked it in prosilver and the style that I use as well, and the issue is the same. Can you replicate it?

Here's a screen shot w/ annotations...

UPDATE/EDIT: Sorry, I'm just now realizing that the formatting that I pointed out was always like this. BUT, the issue that I see that is different is that the image names used to be link, so a user could open only the image in the browser window. That seems not to be the case any longer.

Image

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Fri Oct 13, 2017 10:21 pm
by 3Di
Greets,
I will study this post of yours and see what's the difference between 3.1/3.2 and what not, poorly speaking though: what would it be the desired behaviour. I feel confused a bit here :)

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Fri Oct 13, 2017 10:31 pm
by profKroy
3Di wrote:
Fri Oct 13, 2017 10:21 pm
Greets,
I will study this post of yours and see what's the difference between 3.1/3.2 and what not, poorly speaking though: what would it be the desired behaviour. I feel confused a bit here :)
Thanks 3Di. Check my update above. I realized that the extension has always been functioning the same.

What would be desirable would be when an image is "placed inline" in the post, after it has been attached, if the image in the quoted post would stay in the same position as the original post. I think currently the quoted image is being moved to beneath the text, however the name of the image is staying in place. It has to do with whether or not an image that has been "placed inline" remains in position in the quote.

On a side note, but somewhat related, it seems that the name of the image is no longer a link after it's been quoted. Whereas before a link was created in the quote.

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Fri Oct 13, 2017 10:36 pm
by 3Di
I see, ok. I will get a look at this as soon as I can and keep you all informed.
There is also another bit I have to check as well. ;)

Thanks for feedback. :) Important!

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Thu Jan 18, 2018 10:19 pm
by KMDTHY
Great extention! But it looks a bit funky in Tapatalk App.
Image

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Thu Jan 18, 2018 11:04 pm
by 3Di
Thank you. :)

And no, no support is given for Tapatalk, in any form.
Read here: viewtopic.php?p=14914721#p14914721

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Wed Feb 28, 2018 7:02 pm
by hd321kbps
Does not work and conflicts with the QuickReply Reloaded extension for phpBB 3.2

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Wed Feb 28, 2018 7:20 pm
by 3Di
hd321kbps wrote:
Wed Feb 28, 2018 7:02 pm
Does not work and conflicts with the QuickReply Reloaded extension for phpBB 3.2
Isn't planned in fact, I don't think it will be in a foreseable future.
Anyway, you are more than welcome to open an issue at the tracker (github), thank you!

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Fri Mar 30, 2018 4:24 am
by 3Di
profKroy wrote:
Fri Oct 13, 2017 10:31 pm
What would be desirable would be when an image is "placed inline" in the post, after it has been attached, if the image in the quoted post would stay in the same position as the original post. I think currently the quoted image is being moved to beneath the text, however the name of the image is staying in place. It has to do with whether or not an image that has been "placed inline" remains in position in the quote.
I am getting your point and I know where to put my hands on I think.
Indeed inline images have to be displayed the same way the post has been made.
Instead attached images are placed in the post at the end, on newlines, AFAIR.
profKroy wrote:
Fri Oct 13, 2017 10:31 pm
On a side note, but somewhat related, it seems that the name of the image is no longer a link after it's been quoted. Whereas before a link was created in the quote.
That's due to my code, a design's decision which I have to recall the reason why, though... Maybe below?
BUT, the issue that I see that is different is that the image names used to be link, so a user could open only the image in the browser window. That seems not to be the case any longer.
Arent' the the thumbs originated (quoted) from images posted with attachments (any) clickable?

Scheduled: review of some bits of this code. Drop support for 3.1's serie.

Awaiting feedback. Thank you. :)

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Sun May 06, 2018 5:51 pm
by Lor@n
Installed on phphh3. 2

Work fine.

Thanks

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Mon May 07, 2018 1:31 am
by 3Di
Thanks for your contribution! :)

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Tue Sep 11, 2018 9:51 am
by maik63de
Hello,

I have the extension running in a 3.2.2 board and it works.
Thank you

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Tue Sep 11, 2018 8:46 pm
by 3Di
Thx for feedback! :)

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Wed Sep 12, 2018 1:08 pm
by lopoto
THX 3Di , ext working well :D

Re: [3.1][3.2][BETA] QAIP - Quote Attachments Img in Posts

Posted: Wed Sep 12, 2018 2:13 pm
by 3Di
Great! Thanks again for feedback. :)