Page 10 of 26

Re: [3.1][3.2][BETA] Feed post bot

Posted: Mon Jun 12, 2017 2:28 pm
by RomaamoR
It's easier for me to give you access to the forum than to explain

Re: [3.1][3.2][BETA] Feed post bot

Posted: Mon Jun 12, 2017 7:28 pm
by Ger
I don't understand a word Russian, so that won't work. Also, I don't intend to give private support and a BETA extension not intended for use on live forums.

So, if a feed isn't working for you, please provide the requested information. If you don't, I cannot help you.

Re: [3.1][3.2][BETA] Feed post bot

Posted: Mon Jun 26, 2017 7:54 am
by Mauron
RomaamoR wrote:
Mon Jun 12, 2017 8:26 am
Ger wrote:
Mon Jun 12, 2017 7:08 am
The first one works fine for me, but I cannot open the latter
Column 'topic_desc' cannot be null [1048]
The error is caused by Topic Descriptions, though I recall that latest version fixed it.

Re: [3.1][3.2][BETA] Feed post bot

Posted: Tue Jun 27, 2017 6:29 am
by Ger
Well, case closed than. Thank you!

Re: [3.1][3.2][RC] Feed post bot

Posted: Mon Jul 03, 2017 12:54 pm
by Ger
Since I haven't heard of any issues lately, I've submitted the extension to the CDB. I've added a small feature: the ability to configure the cron_frequency. Previously it was hard coded as 1800 seconds (half an hour), it's now a setting in the ACP module.

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Jul 13, 2017 9:32 am
by Ger
I got a request to make it possible to remove the source link for posted items. Therefore I added the option "append link" for each feed, default enabled.

It's only available through Github ATM: https://github.com/GerB/feedpostbot
In a later stage (when it's feed tested) I'll submit it as a revision to the CDB.

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Jul 13, 2017 3:02 pm
by </Solidjeuh>
I get this in the logs:

Code: Select all

Error in [ROOT]/ext/jv/shoutbox/event/listener.php on rule 170: Undefined index: JV_SHOUTBOX_F_NEW_TOPIC

Error in [ROOT]/includes/message_parser.php on rule 1198: Undefined index: TOO_FEW_CHARS

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Jul 13, 2017 3:05 pm
by Ger
Froddelaar wrote:
Thu Jul 13, 2017 3:02 pm
I get this in the logs:

Code: Select all

Error in [ROOT]/ext/jv/shoutbox/event/listener.php on rule 170: Undefined index: JV_SHOUTBOX_F_NEW_TOPIC

Error in [ROOT]/includes/message_parser.php on rule 1198: Undefined index: TOO_FEW_CHARS
I think you have the wrong topic here. It says there is an error with the shoutbox extension. That has nothing to do with the feed post bot. :)

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Jul 13, 2017 3:09 pm
by </Solidjeuh>
Ger wrote:
Thu Jul 13, 2017 3:05 pm
Froddelaar wrote:
Thu Jul 13, 2017 3:02 pm
I get this in the logs:

Code: Select all

Error in [ROOT]/ext/jv/shoutbox/event/listener.php on rule 170: Undefined index: JV_SHOUTBOX_F_NEW_TOPIC

Error in [ROOT]/includes/message_parser.php on rule 1198: Undefined index: TOO_FEW_CHARS
I think you have the wrong topic here. It says there is an error with the shoutbox extension. That has nothing to do with the feed post bot. :)
Yes it does, the shoutbox announces new topics.
And when I enable your extension it show just empty announcements

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Jul 13, 2017 3:24 pm
by </Solidjeuh>
Nevermind, I disabled & enabled the extension, and now it works :cry: :lol:

Re: [3.1][3.2][RC] Feed post bot

Posted: Fri Jul 14, 2017 6:36 am
by Ger
Great :)

Re: [3.1][3.2][RC] Feed post bot

Posted: Tue Jul 25, 2017 2:09 pm
by TalhaMoazSarwar
Hello,

Your extension is incredibly good. Please make it compatible with this rss feed format

https://www.siasat.pk/forum/external.ph ... orumids=29

Thanks for making this extension..

Re: [3.1][3.2][RC] Feed post bot

Posted: Wed Jul 26, 2017 6:43 am
by Ger
It works for me. The only thing is that most items are just an iframe with a video. Those get stripped since phpBB doesn't allow iframes.

Re: [3.1][3.2][RC] Feed post bot

Posted: Tue Aug 22, 2017 12:30 pm
by Ger
The extension didn't get validated because of potential PHP notices and inability to fetch feeds when allow_url_fopen is disabled on the server.

I've updated the extension (download from github). I appreciate any feedback.

Re: [3.1][3.2][RC] Feed post bot

Posted: Tue Aug 22, 2017 3:53 pm
by Raul [ThE KuKa]
Ger wrote:
Tue Aug 22, 2017 12:30 pm
The extension didn't get validated because of potential PHP notices and inability to fetch feeds when allow_url_fopen is disabled on the server.

I've updated the extension (download from github). I appreciate any feedback.
Thanks Ger.

I reported the team, so that you know exactly the problems seen in the validation process.