Page 14 of 26

Re: [3.1][3.2][RC] Feed post bot

Posted: Tue Sep 19, 2017 8:14 pm
by sysz
It works like a charm now :)

Re: [3.1][3.2][RC] Feed post bot

Posted: Wed Sep 20, 2017 6:39 am
by Ger
Great :)

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Sep 21, 2017 3:13 am
by sysz
Or so i tough :P

Now it dosen't fetch the feeds automatically and instead needs to be manually updated.

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Sep 21, 2017 1:34 pm
by Ger
Keep in mind that it uses the default phpBB cron. Default, phpBB will arrange for periodic tasks to be run automatically when users visit the board. When you have a board with few visitors (not counting bots) this may not be so regular as you expect.

You can instead choose to go to the ACP -> Server settings -> Run periodic tasks from system cron.
When on, phpBB will not schedule any periodic tasks by itself; a system administrator must arrange for bin/phpbbcli.php cron:run to be run by the system cron facility at regular intervals (e.g. every 5 minutes). This means the cron service will check each 5 minutes if there is a pending task to be executed, including (but not only) the feed fetching.

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Sep 21, 2017 4:50 pm
by dynserver
Tried this on my board. It seems to not update the feed according to the time set. I have to do it manually in order for it to fetch the data. :oops:


Am I doing something wrong? I even set the fetch to 5 minutes and waited to see what would happen in 5 minutes while pulling feeds from google news. Nothing happened unless I pressed the manual fetch. Then they'd flood in.

Re: [3.1][3.2][RC] Feed post bot

Posted: Thu Sep 21, 2017 8:21 pm
by Ger
Have you read and understood my previous post?

Re: [3.1][3.2][RC] Feed post bot

Posted: Fri Sep 22, 2017 7:37 pm
by rohde
Hii,

i have problem

[phpBB Debug] PHP Warning: in file [ROOT]/ext/ger/feedpostbot/classes/driver.php on line 259: simplexml_load_string(): Entity: line 2: parser error : XML declaration allowed only at the start of the document
[phpBB Debug] PHP Warning: in file [ROOT]/ext/ger/feedpostbot/classes/driver.php on line 259: simplexml_load_string(): <?xml version="1.0" encoding="UTF-8"?><rss version="2.0"
[phpBB Debug] PHP Warning: in file [ROOT]/ext/ger/feedpostbot/classes/driver.php on line 259: simplexml_load_string(): ^

Warning: Cannot modify header information - headers already sent by (output started at /home/ricardor/public_html/clubedovectra/forum/includes/functions.php:3932) in /home/ricardor/public_html/clubedovectrar/forum/includes/functions_acp.php on line 134

Warning: Cannot modify header information - headers already sent by (output started at /home/ricardor/public_html/clubedovectra/forum/includes/functions.php:3932) in /home/ricardor/public_html/clubedovectra/forum/includes/functions_acp.php on line 134

Warning: Cannot modify header information - headers already sent by (output started at /home/ricardor/public_html/clubedovectra/forum/includes/functions.php:3932) in /home/ricardor/public_html/clubedovectra/forum/includes/functions_acp.php on line 134
url feed
http://revistaautoesporte.globo.com/Rev ... 142,00.xml
https://quatrorodas.abril.com.br/rss/
http://brasilcaminhoneiro.com.br/feed/
https://www.flatout.com.br/feed/

Re: [3.1][3.2][RC] Feed post bot

Posted: Sat Sep 23, 2017 5:11 pm
by Ger
Hello, seems like a malformed XML error on your feed. I can't check much from my phone though, I am on a holiday.

Re: [3.1][3.2][RC] Feed post bot

Posted: Sat Sep 23, 2017 11:54 pm
by olesore
Unfortunately, I could not run the plug-in.
I created a folder called "ger" in the ext folder and uploaded it to the winrar. Then I did not see it in the Customize section of the forum admin panel.

Re: [3.1][3.2][RC] Feed post bot

Posted: Sun Sep 24, 2017 12:35 pm
by Ger
You uploaded it to WinRAR? I have no idea what that's supposed to mean.

Re: [3.1][3.2][RC] Feed post bot

Posted: Sun Sep 24, 2017 8:27 pm
by olesore
Ger wrote:
Sun Sep 24, 2017 12:35 pm
You uploaded it to WinRAR? I have no idea what that's supposed to mean.
Winrar: The name of the program I use to open the downloaded file.
Please do not hang around. I still can not plug in. My phpBB version 3.2.1

Re: [3.1][3.2][RC] Feed post bot

Posted: Tue Sep 26, 2017 6:01 pm
by Ger
I'm still not sure what you mean. Please follow this instructions: https://www.phpbb.com/extensions/installing/

The files should come in yourboard.com/ext/ger/feedpostbot

Re: [3.1][3.2][RC] Feed post bot

Posted: Sat Sep 30, 2017 9:17 pm
by sysz
Got this error when i tried to manually fetch the feeds again.

Code: Select all

SQL ERROR [ mysqli ]

Incorrect string value: '\xF0\x9F\x98\x82 y...' for column 'topic_title' at row 1 [1366]

Re: [3.1][3.2][RC] Feed post bot

Posted: Sat Sep 30, 2017 11:11 pm
by 3Di
sysz wrote:
Sat Sep 30, 2017 9:17 pm
Got this error when i tried to manually fetch the feeds again.

Code: Select all

SQL ERROR [ mysqli ]

Incorrect string value: '\xF0\x9F\x98\x82 y...' for column 'topic_title' at row 1 [1366]
That seems to be an Emoji in the topic title, are you using 3.1 or 3.2?

Re: [3.1][3.2][RC] Feed post bot

Posted: Sun Oct 01, 2017 5:41 am
by sysz
The board is using the latest version, 3.2.1
http://privatebb.se/

The board have at the moment (Total posts 6243 • Total topics 6239), 98% made by the ext, so it might be a pain in the ass to find that or those topics that have a emoji in the topic title :D