[3.2][RC] Thanks for posts (and optional Tapatalk integration)

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
Naguissa
Registered User
Posts: 239
Joined: Thu Mar 02, 2017 6:55 am
Location: Barcelona
Name: Naguissa
Contact:

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Naguissa » Wed May 23, 2018 8:05 pm

larkyv wrote:
Wed May 23, 2018 6:20 pm
It worked perfectly! And I'm more than happy to share the edited files. Now if I could only figure out where to change the text color of the "These users liked the author for the post:" line, that would be great. I'm SO out in left field with phpbb 3.2.2 - the last version I used was 2.015.... which was way simple to tweak compared to this version.

I didn't tweak the email file, as we don't need that functionality.

Hmm. I don't see anywhere to attach a .zip of the files.
Send me it to mi in a PM, I'll hostit in my server and add a note inthe repo (and here, of course!)

User avatar
larkyv
Registered User
Posts: 57
Joined: Wed Feb 21, 2018 3:45 pm

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by larkyv » Wed May 23, 2018 10:16 pm

Okay, Naguissa, thank you. I'll send it on momentarily.

User avatar
Naguissa
Registered User
Posts: 239
Joined: Thu Mar 02, 2017 6:55 am
Location: Barcelona
Name: Naguissa
Contact:

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Naguissa » Thu May 24, 2018 7:49 am

larkyv wrote:
Wed May 23, 2018 10:16 pm
Okay, Naguissa, thank you. I'll send it on momentarily.

Thanks!


I've receive it, revised (there was one "thanks" left in one file) and uploaded here:

https://www.foroelectro.net/thanks-for- ... -t217.html

About the notification email, desn't need any change: it uses terms from language files and there's no "thanks" text there.

User avatar
larkyv
Registered User
Posts: 57
Joined: Wed Feb 21, 2018 3:45 pm

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by larkyv » Thu May 24, 2018 12:51 pm

Oops! I thought I'd re-searched all three files for anything I missed, obviously still missed one!

mouthpiece
Registered User
Posts: 6
Joined: Fri Mar 09, 2018 9:06 am

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by mouthpiece » Fri May 25, 2018 5:27 pm

Trying to uninstall this extension.... and when I delete data I get the error below. Please how do I fix.

Code: Select all

SQL ERROR [ mysqli ]

Table 'xth_20388715_906.phpbbud_thanks' doesn't exist [1146]

SQL

SHOW KEYS FROM phpbbud_thanks

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 936
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 579
CALL: phpbb\db\tools\tools->sql_index_exists()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools\tools->perform_schema_changes()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 711
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 658
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 586
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 514
CALL: phpbb\db\migrator->try_revert()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 488
CALL: phpbb\db\migrator->revert_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 108
CALL: phpbb\db\migrator->revert()

FILE: [ROOT]/ext/gfksx/thanksforposts/ext.php
LINE: 112
CALL: phpbb\extension\base->purge_step()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 359
CALL: gfksx\thanksforposts\ext->purge_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 304
CALL: phpbb\extension\manager->purge_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()

User avatar
Naguissa
Registered User
Posts: 239
Joined: Thu Mar 02, 2017 6:55 am
Location: Barcelona
Name: Naguissa
Contact:

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Naguissa » Fri May 25, 2018 5:36 pm

mouthpiece wrote:
Fri May 25, 2018 5:27 pm
Trying to uninstall this extension.... and when I delete data I get the error below. Please how do I fix.

Code: Select all

SQL ERROR [ mysqli ]

Table 'xth_20388715_906.phpbbud_thanks' doesn't exist [1146]

SQL

SHOW KEYS FROM phpbbud_thanks

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/phpbb/db/driver/driver.php
LINE: 999
CALL: trigger_error()

FILE: [ROOT]/phpbb/db/driver/mysqli.php
LINE: 193
CALL: phpbb\db\driver\driver->sql_error()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 936
CALL: phpbb\db\driver\mysqli->sql_query()

FILE: [ROOT]/phpbb/db/tools/tools.php
LINE: 579
CALL: phpbb\db\tools\tools->sql_index_exists()

FILE: (not given by php)
LINE: (not given by php)
CALL: phpbb\db\tools\tools->perform_schema_changes()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 711
CALL: call_user_func_array()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 658
CALL: phpbb\db\migrator->run_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 586
CALL: phpbb\db\migrator->process_data_step()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 514
CALL: phpbb\db\migrator->try_revert()

FILE: [ROOT]/phpbb/db/migrator.php
LINE: 488
CALL: phpbb\db\migrator->revert_do()

FILE: [ROOT]/phpbb/extension/base.php
LINE: 108
CALL: phpbb\db\migrator->revert()

FILE: [ROOT]/ext/gfksx/thanksforposts/ext.php
LINE: 112
CALL: phpbb\extension\base->purge_step()

FILE: [ROOT]/phpbb/extension/manager.php
LINE: 359
CALL: gfksx\thanksforposts\ext->purge_step()

FILE: [ROOT]/includes/acp/acp_extensions.php
LINE: 304
CALL: phpbb\extension\manager->purge_step()

FILE: [ROOT]/includes/functions_module.php
LINE: 676
CALL: acp_extensions->main()

FILE: [ROOT]/adm/index.php
LINE: 82
CALL: p_master->load_active()
That happened on some old versions when not using memcache...

Try upgrading to latest version and then uninstalling.

parthunter_harrison
Registered User
Posts: 7
Joined: Fri May 25, 2018 11:37 pm

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by parthunter_harrison » Sat May 26, 2018 4:12 am

Can other users see how many "Thanks" the poster has accumulated?

User avatar
Naguissa
Registered User
Posts: 239
Joined: Thu Mar 02, 2017 6:55 am
Location: Barcelona
Name: Naguissa
Contact:

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Naguissa » Sat May 26, 2018 6:38 am

parthunter_harrison wrote:
Sat May 26, 2018 4:12 am
Can other users see how many "Thanks" the poster has accumulated?
In 1st post you can see some pictures and a demo link.

There're several ways that are controlled in ACP.

scheccia
Registered User
Posts: 35
Joined: Fri Feb 10, 2017 8:16 am

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by scheccia » Wed May 30, 2018 10:01 am

I have this error: "tried to redirect to potentially insecure url", when click on thanks button. It often happens but not always, never with old plugin.

User avatar
Naguissa
Registered User
Posts: 239
Joined: Thu Mar 02, 2017 6:55 am
Location: Barcelona
Name: Naguissa
Contact:

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Naguissa » Wed May 30, 2018 10:06 am

scheccia wrote:
Wed May 30, 2018 10:01 am
I have this error: "tried to redirect to potentially insecure url", when click on thanks button. It often happens but not always, never with old plugin.
This seems to be the forum URL configuration, but to be able to check, is there any way to test it?

I'm using this on a https forum and never had a problem, even using nginx (no htaccess file support). Maybe there's any kind of conflict on htaccess, as well....

Lor@n
Registered User
Posts: 30
Joined: Fri Nov 11, 2016 1:25 am

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Lor@n » Wed May 30, 2018 10:56 am

Hi!

In Toplist, i Have this error at the top of de page :

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/pagination.php on line 144: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/pagination.php on line 306: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/pagination.php on line 306: A non-numeric value encountered
PHPbb3.2.2
PHP7.1
MySql 5.6

Thanks

User avatar
Naguissa
Registered User
Posts: 239
Joined: Thu Mar 02, 2017 6:55 am
Location: Barcelona
Name: Naguissa
Contact:

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Naguissa » Wed May 30, 2018 11:19 am

Lor@n wrote:
Wed May 30, 2018 10:56 am
Hi!

In Toplist, i Have this error at the top of de page :

Code: Select all

[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/pagination.php on line 144: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/pagination.php on line 306: A non-numeric value encountered
[phpBB Debug] PHP Warning: in file [ROOT]/phpbb/pagination.php on line 306: A non-numeric value encountered
PHPbb3.2.2
PHP7.1
MySql 5.6

Thanks

I'll check it, thanks for the report.

scheccia
Registered User
Posts: 35
Joined: Fri Feb 10, 2017 8:16 am

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by scheccia » Wed May 30, 2018 3:53 pm

Naguissa wrote:
Wed May 30, 2018 10:06 am
scheccia wrote:
Wed May 30, 2018 10:01 am
I have this error: "tried to redirect to potentially insecure url", when click on thanks button. It often happens but not always, never with old plugin.
This seems to be the forum URL configuration, but to be able to check, is there any way to test it?

I'm using this on a https forum and never had a problem, even using nginx (no htaccess file support). Maybe there's any kind of conflict on htaccess, as well....
until 2 day ago i used the original plugin 2.0.3-dev, and never i had this error, only after update with this.

User avatar
Naguissa
Registered User
Posts: 239
Joined: Thu Mar 02, 2017 6:55 am
Location: Barcelona
Name: Naguissa
Contact:

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by Naguissa » Wed May 30, 2018 7:48 pm

scheccia wrote:
Wed May 30, 2018 3:53 pm
Naguissa wrote:
Wed May 30, 2018 10:06 am
scheccia wrote:
Wed May 30, 2018 10:01 am
I have this error: "tried to redirect to potentially insecure url", when click on thanks button. It often happens but not always, never with old plugin.
This seems to be the forum URL configuration, but to be able to check, is there any way to test it?

I'm using this on a https forum and never had a problem, even using nginx (no htaccess file support). Maybe there's any kind of conflict on htaccess, as well....
until 2 day ago i used the original plugin 2.0.3-dev, and never i had this error, only after update with this.
Is there any public site where I can see it happening and see the problem in action? I cannot reproduce it.

scheccia
Registered User
Posts: 35
Joined: Fri Feb 10, 2017 8:16 am

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Post by scheccia » Thu May 31, 2018 6:40 am

Naguissa wrote:
Wed May 30, 2018 7:48 pm
scheccia wrote:
Wed May 30, 2018 3:53 pm
Naguissa wrote:
Wed May 30, 2018 10:06 am
scheccia wrote:
Wed May 30, 2018 10:01 am
I have this error: "tried to redirect to potentially insecure url", when click on thanks button. It often happens but not always, never with old plugin.
This seems to be the forum URL configuration, but to be able to check, is there any way to test it?

I'm using this on a https forum and never had a problem, even using nginx (no htaccess file support). Maybe there's any kind of conflict on htaccess, as well....
until 2 day ago i used the original plugin 2.0.3-dev, and never i had this error, only after update with this.
Is there any public site where I can see it happening and see the problem in action? I cannot reproduce it.
https://www.acquariofiliafacile.it/view ... 64#p705764
It's random. I try to edit some files... But i'm not sure if solved it.

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: Gubkin, oBot and 20 guests