Page 25 of 36

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Thu May 31, 2018 6:57 am
by Naguissa
scheccia wrote:
Thu May 31, 2018 6:40 am
Naguissa wrote:
Wed May 30, 2018 7:48 pm
scheccia wrote:
Wed May 30, 2018 3:53 pm
Naguissa wrote:
Wed May 30, 2018 10:06 am
scheccia wrote:
Wed May 30, 2018 10:01 am
I have this error: "tried to redirect to potentially insecure url", when click on thanks button. It often happens but not always, never with old plugin.
This seems to be the forum URL configuration, but to be able to check, is there any way to test it?

I'm using this on a https forum and never had a problem, even using nginx (no htaccess file support). Maybe there's any kind of conflict on htaccess, as well....
until 2 day ago i used the original plugin 2.0.3-dev, and never i had this error, only after update with this.
Is there any public site where I can see it happening and see the problem in action? I cannot reproduce it.
https://www.acquariofiliafacile.it/view ... 64#p705764
It's random. I try to edit some files... But i'm not sure if solved it.
I've registered at your forum and checked thanks functionality.

As I see, all thanks links are relative (no protocol and host parts) so it should never cause a https/http problem or a www prefix missing problem.

Being so, the only that comes to my mind is any kind of htaccess problem.


Image

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Thu May 31, 2018 7:24 am
by scheccia
Naguissa wrote:
Thu May 31, 2018 6:57 am
scheccia wrote:
Thu May 31, 2018 6:40 am
Naguissa wrote:
Wed May 30, 2018 7:48 pm
scheccia wrote:
Wed May 30, 2018 3:53 pm
Naguissa wrote:
Wed May 30, 2018 10:06 am


This seems to be the forum URL configuration, but to be able to check, is there any way to test it?

I'm using this on a https forum and never had a problem, even using nginx (no htaccess file support). Maybe there's any kind of conflict on htaccess, as well....
until 2 day ago i used the original plugin 2.0.3-dev, and never i had this error, only after update with this.
Is there any public site where I can see it happening and see the problem in action? I cannot reproduce it.
https://www.acquariofiliafacile.it/view ... 64#p705764
It's random. I try to edit some files... But i'm not sure if solved it.
I've registered at your forum and checked thanks functionality.

As I see, all thanks links are relative (no protocol and host parts) so it should never cause a https/http problem or a www prefix missing problem.

Being so, the only that comes to my mind is any kind of htaccess problem.


Image
It's the last mod that i made. I copy it from old plugins. I'm testing it.

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Thu Jun 07, 2018 2:18 pm
by TearAByte
This looks like a great extension and I would like to test it out.. I've come to the this discussion a bit late, so where do i find the most current version?

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Thu Jun 07, 2018 2:22 pm
by Naguissa
TearAByte wrote:
Thu Jun 07, 2018 2:18 pm
This looks like a great extension and I would like to test it out.. I've come to the this discussion a bit late, so where do i find the most current version?
Look at 1st post....


Welcome!

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Thu Jun 07, 2018 10:16 pm
by TearAByte
Got it, thanks!
Installed it a little while ago - it's looking and working great..
thank you!

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Fri Jun 08, 2018 10:50 am
by PB190
Insctrution for recolor number of received thanks.

Image


Go to - /ext/gfksx/ThanksForPosts/styles/prosilver/template/event/viewtopic_body_postrow_custom_fields_after.html

Change

Code: Select all

<dd class="profile-posts" data-user-receive-id="{{ postrow.POSTER_ID }}">
    <strong>{{ lang('RECEIVED') }}{{ lang('COLON') }}</strong>
    <a href="{postrow.POSTER_RECEIVE_COUNT_LINK}">{% if postrow.POSTER_RECEIVE_COUNT %}{postrow.POSTER_RECEIVE_COUNT}{% else %}0{% endif %}</a>
</dd>
{% endif %}
to

Code: Select all

<dd class="profile-posts receivedrecolor" data-user-receive-id="{{ postrow.POSTER_ID }}">
    <strong>{{ lang('RECEIVED') }}{{ lang('COLON') }}</strong>
    <a href="{postrow.POSTER_RECEIVE_COUNT_LINK}">{% if postrow.POSTER_RECEIVE_COUNT %}{postrow.POSTER_RECEIVE_COUNT}{% else %}0{% endif %}</a>
</dd>
{% endif %}
And this add in /ext/gfksx/ThanksForPosts/styles/prosilver/theme/thanks.css

or in stylesheet.css

Code: Select all

/* received number - recolor */
.postprofile .profile-posts.receivedrecolor a {
color: #00AA00;
}
if you want + hover

just add

Code: Select all

.postprofile .profile-posts.receivedrecolor a:hover {
color: #02e002;
}

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Sat Jun 09, 2018 9:19 am
by PB190

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Sat Jun 09, 2018 3:44 pm
by Naguissa
Thanks to both, I was out today and couldn't reply before.

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Sun Jun 17, 2018 6:49 am
by gossipgarden
Hi, I'm having some trouble getting this extension to work and I was wondering if anyone could help me out.

I've added it to my extensions and enabled it
Image

However, it just isn't showing up at all.
Image

Here are the settings we have for it
Image
Image

Also if i look into the user permissions, this is the only thank you option they have
Image

Have i missed something? It should be showing up right?

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Sun Jun 17, 2018 9:09 am
by Naguissa
**EDITED**

That's quite strange. It seems as it has not been installed at all. Have you checked if the thanks button appears on posts (not on your own posts, of course)? You could try cleaning cache.

If this doesn't work, could you put a link to your board to check? Thanks.

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Sun Jun 17, 2018 12:15 pm
by gossipgarden
Naguissa wrote:
Sun Jun 17, 2018 9:09 am
**EDITED**

That's quite strange. It seems as it has not been installed at all. Have you checked if the thanks button appears on posts (not on your own posts, of course)? You could try cleaning cache.

If this doesn't work, could you put a link to your board to check? Thanks.
Tried clearing the cache but nothing changed.

Here's a link to our forum: http://thegossipgarden.com/

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Sun Jun 17, 2018 1:55 pm
by Naguissa
I've checked the forum and extension files are installed, but I cannot see any sign of it working.

It's really strange, as it appears to be not active at all.

I also checked phpBB is phpBB 3.2.X.

Are you sure extension is active on thi environment? Maybe you have multiple environments (dev, etc) and it's not active on this one.

I've never faced something like this, so other solution may be trying downloading and installing extension again.

I'm sorry, no clue of what could e happening there....

gossipgarden wrote:
Sun Jun 17, 2018 12:15 pm
Naguissa wrote:
Sun Jun 17, 2018 9:09 am
**EDITED**

That's quite strange. It seems as it has not been installed at all. Have you checked if the thanks button appears on posts (not on your own posts, of course)? You could try cleaning cache.

If this doesn't work, could you put a link to your board to check? Thanks.
Tried clearing the cache but nothing changed.

Here's a link to our forum: http://thegossipgarden.com/

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Sun Jun 17, 2018 10:19 pm
by GanstaZ
You can't see buttons or whatever there may be if you don't have custom theme you are using in extension style folder.

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Mon Jun 18, 2018 1:49 am
by gossipgarden
GanstaZ wrote:
Sun Jun 17, 2018 10:19 pm
You can't see buttons or whatever there may be if you don't have custom theme you are using in extension style folder.
If I'm understanding what you meant, I tried putting the style we use in the extensions folder but the extension still didn't work.

Re: [3.2][RC] Thanks for posts (and optional Tapatalk integration)

Posted: Mon Jun 18, 2018 6:23 am
by Naguissa
GanstaZ wrote:
Sun Jun 17, 2018 10:19 pm
You can't see buttons or whatever there may be if you don't have custom theme you are using in extension style folder.
gossipgarden wrote:
Mon Jun 18, 2018 1:49 am
GanstaZ wrote:
Sun Jun 17, 2018 10:19 pm
You can't see buttons or whatever there may be if you don't have custom theme you are using in extension style folder.
If I'm understanding what you meant, I tried putting the style we use in the extensions folder but the extension still didn't work.



Hello,

@GanstaZ had a good idea....


No, you don't need to change any name on extension. Please, reupload extension files to revert any change.

The idea is that maybe your custom style (template) is skipping some events.

I've done some more tests:

http://thegossipgarden.com/app.php/toplist - Empty or disabled. Well, it is for sure empty.
http://thegossipgarden.com/thankslist - ERROR: This is caused because renaming extension files; reverting to original files should work (but empty again)
http://thegossipgarden.com/thankslist/givens/53/true - Same as previous case.


Is there any chance to be able to choose between styles? I once had an extension called "Quick style changer" with 3 styles, but removed it because original phpBB style now is responsive and works OK on any device...