[BETA] [3.2] Prime Notify

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Suggested Hosts
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
Post Reply
User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

[BETA] [3.2] Prime Notify

Post by primehalo »

I've updated Prime Notify to use a proper phpBB 3.2 extension and could use some assistance testing it out. Please do not use this on a live board yet!

Extension Name: Prime Notify
Author: primehalo

Description:
Inserts the content of a post or private messages into notification e-mails for the phpBB 3.2 forum software. Options allow BBCodes to be kept or removed and notification emails to be sent after every new post or just the first new post.

Version: 1.0.0-beta9

Download:
https://www.absoluteanime.com/_phpbb-ex ... notify.zip

GitHub:
https://github.com/primehalo/primenotify

Screenshot: ACP Options
Image

Screenshot: UCP Options
Image
Last edited by primehalo on Thu Oct 03, 2019 5:12 am, edited 3 times in total.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

panhead
Registered User
Posts: 688
Joined: Sat Dec 20, 2003 8:17 pm

Re: [BETA] [3.2] Prime Notify

Post by panhead »

As I liked the previous version I will test it.

panhead
Registered User
Posts: 688
Joined: Sat Dec 20, 2003 8:17 pm

Re: [BETA] [3.2] Prime Notify

Post by panhead »

Code: Select all

The selected extension cannot be enabled, please verify the extension’s requirements.
I'm using 3.2.1, is 3.2.2 required?

User avatar
Theriddler1
Registered User
Posts: 448
Joined: Sat Aug 27, 2011 11:00 pm
Location: NL
Name: Theriddler❶
Contact:

Re: [BETA] [3.2] Prime Notify

Post by Theriddler1 »

panhead wrote:
Wed Feb 21, 2018 9:22 am

Code: Select all

The selected extension cannot be enabled, please verify the extension’s requirements.
I'm using 3.2.1, is 3.2.2 required?
Yes

see ext.php

Code: Select all

public function is_enableable()
    {
        $config = $this->container->get('config');
        return phpbb_version_compare($config['version'], '3.2.2', '>=');
    }
And composer.json

Code: Select all

 "soft-require": {
         "phpbb/phpbb": ">=3.2.2,<3.2.*@dev"
      }
It can be that the author of the extension needs a specific event which not exist in a earlier version of phpbb.
Theriddler - Moderator @ phpBB.nl | phpBBservice.nl Team-member
ImageSupport Tools | Image My Extensions | buy me a beer Image

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] [3.2] Prime Notify

Post by primehalo »

That requirement is because I had to edit several files in the phpbb/notification/ directory and wanted to make sure that the functions I had to change in those files matched exactly with your version of phpbb. I couldn't find where to download older versions of phpBB 3.2 in order to compare those files to see if any changed, but I'm pretty sure they would have changed from phpBB 3.1 since notifications were updated for phpBB 3.2.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

User avatar
3Di
Former Team Member
Posts: 14807
Joined: Mon Apr 04, 2005 11:09 pm
Location: Milan (IT) Frankfurt (DE)
Name: Marco
Contact:

Re: [BETA] [3.2] Prime Notify

Post by 3Di »

primehalo wrote:
Thu Feb 22, 2018 5:17 pm
I couldn't find where to download older versions of phpBB 3.2
Hi :) https://download.phpbb.com/pub/release/3.2/
Btw..

Code: Select all

 "soft-require": {
         "phpbb/phpbb": ">=3.2.2,<3.2.*@dev"
      }
Should be (if you mean less than 3.3.0-dev)

Code: Select all

 "soft-require": {
         "phpbb/phpbb": ">=3.2.1,<3.3.0@dev"
      }
Regards.
Please PM me only to request paid works. Thx.
Want to compensate me for my interest? Donate
My development's activity º PhpStorm's proud user
Extensions, Scripts, MOD porting, Update/Upgrades
:studio_microphone: Premium extensions @ The Studio

panhead
Registered User
Posts: 688
Joined: Sat Dec 20, 2003 8:17 pm

Re: [BETA] [3.2] Prime Notify

Post by panhead »

Then I have to wait with testing until I have upgraded my test-board

User avatar
Hippie459MN
Registered User
Posts: 922
Joined: Mon Oct 15, 2007 10:13 pm
Location: Minnesota, USA
Contact:

Re: [BETA] [3.2] Prime Notify

Post by Hippie459MN »

Awesome! I will certainly be updating my sets site and give this a go. I have been missing the heck out of this add on. Thank you.

User avatar
eunaumtenhoid
Registered User
Posts: 927
Joined: Wed Jun 03, 2009 12:46 am
Location: ????

Re: [BETA] [3.2] Prime Notify

Post by eunaumtenhoid »

nice job ty
My translations of the extensions for Brazilian Portuguese
https://github.com/phpBBTraducoes

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] [3.2] Prime Notify

Post by primehalo »

eunaumtenhoid wrote:
Sun Feb 25, 2018 12:02 pm
nice job ty
Have you been testing it out? I've tested in on my local board and my live board and haven't run into any issues yet.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

russian2
Registered User
Posts: 36
Joined: Sun Jan 14, 2018 3:37 pm

Re: [BETA] [3.2] Prime Notify

Post by russian2 »

Just installed on my live board and got the notification as expected once posted under test user. Will post if get into any issues later, thank you for the great extension!

User avatar
NAPWR
Registered User
Posts: 27
Joined: Thu May 11, 2017 5:40 am

Re: [BETA] [3.2] Prime Notify

Post by NAPWR »

Hello Primehalo,

great to find this extension,

and was wondering if this is available for 3.2.1 yet ?

I did the changes up there ^^

">=3.2.1,<3.3.0@dev"

but still see

ext.php @ line 13

class ext extends \phpbb\extension\base { public function is_enableable() { $config = $this->container->get('config'); return phpbb_version_compare($config['version'], '3.2.2', '>=');

so does this mean it is for 3.2.2 only. :ugeek:

Thanks in advance 8-)

User avatar
primehalo
Former Team Member
Posts: 2855
Joined: Fri May 06, 2005 5:58 pm
Location: Redding, CA
Contact:

Re: [BETA] [3.2] Prime Notify

Post by primehalo »

I looked over the changed files and I do believe it would work with phpBB 3.2.1 but I have not tested it. Try changing both composer.json and ext.php and see if it works.
Ken F. Innes IV
My Extensions | My MODs | My Topics | My Site: Absolute Anime
Experience the wonder of Japanese Animation!

User avatar
NAPWR
Registered User
Posts: 27
Joined: Thu May 11, 2017 5:40 am

Re: [BETA] [3.2] Prime Notify

Post by NAPWR »

primehalo wrote:
Tue Feb 27, 2018 3:14 am
I looked over the changed files and I do believe it would work with phpBB 3.2.1 but I have not tested it. Try changing both composer.json and ext.php and see if it works.
OK, do now thanks :mrgreen:

User avatar
NAPWR
Registered User
Posts: 27
Joined: Thu May 11, 2017 5:40 am

Re: [BETA] [3.2] Prime Notify

Post by NAPWR »

This is after changed EXT.php 3.2.2 to 3.2.1

then it enabled with this error

Something went wrong during the request and an exception was thrown. The changes made before the error occurred were reversed to the best of our abilities, but you should check the board for errors.

The migration "\primehalo\primenotify\migrations\version_100" is not fulfillable, missing migration "\phpbb\db\migration\data\v32x\v322".

Return to the extension list

Post Reply

Return to “Extensions in Development”