[3.2][RC] Privacy Policy

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
R3gi
Registered User
Posts: 100
Joined: Mon May 05, 2014 4:33 pm
Location: Czech Republic

Re: [3.2][RC] Privacy Policy

Post by R3gi » Sun Jul 08, 2018 6:28 pm

Čeština – Czech translation for Privacy Policy (Cookie Policy) – Github Master version 28. 6. 2018.

(The board has some retarded restriction, so I have to use third party file hosting service. Meh.)

User avatar
maxco73
Registered User
Posts: 7
Joined: Tue Jun 19, 2018 3:52 pm

Re: [3.2][RC] Privacy Policy

Post by maxco73 » Thu Jul 19, 2018 9:01 pm

Hi David, I hope you could help me...
I've tried a lot but I can't solve my problem...
I've an old forum created in 2010 a it's been updated on different version of phpbb.
actually it's based:
PHP 5.6.32
PHPBB 3.2.2
prosilver style

i've made a local copy to test the extension
I've already installed your ext site_logo

My problem is that when i activate the ext, in the ACP appear 2 TAB "extension" with the same contents.
https://drive.google.com/open?id=1lxzDo ... mQDhBIWYHJ

but if the left one works properly, if I click on the second one and select an option on the left side i get this error
https://drive.google.com/open?id=1Tr2fa ... GXyREjp87U

and even if in the UCP setting there is the module for privacy data,
https://drive.google.com/open?id=1IUTEW ... _BhZz9X9Q4

in the UCP it doesn't appear
https://drive.google.com/open?id=10NKhc ... ZpnVZddt3-

it seems that the ext with an old DB upgraded doesn't works...

Infact if I create a new forum with the same version of php/phpbb and install your ext it work fine.

How I can solve my problems?
on the new forum your extensions (privacy and site_logo) are on the same tab EXTENSION and on the left i can managed them
https://drive.google.com/open?id=1TRQ6d ... qXBS7reD4c

thanks to all can help me....
bye

janus_zonstraal
Registered User
Posts: 2528
Joined: Sat Aug 30, 2014 1:30 pm

Re: [3.2][RC] Privacy Policy

Post by janus_zonstraal » Fri Jul 20, 2018 4:34 am

The extra module (extensions) has nothing to do with the extension and can be safely removed in Module management.

Make a backup from the database before you do anything.
Sorry! My English is bat ;) !!!

User avatar
maxco73
Registered User
Posts: 7
Joined: Tue Jun 19, 2018 3:52 pm

Re: [3.2][RC] Privacy Policy

Post by maxco73 » Fri Jul 20, 2018 8:19 am

Hi janus,
it's correct that in UCP module management there is a module called "privacy data" and it's the module of this ext that I want show in UCP for the user.
one of my problems is that it doesn't appear.
I.e. if I in the UCP module management create a new module it's shown in the UCP correctly.
It's this ext that with my DB (i presume) create some conflicts.


bye

User avatar
david63
Jr. Extension Validator
Posts: 14575
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Fri Jul 20, 2018 10:14 am

I would suggest that you disable and delete data for this extension and then manually inspect and remove any ACP/UCP modules that relate to this extension (there could be some under "Extensions" and/or "Users & Groups", purge the cache and then enable the extension again.

There is a known bug in 3.2.2 about removing modules via an extension.

If you are not comfortable doing that and you want to PM me an admin login I will look at it for you.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
maxco73
Registered User
Posts: 7
Joined: Tue Jun 19, 2018 3:52 pm

Re: [3.2][RC] Privacy Policy

Post by maxco73 » Fri Jul 20, 2018 3:33 pm

hi david,
what do you mean with "manually inspect and remove any ACP/UCP modules that relate to this extension"
i've to do that in the ACP or in phpmyadmin?


I don't know if it's is related to and installation failed, because i downloaded again the forum in XAMPP and tried to install the ext but igot the same problem.. :-(

thanks
Last edited by maxco73 on Fri Jul 20, 2018 3:46 pm, edited 1 time in total.

User avatar
maxco73
Registered User
Posts: 7
Joined: Tue Jun 19, 2018 3:52 pm

Re: [3.2][RC] Privacy Policy

Post by maxco73 » Fri Jul 20, 2018 3:40 pm

But I also noticed other small differences in the PCA version.
Both forums (real and new test) are now version 3.2.2 but have different graphic aspects.
ES. in the CUSTOMIZATION tab the left side in one case I have first the style management and the other the one of the extensions.
ES: in the GENERAL tab in the real forum I do not see on the left the voice "feed settings" that in the new one is present.
ES: in the GENERAL tab the items "search engine" and "helps supporting phpbb" are reversed
etc ....

As a result of the various problems encountered with the installation I have come to the conclusion (or i'm wrong) that perhaps depends on the fact that the forum was built years ago with versions php and phpbb old and release upgrades in release, while bringing everything to the current version of phpbb 3.2.2 and php 5.6 are not the same thing as an new installation .... I was wondering if there is the possibility of (prior backup of DB and file) to reset everything remotely or create a new db, delete phpbb files, install ex novo, and then reload significant tables ( post, users, msg etc ...)is possible? having available 2 db empty on aruba, can I create a new forum as a subfolder and try what i said above? so I do not create problems for users and only in the certainty of the process to reverse the forums?

User avatar
maxco73
Registered User
Posts: 7
Joined: Tue Jun 19, 2018 3:52 pm

Re: [3.2][RC] Privacy Policy

Post by maxco73 » Fri Jul 20, 2018 3:42 pm

@David: in case you need the admin login for the ACP or phpmyadmin?
thanks

janus_zonstraal
Registered User
Posts: 2528
Joined: Sat Aug 30, 2014 1:30 pm

Re: [3.2][RC] Privacy Policy

Post by janus_zonstraal » Fri Jul 20, 2018 3:51 pm

ES. in the CUSTOMIZATION tab the left side in one case I have first the style management and the other the one of the extensions.
ES: in the GENERAL tab in the real forum I do not see on the left the voice "feed settings" that in the new one is present.
ES: in the GENERAL tab the items "search engine" and "helps supporting phpbb" are reversed
etc ....
You can change that in "module management" and can't be a problem to install the extension.
Sorry! My English is bat ;) !!!

Lord Phobos
Registered User
Posts: 491
Joined: Tue May 18, 2004 11:41 pm

Re: [3.2][RC] Privacy Policy

Post by Lord Phobos » Mon Jul 23, 2018 1:07 am

david63 wrote:
Fri Jun 01, 2018 5:18 am
Lord Phobos wrote:
Fri Jun 01, 2018 1:54 am
And, would this work with Oneall social login?
I have no idea as I do not use that extension.
It is an extension allowing users to create account via facebook api, as well to link existing users to their facebook accounts and using FB to login.
Do you think it could work... or could create a big mess?

I found oneall social login a huge improvement for my board, as it incredibly simplifies the register process (just one click needed).

Thanks in advance.

User avatar
gtsoukn
Registered User
Posts: 44
Joined: Sat Jul 07, 2012 8:36 pm
Location: Greece
Name: George
Contact:

Re: [3.2][RC] Privacy Policy

Post by gtsoukn » Mon Jul 23, 2018 11:30 am

Hi David.

An error founded when a new member tries to register.
The page .../ucp.php?mode=register is blank with no error display.
The member registration completed (it seems in ACP) and the member don't receive the activation email.

Running the forum on localhost (xampp) I have the following error (at page .../ucp.php?mode=register)
Fatal error: Call to a member function update_auto_groups() on null in E:\xampp\htdocs\phpbb32\ext\david63\privacypolicy\event\listener.php on line 281

Code: Select all

		$this->privacypolicy->update_auto_groups($event['user_id']);
Thanks.

PS.1. I'm not sure that the error is from this ext.
PS.2. Sorry for my but English.

User avatar
david63
Jr. Extension Validator
Posts: 14575
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Mon Jul 23, 2018 12:18 pm

Download the latest version - that was a bug in a previous version.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
gtsoukn
Registered User
Posts: 44
Joined: Sat Jul 07, 2012 8:36 pm
Location: Greece
Name: George
Contact:

Re: [3.2][RC] Privacy Policy

Post by gtsoukn » Mon Jul 23, 2018 12:22 pm

I have the last one.
I'll try to re-install.

User avatar
david63
Jr. Extension Validator
Posts: 14575
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Mon Jul 23, 2018 1:04 pm

gtsoukn wrote:
Mon Jul 23, 2018 12:22 pm
I'll try to re-install.
Re download it first
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Lord Phobos
Registered User
Posts: 491
Joined: Tue May 18, 2004 11:41 pm

Re: [3.2][RC] Privacy Policy

Post by Lord Phobos » Mon Jul 23, 2018 3:08 pm

Lord Phobos wrote:
Mon Jul 23, 2018 1:07 am
david63 wrote:
Fri Jun 01, 2018 5:18 am
Lord Phobos wrote:
Fri Jun 01, 2018 1:54 am
And, would this work with Oneall social login?
I have no idea as I do not use that extension.
It is an extension allowing users to create account via facebook api, as well to link existing users to their facebook accounts and using FB to login.
Do you think it could work... or could create a big mess?

I found oneall social login a huge improvement for my board, as it incredibly simplifies the register process (just one click needed).

Thanks in advance.
In the ACP panel of this extension, there is an option to redirect the user (after he succesfully logs in with a social netowrk via oneall) to a specific url.
Could this simple thing make possibile to use both oneall social login and your ext together, redirecting each user to a url after logging?

Thanks in advance.

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: BigRed01, Hartenheer, Hippie459MN, KlausiMaus, panhead, v12mike and 30 guests