[3.2][RC] Privacy Policy

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Ideas Centre
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
bill1980
Registered User
Posts: 127
Joined: Wed Jan 25, 2012 6:27 pm

Re: [3.2][RC] Privacy Policy

Post by bill1980 » Mon May 21, 2018 8:42 pm

GanstaZ wrote:
Mon May 21, 2018 8:20 pm
Upload the unzipped files to [board root]/ext/david63/privacypolicy and enable it in the ACP
Thanks



Couldnt unzip the file in the directory so unzipped it on my computer
/httpdocs/forum/ext/david63-privacypolicy-3.2

Also tried renaming it to
/httpdocs/forum/ext/david63/privacypolicy

Still not showing in ACP

janus_zonstraal
Registered User
Posts: 2669
Joined: Sat Aug 30, 2014 1:30 pm

Re: [3.2][RC] Privacy Policy

Post by janus_zonstraal » Mon May 21, 2018 9:01 pm

Are you sure you have forum/ext/david63/privacypolicy/adm/
Sorry! My English is bat ;) !!!

bill1980
Registered User
Posts: 127
Joined: Wed Jan 25, 2012 6:27 pm

Re: [3.2][RC] Privacy Policy

Post by bill1980 » Mon May 21, 2018 9:12 pm

Im definitely in /httpdocs/forum/ext

I upload the extension so I get

/httpdocs/forum/ext/david63-privacypolicy-3.2 + all the sub folders



Tried renaming to David63/privacypolicy but im obviously not doing that right.

Sorry to be a nuisance

janus_zonstraal
Registered User
Posts: 2669
Joined: Sat Aug 30, 2014 1:30 pm

Re: [3.2][RC] Privacy Policy

Post by janus_zonstraal » Mon May 21, 2018 9:17 pm

Can you post a screen print from the directory in your ftp program?
David63
Now you write a capital letter "D" ?
Sorry! My English is bat ;) !!!

bill1980
Registered User
Posts: 127
Joined: Wed Jan 25, 2012 6:27 pm

Re: [3.2][RC] Privacy Policy

Post by bill1980 » Mon May 21, 2018 9:24 pm


User avatar
</Solidjeuh>
Registered User
Posts: 1020
Joined: Tue Mar 29, 2016 3:45 am
Location: Aalst (Belgium)
Name: Andy Dm
Contact:

Re: [3.2][RC] Privacy Policy

Post by </Solidjeuh> » Mon May 21, 2018 11:25 pm

bill1980 wrote:
Mon May 21, 2018 9:24 pm
https://s7.postimg.cc/7zztfgpej/Untitled.png

Sorry, having a bad day :?
" ext/david63/privacypolicy " NOT " David63/privacypolicy "

See the first post:

Image
We offer fun HTML5 games for young and old.
Register a free account & enjoy all functions!
Save your score, challenge other members or play along with our tournaments.


~~~ https://www.solidjeuh.be ~~~

sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

Re: [3.2][RC] Privacy Policy

Post by sotis » Tue May 22, 2018 4:03 am

david63 wrote:
Mon May 21, 2018 8:37 pm
I have no idea how Facebook works but it may be that it is the same as the bot issue
Do you have a fix for that or you are still working on it for the next release?

Oh, I am sory. I saw you answered that.

User avatar
david63
Jr. Extension Validator
Posts: 14747
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Tue May 22, 2018 7:22 am

scheccia wrote:
Mon May 21, 2018 8:11 pm
I have problem with Bot
GET /privacypolicy HTTP/1.1" 302 31 "-" "Mediapartners-Google" "-" | www.acquariofiliafacile. it | [US]
66.XXX.XX.XXX- - [21/May/2018:21:30:43 +0200] "GET /mostraci-il-tuo-acquario-e-non-solo-con-le-foto-f6/la-situazione-attuale-t9405-s10.html HTTP/1.1" 302 31 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
it's possibleexclude bots from forced acceptance?
I am not seeing any problems with Bots accessing my site. Is this Bot in your Bots table of your board? If not I suggest that you add it and see if the error stops.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
david63
Jr. Extension Validator
Posts: 14747
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Tue May 22, 2018 7:25 am

sotis wrote:
Mon May 21, 2018 5:16 pm
I can not share posts on Facebook and cannot fetch links as Google on Search Console with extension enabled.
The links are redirected to ./app.php/privacypolicy

There is the result on Fecabook Sharing Debugger:

Fetched URL https://www.kaminata.net/forum/viewtopi ... 06#p927906
Canonical URL https://www.kaminata.net/forum/app.php/privacypolicy

Redirect Path
Input URL https://www.kaminata.net/forum/viewtopi ... 06#p927906
302 HTTP Redirect https://www.kaminata.net/forum/app.php/privacypolicy
As I said before I know nothing at all about how Facebook works (and long may it continue that way :evil: ). Can I have a link to where this Facebook link is coming from - I might be able to see something
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

scheccia
Registered User
Posts: 35
Joined: Fri Feb 10, 2017 8:16 am

Re: [3.2][RC] Privacy Policy

Post by scheccia » Tue May 22, 2018 7:38 am

david63 wrote:
Tue May 22, 2018 7:22 am
scheccia wrote:
Mon May 21, 2018 8:11 pm
I have problem with Bot
GET /privacypolicy HTTP/1.1" 302 31 "-" "Mediapartners-Google" "-" | www.acquariofiliafacile. it | [US]
66.XXX.XX.XXX- - [21/May/2018:21:30:43 +0200] "GET /mostraci-il-tuo-acquario-e-non-solo-con-le-foto-f6/la-situazione-attuale-t9405-s10.html HTTP/1.1" 302 31 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
it's possibleexclude bots from forced acceptance?
I am not seeing any problems with Bots accessing my site. Is this Bot in your Bots table of your board? If not I suggest that you add it and see if the error stops.
yes, i enable "Force all users on this board to accept the GDPR." and the bot are redirected.
I solved this problem editing listener.php

Code: Select all

if ($this->config['privacy_policy_enable'] && $this->config['privacy_policy_force'] && $this->user->data['user_accept_date'] == 0 && $this->user->data['user_id'] != ANONYMOUS)
adding ->

Code: Select all

&& !$this->user->data['is_bot']
in this way

Code: Select all

if ($this->config['privacy_policy_enable'] && $this->config['privacy_policy_force'] && $this->user->data['user_accept_date'] == 0 && $this->user->data['user_id'] != ANONYMOUS && !$this->user->data['is_bot'])

User avatar
david63
Jr. Extension Validator
Posts: 14747
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Tue May 22, 2018 7:49 am

That is effectively what I had put in as a fix - thanks for confirming that it works.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

sotis
Registered User
Posts: 294
Joined: Tue Oct 17, 2006 4:56 pm
Location: Bulgaria
Contact:

Re: [3.2][RC] Privacy Policy

Post by sotis » Tue May 22, 2018 9:19 am

This fix works for me either. Thank you guys.

italy70
Registered User
Posts: 157
Joined: Sun Dec 04, 2011 7:48 pm
Contact:

Re: [3.2][RC] Privacy Policy

Post by italy70 » Tue May 22, 2018 9:41 am

Hello,
I installed everything without any problem (at least I hope).
I have problems with cpa translation. I do not understand why you have created multiple files of the same name as you can see from the image. Explain me gently where I'm wrong?
[IMG] http://i65.tinypic.com/2cn9gkl.png [/ IMG]

italy70
Registered User
Posts: 157
Joined: Sun Dec 04, 2011 7:48 pm
Contact:

Re: [3.2][RC] Privacy Policy

Post by italy70 » Tue May 22, 2018 9:41 am

italy70 wrote:
Tue May 22, 2018 9:41 am
Hello,
I installed everything without any problem (at least I hope).
I have problems with cpa translation. I do not understand why you have created multiple files of the same name as you can see from the image. Explain me gently where I'm wrong?
Image

User avatar
david63
Jr. Extension Validator
Posts: 14747
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Tue May 22, 2018 10:17 am

When you create a translation there is a text box at the top with the policy name pre filled in (Cookie Policy) which you can/should change to be in your own language. The only way that you could change it is by editing the database as I have not built in an editing procedure for that field.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: Toxyy and 24 guests