[3.2][RC] Privacy Policy

A place for Extension Authors to post and receive feedback on Extensions still in development. No Extensions within this forum should be used within a live environment!
Scam Warning
Forum rules
READ: phpBB.com Board-Wide Rules and Regulations

IMPORTANT: Extensions Development rules

IMPORTANT FOR NEEDED EVENTS!!!
If you need an event for your extension please read this for the steps to follow to request the event(s)
User avatar
david63
Jr. Extension Validator
Posts: 14893
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Mon Jun 11, 2018 9:15 am

KinGWoK wrote:
Fri Jun 08, 2018 7:26 pm
I'm having some issues with this ext.

A lot of my forum users can't login anymore, even when they have accepted the cookie privacy option, that is even showing in the list in de acp.
Some of them use a link in a email that seems to be the work a round for them, right now,.

What can I do to help my users out, thy tried removing the cookies in there browser, tried remove te cookie true the forum link...???

Anyone having a idea about this ? so I can help my users out ???.......
I cannot reproduce this behaviour using Firefox or Chrome.
HiFiKabin wrote:
Sat Jun 09, 2018 9:36 am
Have you tried using prosilver as the 'guest' style? That would help rule the style in or out as a factor.
I need more precise information as to how these users are trying to access your board, such as which browser, which browser version, what type of device are they using
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
david63
Jr. Extension Validator
Posts: 14893
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Mon Jun 11, 2018 9:16 am

Nienke1973 wrote:
Sun Jun 10, 2018 5:00 pm
Hi David,

Can you tell me the files i need to overwrite to only let the Bot's index my page at the right way without getting stuck on the accept privacy.
RC5 is working without other problems on a live board en I don't want to push the policy again, there is already a loss in users.
RC5 i also translated many things to dutch, if there is a way to only copy the nescesary files that would be great.

best regards Nienke
The update instructions are listed with each update announcement
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Lor@n
Registered User
Posts: 31
Joined: Fri Nov 11, 2016 1:25 am

Re: [3.2][RC] Privacy Policy

Post by Lor@n » Mon Jun 11, 2018 12:57 pm

david63 wrote:
Sun Jun 10, 2018 6:41 am
Daveo16 wrote:
Sat Jun 09, 2018 11:48 pm
Will this work with phpBB 3.2.1 ?
No
It work fine on 3.2.2.


Why would not it work on 3.2.1?

User avatar
david63
Jr. Extension Validator
Posts: 14893
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Mon Jun 11, 2018 1:23 pm

Lor@n wrote:
Mon Jun 11, 2018 12:57 pm
Why would not it work on 3.2.1?
Because I make my extensions for current versions
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Nienke1973
Registered User
Posts: 18
Joined: Sat Feb 17, 2018 2:39 pm

Re: [3.2][RC] Privacy Policy

Post by Nienke1973 » Tue Jun 12, 2018 3:37 pm

Lor@n wrote:
Mon Jun 11, 2018 12:57 pm
david63 wrote:
Sun Jun 10, 2018 6:41 am
Daveo16 wrote:
Sat Jun 09, 2018 11:48 pm
Will this work with phpBB 3.2.1 ?
No
It work fine on 3.2.2.


Why would not it work on 3.2.1?

I'm running 3.2.1 and the Milk theme, and Davids RC5 with my bot problem as described. The rest is really great but did use a external cookies banner.

Nienke1973
Registered User
Posts: 18
Joined: Sat Feb 17, 2018 2:39 pm

Re: [3.2][RC] Privacy Policy

Post by Nienke1973 » Tue Jun 12, 2018 3:40 pm

david63 wrote:
Mon Jun 11, 2018 9:16 am
Nienke1973 wrote:
Sun Jun 10, 2018 5:00 pm
Hi David,

Can you tell me the files i need to overwrite to only let the Bot's index my page at the right way without getting stuck on the accept privacy.
RC5 is working without other problems on a live board en I don't want to push the policy again, there is already a loss in users.
RC5 i also translated many things to dutch, if there is a way to only copy the nescesary files that would be great.

best regards Nienke
The update instructions are listed with each update announcement
Ok thanks for your advice, I will try to translate it again and try it on my testboard

Lor@n
Registered User
Posts: 31
Joined: Fri Nov 11, 2016 1:25 am

Re: [3.2][RC] Privacy Policy

Post by Lor@n » Tue Jun 12, 2018 9:45 pm

Hello. On the registration page, when the future member clicks submit, I have a 500 error.
No problem if the extension is disabled

Here is the apache log

Code: Select all

[Tue Jun 12 23:39:27.667137 2018] [fcgid:warn] [pid 14664:tid 139915697989376] [client 86.248.36.152:39886] mod_fcgid: stderr: PHP Fatal error:  Uncaught Error: Call to a member function update_auto_groups() on null in /home/bmwserie/domains/bmw-serie3.com/public_html/forum_test/ext/david63/privacypolicy/event/listener.php:281, referer: https://www.bmw-serie3.com/forum_test/ucp.php?mode=register
[Tue Jun 12 23:39:27.667220 2018] [fcgid:warn] [pid 14664:tid 139915697989376] [client 86.248.36.152:39886] mod_fcgid: stderr: Stack trace:, referer: https://www.bmw-serie3.com/forum_test/ucp.php?mode=register
[Tue Jun 12 23:39:27.667232 2018] [fcgid:warn] [pid 14664:tid 139915697989376] [client 86.248.36.152:39886] mod_fcgid: stderr: #0 [internal function]: david63\\privacypolicy\\event\\listener->update_auto_groups(Object(phpbb\\event\\data), 'core.user_add_a...', Object(phpbb\\event\\dispatcher)), referer: https://www.bmw-serie3.com/forum_test/ucp.php?mode=register
[Tue Jun 12 23:39:27.667242 2018] [fcgid:warn] [pid 14664:tid 139915697989376] [client 86.248.36.152:39886] mod_fcgid: stderr: #1 /home/bmwserie/domains/bmw-serie3.com/public_html/forum_test/vendor/symfony/event-dispatcher/EventDispatcher.php(184): call_user_func(Array, Object(phpbb\\event\\data), 'core.user_add_a...', Object(phpbb\\event\\dispatcher)), referer: https://www.bmw-serie3.com/forum_test/ucp.php?mode=register
[Tue Jun 12 23:39:27.667253 2018] [fcgid:warn] [pid 14664:tid 139915697989376] [client 86.248.36.152:39886] mod_fcgid: stderr: #2 /home/bmwserie/domains/bmw-serie3.com/public_html/forum_test/vendor/symfony/event-dispatcher/EventDispatcher.php(46): Symfony\\Component\\EventDispatcher\\EventDispatcher->doDispatch(Array, 'core.user_add_a...', Object(phpbb\\event\\data)), referer: https://www.bmw-serie3.com/forum_test/ucp.php?mode=register
[Tue Jun 12 23:39:27.667289 2018] [fcgid:warn] [pid 14664:tid 139915697989376] [client 86.248.36.152:39886] mod_fcgid: stderr: #3 /home/bmwserie/domains/bmw-serie3.com/public_html/forum_test/phpbb/event/dispatcher.php(62): Symfony\\Component\\EventDispatcher\\EventDispatcher->dispatch('core.user_add_a...', Object(phpbb\\event\\data)), referer: https://www.bmw-serie3.com/forum_test/ucp.php?mode=register
[Tue Jun 12 23:39:27.667301 2018] [fcgid:warn] [pid 14664:tid 139915697989376] [client 86.248.36.152:39886] mod_fcgid: stderr:  in /home/bmwserie/domains/bmw-serie3.com/public_html/forum_test/ext/david63/privacypolicy/event/listener.php on line 281, referer: https://www.bmw-serie3.com/forum_test/ucp.php?mode=register
Phpbb3. 2
Mysql 5.7

User avatar
david63
Jr. Extension Validator
Posts: 14893
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Wed Jun 13, 2018 6:48 am

Lor@n wrote:
Tue Jun 12, 2018 9:45 pm
On the registration page, when the future member clicks submit, I have a 500 error.
Thanks - fix done
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

Lor@n
Registered User
Posts: 31
Joined: Fri Nov 11, 2016 1:25 am

Re: [3.2][RC] Privacy Policy

Post by Lor@n » Wed Jun 13, 2018 9:51 am

Wahou great !!

It Work fine

Explode!
Registered User
Posts: 47
Joined: Mon Nov 26, 2007 10:06 am

Re: [3.2][RC] Privacy Policy

Post by Explode! » Fri Jun 15, 2018 9:44 am

Seems to be working perfectly, great work. 8-)

User avatar
david63
Jr. Extension Validator
Posts: 14893
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Fri Jun 15, 2018 9:59 am

Explode! wrote:
Fri Jun 15, 2018 9:44 am
Seems to be working perfectly, great work. 8-)
Thank you
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

v12mike
Registered User
Posts: 260
Joined: Thu Jul 09, 2015 5:03 pm

Re: [3.2][RC] Privacy Policy

Post by v12mike » Fri Jun 15, 2018 11:14 am

Regarding the previous reports of issues with bots, I found that following the installation of this extension, the Google indexing on my sites has dropped to near zero, accompanied by Google search analytics.

I found that there is a bug in the extension:

In listener.php at line 290, the test && !$this->user->data['is_bot'] needs to be added, otherwise the bots are all redirected to the agreement page.

You can test this by putting a bot user agent string into your browser (instructions at: https://www.howtogeek.com/113439/how-to ... xtensions/) but make sure that you have cleared all site cookies, as cookies overeride the bot test.

User avatar
david63
Jr. Extension Validator
Posts: 14893
Joined: Thu Dec 19, 2002 8:08 am
Location: Lancashire, UK
Name: David Wood
Contact:

Re: [3.2][RC] Privacy Policy

Post by david63 » Fri Jun 15, 2018 11:43 am

v12mike wrote:
Fri Jun 15, 2018 11:14 am
In listener.php at line 290, the test && !$this->user->data['is_bot'] needs to be added, otherwise the bots are all redirected to the agreement page
That has been in for a while now and as I said only a few days ago anyone with a bot problem should update to the latest RC and make sure that all the bots are in the bot group.

I have been using this on my live site for a long while and have no problems with Google bot indexing my site.
David
Remember: You only know what you know and - you don't know what you don't know!
My CDB Contributions | How to install an extension
I will not be accepting translations for any of my extensions in Github - please post any translations in the appropriate topic.
No support requests via PM or email as they will be ignored

User avatar
HiFiKabin
Community Team Member
Community Team Member
Posts: 3267
Joined: Wed May 14, 2014 9:10 am
Location: Swearing at the PC, UK
Name: James
Contact:

Re: [3.2][RC] Privacy Policy

Post by HiFiKabin » Sat Jun 16, 2018 11:16 am

Thanks for the latest version David. The auto groups compatibility if brilliant.

johwin61
Registered User
Posts: 4
Joined: Tue Jun 19, 2018 9:01 pm

Re: [3.2][RC] Privacy Policy

Post by johwin61 » Tue Jun 19, 2018 9:11 pm

I have a problem with the extension. It has stopped working. Tapatalk has been updated, which I think has done something as PrivacyPolicy was running fine before. I see at the first page that the extension is not compatible with Tapatalk.

How can I get the PrivacyPolicy back in order? I have tried disabling Tapatalk with no luck.

Post Reply

Return to “Extensions in Development”

Who is online

Users browsing this forum: hydro3, Toxyy and 14 guests